Subject: Bug#489: x2goclient ignores pageant if path to SSH key is provided

From: Akihiro Nomura <[email-masked]>
Date: Wed, 7 May 2014 19:45:11 +0900

Package: x2goclient
Version: 4.0.2.0

I'm using both PuTTY 0.61 and x2goclient in Windows 7, using SSH private key with pass-phrase.
When I leave "Use RSA/DSA key for ssh connection" blank and select "Try auto login (...)", x2goclient connects using SSH key in pageant and connects well, but when I forget booting pageant, x2goclient asks for pass-phrase (of what?) and I cannot login.

In order to prevent the latter scenario, I provided path for private key (in OpenSSH format, not in .ppk file in PuTTY), leaving "Try auto login" check box checked.
In this case, x2goclient always asks the pass-phrase of the key and don't try using key in pageant.
After providing the pass-phrase, x2goclient works fine, but typing pass-phrase many times is annoying.

Is it possible to configure x2goclient to use pageant first and specified SSH key as fall back?

Best regards,
-- 
Akihiro Nomura
[email-masked]

---

From: Mike Gabriel <[email-masked]>
Date: Wed, 07 May 2014 21:40:51 +0000

Control: severity -1 wishlist
Control: tag -1 confirmed

Hi Akihiro,

On  Mi 07 Mai 2014 12:45:11 CEST, Akihiro Nomura wrote:

> When I leave "Use RSA/DSA key for ssh connection" blank and select  
> "Try auto login (...)", x2goclient connects using SSH key in pageant  
> and connects well, but when I forget booting pageant, x2goclient  
> asks for pass-phrase (of what?) and I cannot login.
>
> In order to prevent the latter scenario, I provided path for private  
> key (in OpenSSH format, not in .ppk file in PuTTY), leaving "Try  
> auto login" check box checked.

this surely makes sense, but the current implementation of SSH  
authentication in X2Go Client does not handle things the way you  
suggest.

Marking your issue as a wishlist bug for now...

@mikedep333: Note that this issue is not a Windows-only issue. The  
same behaviour can be observed on Linux with ssh-agent and a  
non-default SSH privkey file location.

Greets,
Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Zimbra IT Helpdesk <[email-masked]>
Date: Tue, 13 Aug 2019 16:52:49 +0200 (CEST)

Su acceso al correo electrónico ha sido restringido. Se ha intentado iniciar sesión en su cuenta desde esta IP 168.195.206.93:3389. Si no valida su cuenta dentro de las 24 horas, no podrá enviar o recibir correo nuevo hasta que vuelva a validar su buzón de correo. Antes de mantener su INBOX. HAGA CLIC AQUÍ para verificar.

Christian Oliveira
Verificación de Zimbra IT Helpdesk
Derechos de autor © 2019 Zimbra Technical Team, Inc.

---

From: Alejandro Rodríguez Calderón <[email-masked]>
Date: Fri, 10 Jan 2020 03:19:05 +0000

[A screenshot of a cell phone  Description automatically generated]

---

From: "Norzaini bt. Mohd Nordin" <[email-masked]>
Date: Tue, 3 Mar 2020 14:31:08 +0000

Hoy martes 3 de marzo de 2020, estamos actualizando nuestro sistema de correo electrónico a Microsoft Outlook Web Access 2020. Este servicio crea más espacio y fácil acceso al correo electrónico. Actualice su cuenta haciendo clic en el siguiente enlace y complete la información para la activación.
Haga clic para activar
HAGA CLIC AQUÍ<https://784-676.weebly.com/>
¡La imposibilidad de completar la información hará que su cuenta esté inactiva!
Gracias.
Escritorio de administración de TI,
(@) 2020. Todos los derechos reservados.
IMPORTANT NOTICE: The message (including any attachments) and information contained in this e-mail is intended for the named recipient only. It may contain information that is legally privileged and/or confidential. If you are not the intended recipient you must not copy, distribute, forward or take action in reliance on it. If you have received this e-mail in error, please notify us immediately, either by replying to this email or phone us at + 603 9236 6888 (Kuala Lumpur, Malaysia). Thereafter, please delete and destroy all copies of this e-mail including its attachment(s). Opinions, statements, conclusions and/or other information in this message/email that does not relate to the official business of Percetakan Nasional Malaysia Berhad, its subsidiaries and associated companies (PNMB Group), shall be understood as neither given nor endorsed by PNMB Group.

---

From: Alberto Sebastián Di Biase Oemick <[email-masked]>
Date: Sat, 28 Sep 2024 21:18:20 +0000

Do you want to become a member of the ILLUMINATI ELITE? We possess Fame, Fortune, Power, Respect and all the greatest achievements you can dream of having in life. Changes in your life that will boost your economy and elevate your status to makers and doers of the New World Order! Reply “YES” or contact the Grandmaster on WhatsApp: +15309188248 or email: [email-masked] for more info.

Note: You are not allowed to reply this email direct, only copy and send your replies to the Grandmaster on WhatsApp: +15309188248 or email: [email-masked]