Subject: Bug#485: X2Go issue (in src:pyhoca-cli) has been marked as closed

From: Mike Gabriel <[email-masked]>
Date: Mon, 20 Oct 2014 13:09:22 +0200 (CEST)

close #485
thanks

Hello,

we are very hopeful that X2Go issue #485 reported by you
has been resolved in the new release (0.5.0.0) of the
X2Go source project »src:pyhoca-cli«.

You can view the complete changelog entry of src:pyhoca-cli (0.5.0.0)
below, and you can use the following link to view all the code changes
between this and the last release of src:pyhoca-cli.

    http://code.x2go.org/gitweb?p=pyhoca-cli.git;a=commitdiff;h=aed661b9e375ec8abef32703bcd8f693d0eb0ff5;hp=3c27e63bc22fc2d366142f5113ddc97ff0e42ecc

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:pyhoca-cli.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:pyhoca-cli
Version: 0.5.0.0-0x2go1
Status: RELEASE
Date: Mon, 20 Oct 2014 13:08:31 +0200
Fixes: 485
Changes: 
 pyhoca-cli (0.5.0.0-0x2go1) RELEASED; urgency=low
 .
   * New upstream version (0.5.0.0):
     - Add cmdline option --broker-url. This adds X2Go Session Broker
       support to PyHoca-CLI.
     - Add cmdline option --broker-password. Masquerade broker password
       in process list (Linux/Mac only).
     - If a user name can neither be detected from the session profile, nor
       from the command line option, try the username used for the broker
       authentication.
     - When --list-profiles is invoked: Don't crash if a session profile
       backend does not rely on config files. Show the session broker URL
       if a broker session profile backend is in use.
     - Update man page with (future) broker options. Some man page fixes
       (mentioning X2Go Client where it should name PyHoca-CLI).
     - Fix description of --from-stdin option on man page. (Fixes: #485).
     - Rename LICENSE.txt to COPYING.
     - Add cmdline options --backend-<*> to enforce usage of certain
       Python X2Go backends for session profile, settings, control session,
       terminal session, etc.
   * pyhoca-cli.spec:
     + Adapt to building on openSUSE/SLES.

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Mon, 20 Oct 2014 11:10:03 +0000

This is an automatic notification regarding your Bug report
which was filed against the pyhoca-cli package:

#485: manpage doesn't match behaviour/sourcecode

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:pyhoca-cli) has been marked as closed
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Mon, 20 Oct 2014 13:09:22 +0200 (CEST)

close #485
thanks

Hello,

light+love

---

Subject: manpage doesn't match behaviour/sourcecode
From: "C. Bienmueller (KGA)" <[email-masked]>
To: [email-masked]
Date: Thu, 01 May 2014 10:52:18 +0200

Package: pyhoca-cli
Version: 0.4.0.2

The manpage (0.2.1.x from Nov 2012) says, that "pyhoca-cli --from-stdin"
expects

        username password server command

to get via stdin.

It only works (and the sourcecode around line 370 explains why) with

        username server command password

In addition, only the sourcecode tells, that the command ist set to
uppercase.

As this usage might be usefull for other cases than LDM it should be
clearified in the manpage. Thanks

System: Ubuntu Trusty, x2go installed via sourcelist entry:
deb http://ppa.launchpad.net/x2go/stable/ubuntu trusty main #x2go