X2Go Bug report logs - #471
ATTENTION @Mike#1 - serious bug in x2goserver upgrade script (debian wheezy+squeeze)

version graph

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: Stefan Baur <newsgroups.mail2@stefanbaur.de>

Date: Thu, 3 Apr 2014 06:55:02 UTC

Severity: grave

Tags: pending

Found in version 4.0.1.14

Fixed in version 4.0.1.15

Done: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>

Bug is archived. No further changes may be made.

Full log


đź”— View this message in rfc822 format

MIME-Version: 1.0
X-Mailer: MIME-tools 5.502 (Entity 5.502)
X-Loop: owner@bugs.x2go.org
From: owner@bugs.x2go.org (X2Go Bug Tracking System)
Subject: Bug#471 closed by Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
 (X2Go issue (in src:x2goserver) has been marked as closed)
Message-ID: <handler.471.c.139651779027983.notifdone@bugs.x2go.org>
References: <20140403093621.BFF7F5DB21@ymir>
X-X2go-PR-Keywords: pending
X-X2go-PR-Message: they-closed 471
X-X2go-PR-Package: x2goserver
X-X2go-PR-Source: x2goserver
Date: Thu, 03 Apr 2014 09:40:02 +0000
Content-Type: multipart/mixed; boundary="----------=_1396518002-30481-0"
[Message part 1 (text/plain, inline)]
This is an automatic notification regarding your Bug report
which was filed against the x2goserver package:

#471: ATTENTION @Mike#1 - serious bug in x2goserver upgrade script (debian wheezy+squeeze)

It has been closed by Mike Gabriel <mike.gabriel@das-netzwerkteam.de>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <mike.gabriel@das-netzwerkteam.de> by
replying to this email.


-- 
X2Go Bug Tracking System
Contact owner@bugs.x2go.org with problems
[Message part 2 (message/rfc822, inline)]
From: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
To: 471-submitter@bugs.x2go.org
Cc: control@bugs.x2go.org, 471@bugs.x2go.org
Subject: X2Go issue (in src:x2goserver) has been marked as closed
Date: Thu, 3 Apr 2014 11:36:21 +0200 (CEST)
close #471
thanks

Hello,

we are very hopeful that X2Go issue #471 reported by you
has been resolved in the new release (4.0.1.15) of the
X2Go source project »src:x2goserver«.

You can view the complete changelog entry of src:x2goserver (4.0.1.15)
below, and you can use the following link to view all the code changes
between this and the last release of src:x2goserver.

    http://code.x2go.org/gitweb?p=x2goserver.git;a=commitdiff;h=7e43e787a8ffe26a34b66dbd4dc167e4cf29f74c;hp=ed4a76ce5015ee195476d2612abc94459e552c3a

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:x2goserver.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:x2goserver
Version: 4.0.1.15-0x2go1
Status: RELEASE
Date: Thu, 03 Apr 2014 11:35:50 +0200
Fixes: 471
Changes: 
 x2goserver (4.0.1.15-0x2go1) RELEASED; urgency=low
 .
   * New upstream release (4.0.1.15):
     + Fix hanging of x2goserver init script. Cherry-pick a322d8c from master
       branch. (Fixes: #471).
     + Add COPYING (GPL-2) file to base project folder.

[Message part 3 (message/rfc822, inline)]
From: Stefan Baur <newsgroups.mail2@stefanbaur.de>
To: "x2go-dev@lists.berlios.de" <x2go-dev@lists.berlios.de>, Mike Gabriel <mike.gabriel@das-netzwerkteam.de>, submit@bugs.x2go.org
Subject: ATTENTION @Mike#1 - serious bug in x2goserver upgrade script (debian wheezy+squeeze)
Date: Thu, 03 Apr 2014 08:47:25 +0200
Package: x2goserver
Severity: grave
Version: 4.0.1.14

Hi Mike,

this is happening on

x2goserver (4.0.1.14-0x2go1+git20140402.842+squeeze.main.1)

as well.

Please help! All my machines are stuck in the upgrade process! This is
not good!

-Stefan


-------- Original-Nachricht --------
Betreff: [X2Go-User] Unable to upgrade
Datum: Wed, 2 Apr 2014 19:14:53 +0300
Von: Panayotis Katsaloulis <panayotis@panayotis.com>
An: x2go-user@lists.berlios.de

Hello all!

I have installed x2go, I can connect - everything is fine.
In the past I think there was a problem when I tried to launch a client
(as xterm session), and which I was unable to properly close, so I
forced close it.

The problem is that I am unable to upgrade through apt-get upgrade though.

Now when I try to upgrade I get this message:

Processing triggers for menu (2.1.46) ...
Setting up x2goserver (4.0.1.14-0x2go1+git20140402.842+wheezy.main.1) ...
Group x2gouser already exists.
User x2gouser already exists.
[info] Cleaning up stale X2Go sessions..

… and the screen remains like this forever.

The uname -a command produces the following result:

Linux danube 3.13-1-amd64 #1 SMP Debian 3.13.7-1 (2014-03-25) x86_64
GNU/Linux

Any help?

--
Panayotis


_______________________________________________
X2Go-User mailing list
X2Go-User@lists.berlios.de
https://lists.berlios.de/mailman/listinfo/x2go-user

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Thu Aug 13 11:48:50 2020; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.