Subject: Re: Bug#410: Segfault of _X11TransWritev in libNX_X11.so.6 with libQtGui

From: Mike Gabriel <[email-masked]>
Date: Mon, 30 Jun 2014 20:02:58 +0000

close #410
close #113
close #467
thanks

Hi Sven,

On  Mo 30 Jun 2014 15:32:14 UTC, Sven Willenberger wrote:

>> """ (quoted from above...)
>> +       # Provide means for Xinerama support in NX/X2Go sessions. This
>> +       # This also requires two post-install symlinks:
>> +       # (DESTDIR)$(NXLIBDIR)/X11/Xinerama/libNX_X11.so.6 ->
>> /usr/<libdir>/libX11.so.6
>> +       # (DESTDIR)$(NXLIBDIR)/X11/Xinerama/libNX_Xext.so.6 ->
>> /usr/<libdir>/libXext.so.6
>> """

> I went ahead and changed the PKGBUILD file (Archlinux's package
> building spec file) to include the symlinks as you pointed out (and as
> are contained as comments in the Makefile) and rebuilt the package. It
> works!! (pyQt, PySide, vlc all work now). That was the fix that was
> needed and will report this to the package maintainers.

Great that we could track this down...

@all: X2Go BTS issues #113, #410 and #467 have been identified as  
packaging issues on Archlinux. For further reference, see here:

https://bugs.archlinux.org/task/41037

Sven, thanks for your help and providing your distro-specific  
expertise on this...
Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Mon, 30 Jun 2014 20:05:02 +0000

This is an automatic notification regarding your Bug report
which was filed against the nxagent package:

#467: Segfault when using SDL_Init()

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: Re: Bug#410: Segfault of _X11TransWritev in libNX_X11.so.6 with libQtGui
From: Mike Gabriel <[email-masked]>
To: Sven Willenberger <[email-masked]>
Cc: [email-masked], [email-masked]
Date: Mon, 30 Jun 2014 20:02:58 +0000

close #410
close #113
close #467
thanks

Hi Sven,

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

Subject: Segfault when using SDL_Init()
From: [email-masked]
To: [email-masked]
Date: Sat, 29 Mar 2014 19:01:01 +0100

Package: nxagent
Version: 3.5.0.22

-- Description --

When using SDL_Init() in SDL2 I get a segfault in libNX_X11.so. This does not happen using SDL1.

OS: Manjaro Linux 64-bit (Arch Linux based)

$ x2goversion 
x2goagent: 3.5.0.22
x2goserver: 4.0.1.13
x2goserver-compat: 4.0.1.13
x2goserver-extensions: 4.0.1.13
x2goserver-fmbindings: 4.0.1.13
x2goserver-printing: 4.0.1.13
x2goserver-pyhoca: 4.0.1.13

-- GDB Backtrace --

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff4dafcb0 in _X11TransWritev () from /usr/lib/nx/X11/libNX_X11.so.6

#0  0x00007ffff4dafcb0 in _X11TransWritev () from /usr/lib/nx/X11/libNX_X11.so.6
#1  0x00007ffff4d93b8e in _XSend () from /usr/lib/nx/X11/libNX_X11.so.6
#2  0x00007ffff4d88e69 in XQueryExtension () from /usr/lib/nx/X11/libNX_X11.so.6
#3  0x00007ffff4d7eaf2 in XInitExtension () from /usr/lib/nx/X11/libNX_X11.so.6
#4  0x00007ffff50627bb in XextAddDisplay () from /usr/lib/nx/X11/libNX_Xext.so.6
#5  0x00007ffff5271ee1 in XPanoramiXQueryExtension () from /usr/lib/nx/X11/Xinerama/libXinerama.so.1
#6  0x00007ffff7b8d514 in ?? () from /usr/lib/libSDL2-2.0.so.0
#7  0x00007ffff7b906be in ?? () from /usr/lib/libSDL2-2.0.so.0
#8  0x00007ffff7b84181 in ?? () from /usr/lib/libSDL2-2.0.so.0
#9  0x00007ffff7aec5ff in ?? () from /usr/lib/libSDL2-2.0.so.0
#10 0x00000000004006bb in main () at a.c:4

-- Reproduce --

$ gcc -o a a.c -lSDL2 -I/usr/include/SDL2
$ cat a.c 
#include <SDL.h>

int main() {
    SDL_Init(SDL_INIT_EVERYTHING);

    SDL_Quit();
    return 0;
}
$./a
Segmentation fault (core dumped)