Subject: Request for patch review

From: Mike Gabriel <[email-masked]>
Date: Thu, 27 Feb 2014 15:15:13 +0000

Hi Alex,

can you please review the proposed patch in #440 [1]?

Thanks,
Mike

[1] http://bugs.x2go.org/440
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Oleksandr Shneyder <[email-masked]>
Date: Fri, 28 Feb 2014 14:23:40 +0100

Hi Mike,

it seems good to me. However I can not apply this patch on master branch:

$ git apply --check switch-to-QNetworkAccessManager.patch
error: patch failed: httpbrokerclient.cpp:93
error: httpbrokerclient.cpp: patch does not apply
error: patch failed: httpbrokerclient.h:62
error: httpbrokerclient.h: patch does not apply

please send correct patch for master branch *without* trailing
whitespaces and I'll test and apply it.

regards,
Alex

-- 
----------------------------------------------------
Oleksandr Shneyder  | Email: [email-masked]
phoca GmbH          | Tel. : 0911 - 14870374 0
Bräuhausgasse 9     | Fax. : 0911 - 14870374 9
D-82205 Gilching    | Mobil: 0163 - 49 64 461

Geschäftsführung:
Dipl.-Inf. Oleksandr Shneyder

Amtsgericht München | http://www.phoca-gmbh.de
HRB 196 658         | http://www.x2go.org
USt-IdNr.: DE281977973
----------------------------------------------------

---

From: Josh Lukens <[email-masked]>
Date: Fri, 28 Feb 2014 08:53:15 -0500

Not sure what happened, I just rebaselined and recreated the patch.  New patch attached.  Note this also includes possible fix for bug 138.

---

From: Josh Lukens <[email-masked]>
Date: Fri, 28 Feb 2014 23:05:05 -0500

One last try.  Cleaned up trailing white space, removed password from debug output, and fixed some spacing.

---

From: Josh Lukens <[email-masked]>
Date: Tue, 4 Mar 2014 22:39:40 -0500

Found a small (but important) copy and paste error introduced when I remade the origional patch.  As is session broker sessions can't be properly selected.  The attached patch against head corrects the issue.

---

From: Mike Gabriel <[email-masked]>
Date: Wed, 05 Mar 2014 07:43:31 +0000

On  Mi 05 Mär 2014 04:39:40 CET, Josh Lukens wrote:

> Found a small (but important) copy and paste error introduced when I  
> remade the origional patch.  As is session broker sessions can't be  
> properly selected.  The attached patch against head corrects the  
> issue.

Committed and pushed:
http://code.x2go.org/gitweb?p=x2goclient.git;a=commitdiff;h=040c9423c2806de3236e8008059be30aa697ef81

THANKS!
Mike
-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy: