Subject: Incorrect ssh options

From: Orion Poplawski <[email-masked]>
Date: Tue, 18 Feb 2014 20:15:33 -0700

Package: x2goclient
Version: 4.0.1.3
Tags: patch

x2goclient appears to use some ancient Debianism's for ssh options.  The
attached patch should hopefully fix, assuming the comments in bug 125263
below are correct.

https://bugzilla.redhat.com/show_bug.cgi?id=1066744
https://bugzilla.redhat.com/show_bug.cgi?id=125263

-- 
Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA/CoRA Division                    FAX: 303-415-9702
3380 Mitchell Lane                  [email-masked]
Boulder, CO 80301              http://www.cora.nwra.com
diff -up x2goclient-4.0.1.3/sshprocess.cpp.sshopt x2goclient-4.0.1.3/sshprocess.cpp
--- x2goclient-4.0.1.3/sshprocess.cpp.sshopt	2014-01-22 00:58:25.000000000 -0700
+++ x2goclient-4.0.1.3/sshprocess.cpp	2014-02-18 20:05:44.129767801 -0700
@@ -31,11 +31,7 @@
 #undef DEBUG
 // #define DEBUG
 
-#ifdef Q_OS_DARWIN
 #define KEEPALIVE_OPTION " -o ServerAliveInterval=60 "
-#else
-#define KEEPALIVE_OPTION " -o ProtocolKeepAlives=60 "
-#endif
 
 SshProcess::SshProcess(SshMasterConnection* master, int pid): QObject(0)
 {

---

From: Mike Gabriel <[email-masked]>
Date: Wed, 19 Feb 2014 15:55:51 +0000

Hi Alex,

> https://bugzilla.redhat.com/show_bug.cgi?id=125263

Please comment on the patch provided with #434 [1].

Mike

[1]  
http://bugs.x2go.org/cgi-bin/bugreport.cgi?msg=5;filename=x2goclient-sshopt.patch;att=1;bug=434
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb