X2Go Bug report logs - #426
"pidof: command not found" when resuming x2go session

version graph

Package: x2godesktopsharing; Maintainer for x2godesktopsharing is X2Go Developers <x2go-dev@lists.x2go.org>;

Reported by: Michael DePaulo <mikedep333@gmail.com>

Date: Sat, 1 Feb 2014 18:35:01 UTC

Severity: normal

Tags: pending

Found in version 3.1.1.0

Fixed in version 3.1.1.1

Done: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>

Bug is archived. No further changes may be made.

Full log


🔗 View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#426: "pidof: command not found" when resuming x2go session
Reply-To: Michael DePaulo <mikedep333@gmail.com>, 426@bugs.x2go.org
Resent-From: Michael DePaulo <mikedep333@gmail.com>
Resent-To: x2go-dev@lists.berlios.de
Resent-CC: X2Go Developers <x2go-dev@lists.berlios.de>
X-Loop: owner@bugs.x2go.org
Resent-Date: Sat, 01 Feb 2014 18:35:01 +0000
Resent-Message-ID: <handler.426.B.139127941025314@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: report 426
X-X2Go-PR-Package: x2goserver
X-X2Go-PR-Keywords: 
Received: via spool by submit@bugs.x2go.org id=B.139127941025314
          (code B); Sat, 01 Feb 2014 18:35:01 +0000
Received: (at submit) by bugs.x2go.org; 1 Feb 2014 18:30:10 +0000
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=-1.9 required=5.0 tests=BAYES_00,FREEMAIL_FROM,
	T_DKIM_INVALID autolearn=ham version=3.3.2
Received: from mail-we0-f174.google.com (mail-we0-f174.google.com [74.125.82.174])
	by ymir (Postfix) with ESMTPS id 152165DB17
	for <submit@bugs.x2go.org>; Sat,  1 Feb 2014 19:30:10 +0100 (CET)
Received: by mail-we0-f174.google.com with SMTP id x55so753980wes.5
        for <submit@bugs.x2go.org>; Sat, 01 Feb 2014 10:30:09 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=gmail.com; s=20120113;
        h=mime-version:date:message-id:subject:from:to:content-type;
        bh=z1a5dp5U+rEwLL3dYzCZIZtb2GqxMiTkNtsdwbhrKLg=;
        b=gUtNc/nDngis6TQO/oybHGdczFZx0JyLa39uEwv9EANC1tPTZagyXwRrs6ee4cNpKv
         0Hv5X6EL1sYYBHtprPcTDy1QmZEviV2qkVf1hsgVvfckN5/QPKQBaYHpgiyz2HoQIPG4
         neQ1bGqWOsEXDYyO8/6PIW6OvJhX+ZRJPh7Z6FUqQi3k2ZIiY6Lv4+l+UtqKl+gyphin
         zbOY6bzokNkOSaIv73jsd6h01lOGz99JiMFVZ1CpF6PSVQCCyxEHyNnCem5HsXKBxoIG
         K/JJXYCgdrT/LYOvsAu67jkeH12aBnfbp0iH7BTtDPxOtj0y0rX8zVRNFxlAAYiGXYpD
         Pdiw==
MIME-Version: 1.0
X-Received: by 10.194.142.142 with SMTP id rw14mr77212wjb.87.1391279409716;
 Sat, 01 Feb 2014 10:30:09 -0800 (PST)
Received: by 10.180.82.227 with HTTP; Sat, 1 Feb 2014 10:30:09 -0800 (PST)
Date: Sat, 1 Feb 2014 13:30:09 -0500
Message-ID: <CAMKht8j0tNW_jbq7riXLRMLmOVJi5EeGgvHWMTNTJkQUjJhb5Q@mail.gmail.com>
From: Michael DePaulo <mikedep333@gmail.com>
To: submit@bugs.x2go.org
Content-Type: text/plain; charset=ISO-8859-1
Package: x2goserver
Version: 4.0.1.10

I observed this error:
http://i.imgur.com/9Va5sJJ.png

/usr/bin/x2goterminate-desktopsharing: line 44: pidof: command not found

When resuming an X2Go session.

Server: x2goserver 4.0.1.10 (Fedora 20 64-bit)
Client: x2goclient 4.0.1.3 (Windows 8.1 64-bit)

Note that the other error messages will be reported in a separate bug report)

Note that on Fedora 20, pidof is located at:
/usr/sbin/pidof

/sbin/pidof would also work too because /sbin has been a symlink to
/usr/sbin on Fedora since Fedora 17's "/usr Merge":
https://fedoraproject.org/wiki/Features/UsrMove

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Thu Jul 25 18:30:30 2024; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.