Subject: Bug#422: X2Go issue (in src:x2goclient) has been marked as closed

From: Mike Gabriel <[email-masked]>
Date: Thu, 10 Apr 2014 13:52:13 +0200 (CEST)

close #422
thanks

Hello,

we are very hopeful that X2Go issue #422 reported by you
has been resolved in the new release (4.0.2.0) of the
X2Go source project »src:x2goclient«.

You can view the complete changelog entry of src:x2goclient (4.0.2.0)
below, and you can use the following link to view all the code changes
between this and the last release of src:x2goclient.

    http://code.x2go.org/gitweb?p=x2goclient.git;a=commitdiff;h=cbe900f245206ad9bd62d0fbaf226da1b3ffc44e;hp=f7cdada8c57c45ee9ea3b6c42bd680fae26d728c

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:x2goclient.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:x2goclient
Version: 4.0.2.0-0x2go1
Status: RELEASE
Date: Thu, 10 Apr 2014 13:47:56 +0200
Fixes: 138 349 422 440 446 448 453
Changes: 
 x2goclient (4.0.2.0-0x2go1) RELEASED; urgency=low
 .
   [ Oleksandr Shneyder ]
   * New upstream version (4.0.2.0):
     - Revrite SSH Classes to support libssh fix.
     - Add Class HelpDialog to show options in scroll area.
     - Fix authentication on SSH Broker with key + passphrase.
     - Set modmap timer timeout to 10 sec on Mac.
     - Fix running xmodmap if X2Go Client not started from terminal.
     - Setting keyboard modifiers with xmodmap.
     - Fix multimonitor support on Linux.
     - Display more version info. Parameters --version, --git, --changelog.
     - Don't show GUI dialog for --version, --help, etc, if started
       from terminal on linux and mac.
     - If no user in session config, display system username in pass form.
     - Check if txt/changelog and txt/git exist on config phase.
       Rename option "--git" to "--git-info".
     - Change x2goclient.nsi for nightly builds.
 .
   [ Josh Lukens ]
   * New upstream version (4.0.2.0):
     - Switch to QNetworkAccessManager. Appropriately set content type
       header to "application/x-www-form-urlencoded" for HTTP post
       requests. (Fixes: #440, #138).
     - Fix copy+paste errors in QNetworkAccessManager code.
     - Provide support for dynamic authentication IDs. This is
       a requirement for using the broker client against brokers
       that use some sort of OTP authentication mechanism.
       (Fixes: #446).
 .
   [ Mike Gabriel ]
   * New upstream version (4.0.2.0):
     - Drop create_text.sh again, implement changelog copying
       in distro build files. Implement Git history creation for
       nightly builds in build scripts.
     - Rename txt/git to txt/git-info (make it compliant with cmdline
       options).
     - Allow starting shadow sessions from the command line with
       option --hidden being enabled. (Fixes: #349).
   * debian/control:
     + Build-depend on libssh-dev (>= 0.5.4-2).
     + Bump Standards: to 3.9.5. No changes needed.
   * debian/rules:
     + Copy debian/changelog into txt/ subfolder during dh_auto_configure.
     + Create txt/git-info files for ChangeLog.git if it exists.
   * x2goclient.spec:
     + Copy ChangeLog (or debian/changelog) into txt/ subfolder during
       %setup.
     + Copy ChangeLog.gitlog (if present) into txt/ subfolder during %setup.
     + B-R (epel-7): man2html-core (same as for Fedora builds).
 .
   [ Mike DePaulo ]
   * New upstream version (4.0.2.0):
     - Decrease HelpDialog's tab width from 320 to 30
       (the width of 10 spaces.) (Fixes: #453)
     - Windows: Fix compatibility with PulseAudio 3.0 & later through
       new cookie handling. (Fixes: #422)
     - Windows: Upgrade included PulseAudio from 1.1 to 5.0.
       The 5.0 build is patched for X2Go bug #363. and available here:
         https://build.opensuse.org/project/show/home:mikedep333:branches:home:\
         mkbosmans:mingw32:pulseaudio
     - Windows: Reapply KDE on Windows's patch for Pageant support to
       libssh 0.5.5. (Fixes: #448)

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Thu, 10 Apr 2014 11:55:11 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goclient package:

#422: Windows PulseAudio 3.0 and later fail to start due to missing cookie

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:x2goclient) has been marked as closed
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Thu, 10 Apr 2014 13:52:13 +0200 (CEST)

close #422
thanks

Hello,

light+love

---

Subject: Windows PulseAudio 3.0 and later fail to start due to missing cookie
From: Michael DePaulo <[email-masked]>
To: [email-masked]
Date: Wed, 29 Jan 2014 19:32:51 -0500

Package: x2goclient
Version: 4.0.1.3

X2Go Client 4.0.1.3 for for Windows is bundled with PulseAudio 1.1. If
you replace 1.1 with 3.0 or later (2.0 was not tested), the
.pulse-cookie file is not created and therefore pulseaudio.exe either
fails to start or repeatedly restarts.

The bottom line is that sound will not work in Windows X2go Client
with these newer versions of PulseAudio.

The simple workaround is to run X2Go Client with PulseAudio 1.1 once
and then exit x2goclient. The cookie will be present even after
x2goclient is closed. Newer versions of PulseAudio can then use that
cookie.

These are my full test results for what files are generated with
different versions of PulseAudio. They were tested on windows 7 32-bit
SP1 Professional (with all important and recommended windows updates
installed.)  "mothership-7-32" is my test VM's hostname.

Note that I tested PulseAudio 1.1 (and 1 or 2 newer versions) under
Windows 8.1 64-bit Professional (with all important and recommended
windows updates installed) and the results were the same.

1.1:
Under C:\Users\mike\.x2go\pulse\ :
.pulse-cookie
.esd_auth
.pulse\
.pulse\mothership-7-32-runtime\
tmp.Hp2820\
tmp.Hp2820\config.pa

3.0
Under C:\Users\mike\.x2go\pulse\ :
.pulse\
.pulse\mothership-7-32-runtime\
tmp.Hp1572
tmp.Hp1572\config.pa
(Pulseaudio.exe does not appear to be running at all, but maybe what
happened under 4.99.2 is happening.)

4.0:
Under C:\Users\mike\.x2go\pulse\ :
.pulse\
.pulse\mothership-7-32-runtime\
.pulse\mothership-7-32-runtime\pid
tmp.Hp2656
tmp.Hp2656\config.pa
Also, windows complains that "pulseaudio.exe has stopped working". And
it does so repeatedly,.This suggests that x2goclient.exe keeps on
trying to restart pulseaudio.exe

4.99.2:
Under C:\Users\mike\.x2go\pulse\ :
.pulse\
.pulse\mothership-7-32-runtime\
.pulse\mothership-7-32-runtime\pid (keeps on being created and then
disappearing because pulseaudio.exe keeps stopping and starting)
tmp.Hp3716
tmp.Hp3716\config.pa

-Mike#2