Subject: Bug#404: X2Go issue (in src:x2goserver) has been marked as closed

From: Mike Gabriel <[email-masked]>
Date: Mon, 20 Jan 2014 14:01:31 +0100 (CET)

close #404
thanks

Hello,

we are very hopeful that X2Go issue #404 reported by you
has been resolved in the new release (4.0.0.11) of the
X2Go source project »src:x2goserver«.

You can view the complete changelog entry of src:x2goserver (4.0.0.11)
below, and you can use the following link to view all the code changes
between this and the last release of src:x2goserver.

    http://code.x2go.org/gitweb?p=x2goserver.git;a=commitdiff;h=08ea303754ff155fe0656e7aae5bc696fdcea4d4;hp=560ad5c9587051726ab08cecb4f7b08b35a16784

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:x2goserver.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:x2goserver
Version: 4.0.0.11-0x2go1
Status: RELEASE
Date: Mon, 20 Jan 2014 14:00:42 +0100
Fixes: 404
Changes: 
 x2goserver (4.0.0.11-0x2go1) RELEASED; urgency=low
 .
   * New upstream version (4.0.0.11):
     - Use perl instead of sed for search+replace in session names sanitizing.
       (Fixes: #404).

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Mon, 20 Jan 2014 13:05:02 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goserver package:

#404: Parts of the username are sanitized away in the session name.

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:x2goserver) has been marked as closed
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Mon, 20 Jan 2014 14:01:31 +0100 (CET)

close #404
thanks

Hello,

light+love

---

Subject: Parts of the username are sanitized away in the session name.
From: Klaus Ade Johnstad <[email-masked]>
To: [email-masked]
Date: Sun, 19 Jan 2014 12:52:35 +0100

Package: x2goserver
Version: 4.0.1.12
I have a user that is unable to login to a Debian Wheezy server using 
xfce4. She is able to login with ssh and with nx, but not with x2go. 
Her username is «eaan», and this is what happens when she tries to run 
x2gostartagent:
eaan@server:~$ x2gostartagent
eaan is not authorized at /usr/lib/x2go/x2gosqlitewrapper.pl line 526.
: /usr/lib/x2go/x2gosqlitewrapper insertsession 51 server 
en-51-1390073858 at /usr/lib/x2go/x2godbwrapper.pm line 320.

Notize how her username «eaan» somehow is sanitized into «en» in the 
session name, the aa's are gone.

-- 
Klaus Ade Johnstad
[email-masked]
Mobil:938 69 567

67E61D18B2C44F8A3DA35C6D849F9F5F 26FA477D