Subject: Bug#404: Parts of the username are sanitized away in the session name.

From: Klaus Ade Johnstad <[email-masked]>
Date: Sun, 19 Jan 2014 12:52:35 +0100

Package: x2goserver
Version: 4.0.1.12
I have a user that is unable to login to a Debian Wheezy server using 
xfce4. She is able to login with ssh and with nx, but not with x2go. 
Her username is «eaan», and this is what happens when she tries to run 
x2gostartagent:
eaan@server:~$ x2gostartagent
eaan is not authorized at /usr/lib/x2go/x2gosqlitewrapper.pl line 526.
: /usr/lib/x2go/x2gosqlitewrapper insertsession 51 server 
en-51-1390073858 at /usr/lib/x2go/x2godbwrapper.pm line 320.

Notize how her username «eaan» somehow is sanitized into «en» in the 
session name, the aa's are gone.

-- 
Klaus Ade Johnstad
[email-masked]
Mobil:938 69 567

67E61D18B2C44F8A3DA35C6D849F9F5F 26FA477D

---

From: Mike Gabriel <[email-masked]>
Date: Mon, 20 Jan 2014 11:47:51 +0000

Control: tag -1 moreinfo

Hi Klaus Ade,

> session name, the aa's are gone.

eaan@minobo:~$ x2gostartagent
57
296e1b399b0720fb0569aeed6678772c
31221
eaan-57-1390218373
30004
30005
30006

OK, we need to dig deeper...

X2Go Server has trouble with non-posix home directory names... Does  
her home directory have a non-7bit-ascii dir name?

Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Klaus Ade Johnstad <[email-masked]>
Date: Mon, 20 Jan 2014 12:57:11 +0100

> her home directory have a non-7bit-ascii dir name?

No, her home-dir does not contain any non-7bit-ascii.

-- 
Klaus Ade Johnstad
[email-masked]
Mobil:938 69 567

---

From: Mike Gabriel <[email-masked]>
Date: Mon, 20 Jan 2014 13:24:33 +0000

> No, her home-dir does not contain any non-7bit-ascii.

For the interest of all, Klaus Ade found the reason [1] for this weird  
issue. It is locale related. Using perl -pe instead of sed solves the  
problem.

Mike

[1] http://osdir.com/ml/bug-gnu-utils-gnu/2013-06/msg00013.html
-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy: