Subject: X2Go issue (in src:nx-libs) has been marked as closed

From: Mike Gabriel <[email-masked]>
Date: Tue, 6 May 2014 18:07:35 +0200 (CEST)

close #393
thanks

Hello,

we are very hopeful that X2Go issue #393 reported by you
has been resolved in the new release (2:3.5.0.23) of the
X2Go source project »src:nx-libs«.

You can view the complete changelog entry of src:nx-libs (2:3.5.0.23)
below, and you can use the following link to view all the code changes
between this and the last release of src:nx-libs.

    http://code.x2go.org/gitweb?p=nx-libs.git;a=commitdiff;h=4f56401ad0df9cf6380910418e283267a04bbf2e;hp=626b5dbae6b7b432d573f88abc8e3e8ae2bdba85

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:nx-libs.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:nx-libs
Version: 2:3.5.0.23-0x2go1
Status: RELEASE
Date: Tue, 06 May 2014 18:05:47 +0200
Fixes: 393 411 412 423
Changes: 
 nx-libs (2:3.5.0.23-0x2go1) RELEASED; urgency=low
 .
   [ Orion Poplawski ]
   * Add patch: 054_nx-X11_ppc64-ftbfs.full.patch. Fix FTBFS on ppc64
     architecture. (Fixes: #411).
   * Add patch: 055_nx-X11_imake-Werror-format-security.full.patch. Fix FTBFS
     of imake on current Fedora rawhide (21) which uses the compiler option
     -Werror=format-security for all builds. (Fixes: #412).
   * Add patch: 056_nx-X11-Werror-format-security.patch. Fix more
     -Werror=format-security errors that only show up on ARM builds. (Fixes:
     #423).
   * nx-libs.spec:
     - Sync nx-libs.spec in Fedora with upstream's nx-libs.spec file. (Fixes:
       #393).
 .
   [ Mike Gabriel ]
   * debian/control:
     + Build our imake against x11proto-core-dev headers.
   * nx-libs.spec:
     + Build our imake against xorg-x11-proto-devel.
 .
   [ Oleksandr Shneyder ]
   * Add patch: 205_nxagent_refresh-adsl.full.patch. Fix refresh error on RDP
     connections to Windows 2012 if speed=ADSL.

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Tue, 06 May 2014 16:10:06 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goagent package:

#393: Improvements for RPM package (Xinerama support)

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:nx-libs) has been marked as closed
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Tue, 6 May 2014 18:07:35 +0200 (CEST)

close #393
thanks

Hello,

light+love

---

Subject: Improvements for RPM package (Xinerama support)
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Date: Mon, 06 Jan 2014 15:10:51 +0000

Package: x2goagent
Severity: minor
Version: 3.5.0.22
Tag: rpm-packages patch

Some more improvements for our nx-libs.spec as suggested by Orion via  
x2go-dev.

Mike

----- Weitergeleitete Nachricht von Orion Poplawski  
<[email-masked]> -----
   Datum: Sun, 05 Jan 2014 20:46:26 -0700
     Von: Orion Poplawski <[email-masked]>
Betreff: Re: [X2Go-Dev] Bug#370: RPM package: nx-libs lacks Xinerama support
      An: Mike Gabriel <[email-masked]>
      Cc: [email-masked]

On 12/16/2013 12:37 AM, Mike Gabriel wrote:
> Hi Orion,
>
> On  Mo 16 Dez 2013 03:14:02 CET, Orion Poplawski wrote:
>
>> On 12/14/2013 02:00 PM, Mike Gabriel wrote:
>>> Package: nx-libs Severity: important Tag: rpm-package
>>>
>>> The current RPMs built from nx-libs HEAD lack Xinerama support
>>> because of missing symlinks. The links should be created like
>>> below when the package libNX_Xinerama gets installed:
>>>
>>> mike@minobo:/usr/lib64/nx/X11$ ls Xinerama/ -al insgesamt 16
>>> libNX_X11.so.6 -> /usr/lib64/libX11.so.6 libNX_Xext.so.6 ->
>>> /usr/lib64//libXext.so.6 libXinerama.so -> ../libNX_Xinerama.so
>>> libXinerama.so.1 -> ../libNX_Xinerama.so.1
>>
>> Shouldn't NX be taught to just use libXinerama.so.1 directly
>> instead?
>
> The libNX_Xinerama.so.1 is very much different from libXinerama.so
> as it retrieves its data about number of screens and screen
> resolutions from a file (and not from hardware).
>
> Scan for NX_XINERAMA_CONF in [1] for details.
>
> Mike
>
> [1]
> http://code.x2go.org/gitweb?p=nx-libs.git;a=blob;f=debian/patches/202_nx-X11_enable-xinerama.full.patch
>
>
>

Hmm, okay, I think I get more of the game being played here.  I've
implemented it differently in the Fedora spec:

In %install:

# Need for Xinerama support
ln -s -f ../../../../%{_lib}/libX11.so.6
%{buildroot}%{_libdir}/nx/X11/Xinerama/libNX_X11.so.6
ln -s -f ../../../../%{_lib}/libXext.so.6
%{buildroot}%{_libdir}/nx/X11/Xinerama/libNX_Xext.so.6

Though these probably should just get done in the Makefile.  But the
relative paths might be tricky.

and:

  Summary:        Xinerama extension to the NX Protocol
  Requires:       %{name}%{?_isa} = %{version}-%{release}
+Requires:       libX11%{?_isa}
+Requires:       libXext%{?_isa}

(%{?_isa} gets the architecture correct)

  %files -n libNX_Xinerama
  %{_libdir}/nx/X11/libNX_Xinerama.so.1*
+%{_libdir}/nx/X11/Xinerama/

No need for %pre/%post

- --
Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA/CoRA Division                    FAX: 303-415-9702
3380 Mitchell Lane                  [email-masked]
Boulder, CO 80301              http://www.cora.nwra.com

----- Ende der weitergeleiteten Nachricht -----

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb