Subject: X2Go issue (in src:x2goserver) has been marked as closed

From: Mike Gabriel <[email-masked]>
Date: Mon, 6 Jan 2014 18:28:55 +0100 (CET)

close #391
thanks

Hello,

we are very hopeful that X2Go issue #391 reported by you
has been resolved in the new release (4.0.1.11) of the
X2Go source project »src:x2goserver«.

You can view the complete changelog entry of src:x2goserver (4.0.1.11)
below, and you can use the following link to view all the code changes
between this and the last release of src:x2goserver.

    http://code.x2go.org/gitweb?p=x2goserver.git;a=commitdiff;h=c05a15086ed4a007d3627b08ae5279f31a046b4c;hp=18702f6ea834854b9777c43714d3047ab4a543f4

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:x2goserver.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:x2goserver
Version: 4.0.1.11-0x2go1
Status: RELEASE
Date: Mon, 06 Jan 2014 18:24:49 +0100
Fixes: 391
Changes: 
 x2goserver (4.0.1.11-0x2go1) RELEASED; urgency=low
 .
   * New upstream version (4.0.1.11):
     - Fix x2gofm.desktop syntax. (Fixes: #391).
     - Include all achievements from LTS release branch (as of version
       4.0.0.9).
   * x2goserver.spec:
     - Enhance requirement of desktop-file-utils, validate x2gofm.desktop
       during package build.

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Mon, 06 Jan 2014 17:30:04 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goserver package:

#391: Need trailing ; in MimeType in desktop file

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:x2goserver) has been marked as closed
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Mon, 6 Jan 2014 18:28:55 +0100 (CET)

close #391
thanks

Hello,

light+love

---

Subject: Need trailing ; in MimeType in desktop file
From: Orion Poplawski <[email-masked]>
To: [email-masked]
Date: Fri, 03 Jan 2014 13:47:38 -0700

Package: x2goserver
Version: 4.0.1.10
Tags: patch

This fixes.

You also want:

in %package fmbindings:

BuildRequires:  desktop-file-utils

Requires(post): desktop-file-utils
Requires(postun): desktop-file-utils

in %install:

desktop-file-validate %{buildroot}%{_datadir}/applications/x2gofm.desktop

-- 
Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA, Boulder/CoRA Office             FAX: 303-415-9702
3380 Mitchell Lane                       [email-masked]
Boulder, CO 80301                   http://www.nwra.com
diff -up x2goserver-4.0.1.10/x2goserver-fmbindings/share/applications/x2gofm.desktop.mimetype x2goserver-4.0.1.10/x2goserver-fmbindings/share/applications/x2gofm.desktop
--- x2goserver-4.0.1.10/x2goserver-fmbindings/share/applications/x2gofm.desktop.mimetype	2014-01-03 10:27:31.167601207 -0700
+++ x2goserver-4.0.1.10/x2goserver-fmbindings/share/applications/x2gofm.desktop	2014-01-03 10:28:15.184321072 -0700
@@ -1,7 +1,7 @@
 [Desktop Entry]
 Encoding=UTF-8
 Name=x2gofm
-MimeType=application/sshfsdisk-x2go;application/sshfscdrom-x2go;application/sshfsremovable-x2go
+MimeType=application/sshfsdisk-x2go;application/sshfscdrom-x2go;application/sshfsremovable-x2go;
 Exec=x2gofm %f
 Type=Application
 Terminal=false