Subject: Bug#384: X2Go issue (in src:x2goclient) has been marked as closed

From: Mike Gabriel <[email-masked]>
Date: Wed, 22 Jan 2014 08:57:52 +0100 (CET)

close #384
thanks

Hello,

we are very hopeful that X2Go issue #384 reported by you
has been resolved in the new release (4.0.1.3) of the
X2Go source project »src:x2goclient«.

You can view the complete changelog entry of src:x2goclient (4.0.1.3)
below, and you can use the following link to view all the code changes
between this and the last release of src:x2goclient.

    http://code.x2go.org/gitweb?p=x2goclient.git;a=commitdiff;h=63d0bbb5faa8aac57d6c5e72ce1f67dc9254b6f3;hp=f7cdada8c57c45ee9ea3b6c42bd680fae26d728c

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:x2goclient.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:x2goclient
Version: 4.0.1.3-0x2go1
Status: RELEASE
Date: Wed, 22 Jan 2014 08:56:30 +0100
Fixes: 384
Changes: 
 x2goclient (4.0.1.3-0x2go1) RELEASED; urgency=low
 .
   [ Oleksandr Shneyder ]
   * New upstream version (4.0.1.3):
     - changed keyboard settings. Supported modes: auto, none and config with
       model/layout(variant)
     - Enables forwarding (delegation) of GSSAPI credentials to the server.
     - Make GSSAPI delegation configurable.
     - Update Russian translation file.
 .
   [ Orion Poplawski ]
   * New upstream version (4.0.1.3):
     - Protect x2goplugin.html. Make it only available from the local host.
 .
   [ Mike Gabriel ]
   * New upstream version (4.0.1.3):
     - Fix scan for pulseaudio cookie file. Issue got introduced in X2Go Client
       4.0.1.2 and let pulseaudio sound setup fail completely in the Linux
       X2Go Client of that version. (Fixes: #384).
     - Minor update of the German translation file.
 .
   [ Klaus Ade Johnstad ]
   * New upstream version (4.0.1.3):
     - Update Bokmal translation file.
 .
   [ Ricardo Díaz Martín ]
   * New upstream version (4.0.1.3):
     - Update Spanish translation file.
 .
   [ Daniel Lindgren ]
   * New upstream version (4.0.1.3):
     - Update Swedish translation file.
 .
   [ Stefan Baur ]
   * New upstream version (4.0.1.3):
     - Update German translation file.
 .
   [ Martti Pitkanen ]
   * New upstream version (4.0.1.3):
     - New translation of X2Go Client to Finnish.

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Wed, 22 Jan 2014 08:00:02 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goclient package:

#384: Sound stopped working on Linux X2Goclient, or: Lookin' For Cookie In All The Wrong Places

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:x2goclient) has been marked as closed
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Wed, 22 Jan 2014 08:57:52 +0100 (CET)

close #384
thanks

Hello,

light+love

---

Subject: Sound stopped working on Linux X2Goclient, or: Lookin' For Cookie In All The Wrong Places
From: Stefan Baur <[email-masked]>
To: [email-masked]
Date: Mon, 30 Dec 2013 01:10:40 +0100

package: x2goclient
severity: important
version:4.0.1.2

With X2Goclient 4.0.1.2, sound stopped working on Linux clients. Windows 
clients were unaffected.

Manually copying over the .pulse-cookie file while the session was 
running fixed the issue.
Thanks to sunweaver (Mike#1) and dowdle on IRC, enough info was gathered 
that I could put two and two together as to what went wrong.
Initial theory was that a patch was added for pulseaudio 4 (which keeps 
the .pulse-cookie file in a different location), but said patch wouldn't 
check for the version of pulseaudio actually installed on the client.  
Debian Wheezy shipping with a 2.x release of pulseaudio, the location to 
copy the file from wouldn't exist, which would explain the behavior we'd 
seen.

Close, but no cookie. (Pun intended.)

stracing x2goclient shows this:

username@mycutelittletestmachine:~/.config/pulse$ grep -i cookie stracelog
read(7, "\0\0\0\4\300\250\0\264\0\0010\0\22MIT-MAGIC-COOKIE-1\0"..., 
4096) = 317
writev(6, [{"l\0\v\0\0\0\22\0\20\0\0\0", 12}, {"", 0}, 
{"MIT-MAGIC-COOKIE-1", 18}, {"\0\0", 2}, 
{"=[\272)\364\376\331l\327\242\365\307\302\2\17J", 16}, {"", 0}], 6) = 48
stat64("/home/username.config/pulse/cookie", 0xbfacb180) = -1 ENOENT (No 
such file or directory)
stat64("/home/username.pulse-cookie", 0xbfacb180) = -1 ENOENT (No such 
file or directory)

So while it DOES attempt to check both possible locations, it actually 
checks in /home/username.config/pulse/cookie and 
/home/username.pulse-cookie while it should check in 
/home/username/.config/pulse/cookie and /home/username/.pulse-cookie - 
the slash between username and directory is missing.

Please fix ASAP.

-Stefan
PS: If anyone actually remembers the game title the second part of the 
subject is referencing: Complimentary cookie for you!