Subject: Bug#365: Please add config option for "Eye Candy" regarding session icons

From: Stefan Baur <[email-masked]>
Date: Mon, 20 Jan 2014 18:06:17 +0100

Hi List & hi Bugwatchers,

Mike#1 and I discussed the following approach via phone today:

- x2goclient gets a new commandline option --keep-icon
- when this commandline option is set, the taskbar icon will not change 
upon successful connect (global setting)
- a new configfile option "keep-icon=true/false" will be added
- when this configfile option is set, the taskbar icon will not change 
upon successful connect (per-session setting)
- this change will be implemented for 4.0.1.3
- a config option/checkbox for it will be added with a later release.

- Stefan

---

From: Mike Gabriel <[email-masked]>
Date: Wed, 22 Jan 2014 08:08:18 +0000

On  Mo 20 Jan 2014 18:06:17 CET, Stefan Baur wrote:

> - when this commandline option is set, the taskbar icon will not  
> change upon successful connect (global setting)
> - when this configfile option is set, the taskbar icon will not  
> change upon successful connect (per-session setting)

Targetting this for X2Go Client 4.0.1.14 (and 4.0.2.0). 4.0.1.13 has  
just been released (to get the audio issue off the table).

Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Mike Gabriel <[email-masked]>
Date: Wed, 22 Jan 2014 08:15:27 +0000

> just been released (to get the audio issue off the table).

Typo, of course... targetting for 4.0.1.4 (not .14).

Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

---

From: Stefan Baur <[email-masked]>
Date: Fri, 06 Jun 2014 19:57:58 +0200

> Typo, of course... targetting for 4.0.1.4 (not .14).

I just checked as I'm wondering if 4.0.2.0 is ready to be unleashed upon
my customers, and it seems 4.0.2.0 does not understand the commandline
parameter "--keep-icon".

Is there any chance we can get that feature - keeping the generic
"Accellerated X" icon in the taskbar when --keep-icon is specified on
the command line - implemented/working in the near future?

-Stefan