Subject: Bug#353: Issue should be resolved since x2goserver 4.0.1.10

From: Mike Gabriel <[email-masked]>
Date: Sun, 15 Jun 2014 20:15:27 +0000

Control: close -1

The issue reported as bug #353 should have been resolved in X2Go  
Server 4.0.1.10.

Unfortunately, I forgot to close this bug with the fixing commit [1].

Thanks,
Mike

[1] http://code.x2go.org/gitweb?p=x2goserver.git;a=commitdiff;h=14900d5
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Sun, 15 Jun 2014 20:20:02 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goserver package:

#353: Subsequent attempts to resume a fullscreen linux session fails

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
353: http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=353
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: Issue should be resolved since x2goserver 4.0.1.10
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Cc: [email-masked]
Date: Sun, 15 Jun 2014 20:15:27 +0000

Control: close -1

Thanks,
Mike

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

Subject: Subsequent attempts to resume a fullscreen linux session fails
From: Harvey Eneman <[email-masked]>
To: [email-masked]
Date: Tue, 03 Dec 2013 23:13:48 -0800

Package: x2goserver
Version: 4.0.1.7

As of version 4.0.1.7, x2gostartagent no longer includes the geometry
field in the options file when fullscreen is used.  Unfortunately,
x2goresume-session assumes the geometry field is at position 13 and
subsequently corrupts the options file.  The attached patch modifies
x2goresume-session to avoid the corruption by detecting whether the
geometry was specified and, if not, setting an appropriate default value
and reapplying the subsequent positional assignments.

*** x2goserver-4.0.1.9.orig/x2goserver/bin/x2goresume-session	2013-11-28 07:20:50.000000000 -0800
--- x2goserver-4.0.1.9/x2goserver/bin/x2goresume-session	2013-12-03 16:03:45.000000000 -0800
***************
*** 131,136 ****
--- 131,143 ----
  KTSTR=`echo "$OPTIONS" | awk -F, {'print $12'}`
  LISTSTR=`echo "$OPTIONS" | awk -F, {'print $17'}`
  
+ XGSTR=`echo $GSTR | sed s/geometry=.*//`
+ if [ -n "$XGSTR" ]; then
+ 	GSTR="geometry="
+         RSTR=`echo "$OPTIONS" | awk -F, {'print $13'}`
+         FSTR=`echo "$OPTIONS" | awk -F, {'print $14'}`
+         LISTSTR=`echo "$OPTIONS" | awk -F, {'print $16'}`
+ fi
  
  KTSTR=`echo "$KTSTR" | sed "s/\//\\\\\\\\\//"`
  X2GO_KBD_TYPE=`echo "$X2GO_KBD_TYPE" | sed "s/\//\\\\\\\\\//"`