Subject: Bug#35: On Debian systems (wheezy/sid): Menus in Libreoffice and some other applications are not rendered properly

From: Mike Gabriel <[email-masked]>
Date: Fri, 21 Sep 2012 12:57:49 +0200

Package: x2goagent
Version: 3.5.0.15
Severity: grave

for the record: there currently is a grave bug in Debian testing  
(forwarded to freedesktop.org) that describes a rendering problem of  
GTK based application menus.
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=666564

I can reproduce these problems with latest x2goagent version, as well.

However, I am not sure, to what respect we can solve this in X2Go. As  
it is a bug in the Xserver code of Xorg, we finally may have to patch  
the solution into x2goagent sometime (or search for it by ourselves)  
but we also may not...

Because: the problem does not occur on Ubuntu precise as X2Go Server.  
It only occurs on Debian wheezy/sid as X2Go Server. This leads me to  
the conclusion that the issue has to be solved inside Debian and we  
will be happy in X2Go once that is fixed.

This bug is for documenting the progress of the X2Go team and others  
on this issue.

1. DESKTOP SESSIONS

   * Menus are rendered ok under Ubuntu precise
   * Menus are sometimes rendered ok under Debian, sometimes lines are missing

2. ROOTLESS SESSIONS

   * Libreoffice (from wheezy/sid) does not have any text in the menus at all
   * On Ubuntu precise Libreoffice looks ok...

Greets,
Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, rothenstein 5, 24214 neudorf-bornstein
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Stefan Baur <[email-masked]>
Date: Fri, 21 Sep 2012 13:17:07 +0200

>    * Libreoffice (from wheezy/sid) does not have any text in the menus

I can *not* confirm this - Libreoffice works fine here. Attaching lists 
of installed packages, sources.list and debian version for comparison. 
Feel free to request more info. Could it be a client-side X-Server issue?

dpkg -l |grep libreoff
ii  libreoffice                          1:3.5.4+dfsg-1 
          i386         office productivity suite
ii  libreoffice-base                     1:3.5.4+dfsg-1 
          i386         office productivity suite -- database
ii  libreoffice-base-core                1:3.5.4+dfsg-1 
          i386         office productivity suite -- shared library
ii  libreoffice-calc                     1:3.5.4+dfsg-1 
          i386         office productivity suite -- spreadsheet
ii  libreoffice-common                   1:3.5.4+dfsg-1 
          all          office productivity suite -- arch-independent files
ii  libreoffice-core                     1:3.5.4+dfsg-1 
          i386         office productivity suite -- arch-dependent files
ii  libreoffice-draw                     1:3.5.4+dfsg-1 
          i386         office productivity suite -- drawing
ii  libreoffice-emailmerge               1:3.5.4+dfsg-1 
          all          office productivity suite -- email mail merge
ii  libreoffice-filter-binfilter         1:3.5.4+dfsg-1 
          i386         office productivity suite -- legacy filters (e.g. 
StarOffice 5.2)
ii  libreoffice-filter-mobiledev         1:3.5.4+dfsg-1 
          all          office productivity suite -- mobile devices filters
ii  libreoffice-help-de                  1:3.5.4+dfsg-1 
          all          office productivity suite -- German help
ii  libreoffice-impress                  1:3.5.4+dfsg-1 
          i386         office productivity suite -- presentation
ii  libreoffice-java-common              1:3.5.4+dfsg-1 
          all          office productivity suite -- arch-independent 
Java support files
ii  libreoffice-l10n-de                  1:3.5.4+dfsg-1 
          all          office productivity suite -- German language package
ii  libreoffice-math                     1:3.5.4+dfsg-1 
          i386         office productivity suite -- equation editor
ii  libreoffice-officebean               1:3.5.4+dfsg-1 
          i386         office productivity suite -- Java bean
ii  libreoffice-report-builder-bin       1:3.5.4+dfsg-1 
          i386         LibreOffice extension for building database 
reports -- libraries
ii  libreoffice-style-crystal            1:3.5.4+dfsg-1 
          all          office productivity suite -- Crystal symbol style
ii  libreoffice-style-oxygen             1:3.5.4+dfsg-1 
          all          office productivity suite -- Oxygen symbol style
ii  libreoffice-writer                   1:3.5.4+dfsg-1 
          i386         office productivity suite -- word processor

dpkg -l | grep nx
rc  freenx-media 
0.7.3+teambzr104-0freenxteam1~intrepid1 i386         Remote 
desktop/application/thin-client server media support
ii  libnx-x11 
2:3.5.0.14-0+wheezy~main~312~build1     i386         nx-X11
ii  nxagent 
2:3.5.0.14-0+wheezy~main~312~build1     i386         NX agent

dpkg -l | grep x2go
ii  cups-x2go 
3.0.0.3-0~x2go1+wheezy~main~54~build1   all          X2GO printer for CUPS
ii  x2go-keyring 
2012.07.23+wheezy~main~17~build1        all          GnuPG keys of all 
X2Go developers and the X2Go archive
ii  x2goagent 
2:3.5.0.14-0+wheezy~main~312~build1     all          X2Go agent
ii  x2goserver 
3.1.1.3-0~x2go1+wheezy~main~571~build1  i386         X2Go server daemon 
scripts
ii  x2goserver-extensions 
3.1.1.3-0~x2go1+wheezy~main~571~build1  all          X2Go server daemon 
scripts (extensions)
ii  x2goserver-printing 
3.1.1.3-0~x2go1+wheezy~main~571~build1  all          X2Go server daemon 
scripts (printing)

cat /etc/apt/sources.list
# Security Updates
deb http://security.debian.org/ wheezy/updates main contrib non-free
deb-src http://security.debian.org/ wheezy/updates main contrib non-free

# Backports
#deb http://ftp.de.debian.org/debian-backports wheezy-backports main 
contrib non-free

# ClamAV etc.
#deb http://ftp.debian.org/debian wheezy-updates main contrib non-free
#deb-src http://ftp.debian.org/debian wheezy-updates main contrib non-free

# Acrobat Reader
deb http://www.deb-multimedia.org wheezy main non-free

# Wheezy
deb http://ftp.de.debian.org/debian/ wheezy main contrib non-free
deb-src http://ftp.de.debian.org/debian/ wheezy main contrib non-free

# X2go Repository
deb http://packages.x2go.org/debian wheezy main
# X2go Repository (sources)
deb-src http://packages.x2go.org/debian wheezy main

cat /etc/debian_version
wheezy/sid

This is the server side, client is using Windows 7, 32-Bit, German with 
the interim client from 
http://code.x2go.org/releases/binary-win32/x2goclient/with-old-pulseaudio-0.9.6/x2goclient-3.99.3.0.interims-pre2-setup.exe 
working in *published application mode* (which is rootless, obviously).

-Stefan

---

From: Mike Gabriel <[email-masked]>
Date: Fri, 21 Sep 2012 13:24:25 +0200

Hi Stefan,

On Fr 21 Sep 2012 13:17:07 CEST Stefan Baur wrote:

> I can *not* confirm this - Libreoffice works fine here. Attaching  
> lists of installed packages, sources.list and debian version for  
> comparison. Feel free to request more info. Could it be a  
> client-side X-Server issue?
>
> ii  libnx-x11 2:3.5.0.14-0+wheezy~main~312~build1     i386         nx-X11
> ii  nxagent 2:3.5.0.14-0+wheezy~main~312~build1     i386         NX agent

Can you please test with x2goagent 3.5.0.15? It should be available in  
the main repos.

Only test on a non-production server, please.

Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

---

From: Stefan Baur <[email-masked]>
Date: Fri, 21 Sep 2012 13:54:15 +0200

Am 21.09.2012 13:24, schrieb Mike Gabriel:
>> comparison. Feel free to request more info. Could it be a client-side
>> X-Server issue?
>>

Now:

dpkg -l | grep nx
rc  freenx-media 0.7.3+teambzr104-0freenxteam1~intrepid1 i386 Remote 
desktop/application/thin-client server media support
ii  libnx-x11 2:3.5.0.15-0+wheezy~main~328~build1 i386 nx-X11
ii  nxagent 2:3.5.0.15-0+wheezy~main~328~build1 i386 NX agent

Same result, works fine for me, I can see all the menus in LibreOffice.

Could it be that your locale setting is somehow messed up?
I'm using LANG="de_DE.UTF-8" and I'm seeing all menus in German.

locale-gen
Generating locales (this might take a while)...
   de_DE.UTF-8... done
Generation complete.

> Only test on a non-production server, please.

Wheezy isn't stable yet, so it doesn't belong on a production server 
anyways.

-Stefan