Subject: X2Go issue (in src:x2goserver) has been marked as closed

From: Mike Gabriel <[email-masked]>
Date: Thu, 28 Nov 2013 16:13:04 +0100 (CET)

close #348
thanks

Hello,

we are very hopeful that X2Go issue #348 reported by you
has been resolved in the new release (4.0.0.7) of the
X2Go source project »src:x2goserver«.

You can view the complete changelog entry of src:x2goserver (4.0.0.7)
below, and you can use the following link to view all the code changes
between this and the last release of src:x2goserver.

    http://code.x2go.org/gitweb?p=x2goserver.git;a=commitdiff;h=05feee6e69b79b66f984eb0174633a292884bd58;hp=638a08b7944463d19654d91b52e360e12bc77d4f

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:x2goserver.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:x2goserver
Version: 4.0.0.7-0x2go1
Status: RELEASE
Date: Thu, 28 Nov 2013 16:00:37 +0100
Fixes: 348
Changes: 
 x2goserver (4.0.0.7-0x2go1) RELEASED; urgency=low
 .
   * New bugfix upstream version (4.0.0.7):
     - Revert keyboard workaround for Mac OS X, as it causes other issues.
       (Fixes: #348).
   * debian/source/format:
     + Switch to format 1.0.

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Thu, 28 Nov 2013 15:18:04 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goserver package:

#348: x2goserver 4.0.1.8: screws up keyboard for Mac users

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:x2goserver) has been marked as closed
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Thu, 28 Nov 2013 16:13:04 +0100 (CET)

close #348
thanks

Hello,

light+love

---

Subject: x2goserver 4.0.1.8: screws up keyboard for Mac users
From: Anders Bruun Olsen <[email-masked]>
To: X2go bugs <[email-masked]>
Date: Tue, 26 Nov 2013 11:30:19 +0100

Package: x2goserver
Version: 4.0.1.8
Severity: critical

After upgrading to x2goserver 4.0.1.8 the keyboard is completely screwed up
in x2goclient on Mac.
Downgrading x2goserver to 4.0.1.6 fixes the problem. The problem must have
been introduced in 4.0.1.7 or 4.0.1.8. Perhaps that new keyboard layout
detection?

My setup:
Server is Ubuntu 12.04 with XFCE 4.10.
Client is OSX 10.9 and I have tested with x2goclient 4.0.0.4, 4.0.1.1 and
latest git.

-- 
Anders Bruun Olsen
It-ansvarlig
Det Danske Sprog- og Litteraturselskab
(Society for Danish Language and Literature)