Subject: Bug#348: Keyboard works with newer version of X11

From: John Pellman <[email-masked]>
Date: Tue, 1 Sep 2015 19:01:20 +0000

I was having difficulty with the keyboard working with x2go 4.0.4.0 using X11 2.6.5 on OS X (specifically, the ctrl key was not working). Changing settings in the X11 preferences did not have any effect.  Upgrading to XQuartz 2.7.7 appears to have resolved the issue for me.

John Pellman
Research Assistant
Child Mind Institute
445 Park Avenue
New York, NY 10022
e: [email-masked]<mailto:[email-masked]>
p: 646.625.4386

Facebook: facebook.com/ChildMindInstitute<https://webmail.childmind.org/owa/redir.aspx?C=O8QFNsfa-UyaNrHBP-cooVIPOsCxB9II5Mymj2nSkA-o-goowFRN8lAUMakQgZ36fwXhoima10Q.&URL=http%3a%2f%2ffacebook.com%2fChildMindInstitute> | Follow us on Twitter: twitter.com/ChildMindDotOrg<https://webmail.childmind.org/owa/redir.aspx?C=O8QFNsfa-UyaNrHBP-cooVIPOsCxB9II5Mymj2nSkA-o-goowFRN8lAUMakQgZ36fwXhoima10Q.&URL=http%3a%2f%2ftwitter.com%2fChildMindDotOrg>

This email message, including any attachments, is for the sole use of the intended recipient(s) and may contain information that is proprietary, confidential, and exempt from disclosure under applicable law. Any unauthorized review, use, disclosure, or distribution is prohibited. If you have received this email in error please notify the sender by return email and delete the original message. Please note, the recipient should check this email and any attachments for the presence of viruses. The organization accepts no liability for any damage caused by any virus transmitted by this email.

---

From: Orion Poplawski <[email-masked]>
Date: Thu, 10 Sep 2015 16:29:25 -0600

We are seeing issue with <Tab> and p not working in XFCE 4.8.0 and 4.12.1 with
OSX x2goclient 4.0.5.0.  This appears to be due to the default mapping of
<Super><Tab> and <Super>p to keyboard shortcuts by xfce and no <Super> key
defined by XQuartz.  XFCE bug is https://bugzilla.xfce.org/show_bug.cgi?id=10760

A workaround for the OSX client is to define the Super keys in ~/.Xmodmap:

keycode 63 = Super_L
keycode 71 = Super_R

or similar.

-- 
Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA, Boulder/CoRA Office             FAX: 303-415-9702
3380 Mitchell Lane                       [email-masked]
Boulder, CO 80301                   http://www.nwra.com