Subject: tempfile command not know / available (?) in Fedora

From: Mike Gabriel <[email-masked]>
Date: Mon, 25 Nov 2013 20:31:57 +0000

Package: x2goserver-xsession
Version: 4.0.1.8

Hi Orion,

on IRC we just discovered that  x2goserver-xsession/etc/Xsession uses  
a command named tempfile. On Debian, the binary is in package  
debianutils which makes it appear like a Debianism. However, I found  
evidence of the file being known to other Unices [1].

What would be the Fedora way of ,,tempfile''? Shall we change that  
upstream? Or can you provide that binary somehow in Fedora?

Mike

[1] http://nixdoc.net/man-pages/linux/man1/tempfile.1.html

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Orion Poplawski <[email-masked]>
Date: Mon, 25 Nov 2013 13:44:20 -0700

On 11/25/2013 01:31 PM, Mike Gabriel wrote:
> on IRC we just discovered that  x2goserver-xsession/etc/Xsession uses a
> command named tempfile. On Debian, the binary is in package debianutils which
> makes it appear like a Debianism. However, I found evidence of the file being
> known to other Unices [1].
>
> What would be the Fedora way of ,,tempfile''? Shall we change that upstream?
> Or can you provide that binary somehow in Fedora?
>
> Mike
>

Fedora uses "mktemp".  Does Debian have that?

-- 
Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA, Boulder/CoRA Office             FAX: 303-415-9702
3380 Mitchell Lane                       [email-masked]
Boulder, CO 80301                   http://www.nwra.com