Subject: X2Go issue (in src:x2goserver) has been marked as closed

From: Mike Gabriel <[email-masked]>
Date: Fri, 7 Jun 2013 23:08:43 +0200 (CEST)

close #32
thanks

Hello,

we are very hopeful that X2Go issue #32 reported by you
has been resolved in the new release (4.0.1.0) of the
X2Go source project »src:x2goserver«.

You can view the complete changelog entry of src:x2goserver (4.0.1.0)
below, and you can use the following link to view all the code changes
between this and the last release of src:x2goserver.

    http://code.x2go.org/gitweb?p=x2goserver.git;a=commitdiff;h=51551c467a7dca4be4fb890f3c6a29e7173d05cc;hp=498e2b7e5a8fa9216a57f2234f57f6a6fa7ed261

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:x2goserver.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:x2goserver
Version: 4.0.1.0
Status: RELEASE
Date: Fri, 07 Jun 2013 23:07:40 +0200
Fixes: 32
Changes: 
 x2goserver (4.0.1.0) RELEASED; urgency=low
 .
   * New upstream version (4.0.1.0):
     - Make x2gomountdirs / x2goumount-session UNC path aware.
     - Add support to x2gocleansessions to suspend session via state changes
       in the session DB.
     - Add support for terminating sessions via the session DB.
     - Raise the frequency of the x2gocleansessions loop to every two seconds.
     - Send SIGKILL to blocked X-Server (x2goagent) processes, if they do not
       disappear within 20secs. (Fixes: #32).

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Fri, 07 Jun 2013 21:18:06 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goserver package:

#32: x2gocleansessions not properly suspending disconnected sessions.

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:x2goserver) has been marked as closed
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Fri, 7 Jun 2013 23:08:43 +0200 (CEST)

close #32
thanks

Hello,

light+love

---

Subject: x2gocleansessions not properly suspending disconnected sessions.
From: Dick Kniep <[email-masked]>
To: [email-masked] <[email-masked]>
Date: Wed, 19 Sep 2012 13:08:36 +0200

Package: x2goclient

Severity: normal

Version 3.1.1.3

 
Sometimes a session is improperly terminated, but keeps the status 'R' this prevents the start of a new session. 

After investigating further I found x2goagent was running but could not be canceled normally. So I ran kill -9. After that the session disappeared and everything turned back to normal. So apparently there can be circumstances that x2goagent hangs.

In fact there are 2 issues here

1. x2goterminate-session should be able to handle a situation where x2goagent hangs and cannot be terminated normally

2. it is possible to get in a situation where x2goagent hangs. (I have no idea how that is done)

Met vriendelijke groet,
Dick Kniep
Lindix BV
tel. 036-5215580
mob. 06-50991858