Subject: Bug#291: eclipse: Eclipse crash when i try to open a file

From: Dev <[email-masked]>
Date: Wed, 28 Aug 2013 21:28:10 +0200

Package: eclipse
Version: 3.8.0~rc4-1
Severity: important

Dear Maintainer,

I use Debian Wheezy with x2go.

I use eclipse 3.8 from wheezy repository

I launch eclipse and i try to open a file (right click + «open»)

Eclipse crash with this error message

The program 'Eclipse' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
   (Details: serial 5058 error_code 2 request_code 147 minor_code 26)
   (Note to programmers: normally, X errors are reported asynchronously;
    that is, you will receive the error a while after causing it.
    To debug your program, run it with the --sync command line
    option to change this behavior. You can then get a meaningful
    backtrace from your debugger if you break on the gdk_x_error() 
function.)

-- System Information:
Debian Release: 7.1
   APT prefers stable-updates
   APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.10.9-xxxx-grs-ipv6-64 (SMP w/4 CPU cores)
Locale: LANG=fr_FR.UTF-8@euro, LC_CTYPE=fr_FR.UTF-8@euro (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages eclipse depends on:
ii  eclipse-jdt  3.8.0~rc4-1
ii  eclipse-pde  3.8.0~rc4-1

eclipse recommends no packages.

eclipse suggests no packages.

Versions of packages eclipse-platform depends on:
ii  ant                            1.8.2-4
ii  ant-optional                   1.8.2-4
ii  default-jre [java6-runtime]    1:1.6-47
ii  eclipse-platform-data          3.8.0~rc4-1
ii  eclipse-rcp                    3.8.0~rc4-1
ii  gconf-service                  3.2.5-1+build1
ii  java-common                    0.47
ii  libc6                          2.13-38
ii  libcommons-codec-java          1.6-1
ii  libcommons-httpclient-java     3.1-10.2
ii  libcommons-logging-java        1.1.1-9
ii  libgconf-2-4                   3.2.5-1+build1
ii  libglib2.0-0                   2.33.12+really2.32.4-5
ii  libjetty8-java                 8.1.3-4
ii  libjsch-java                   0.1.42-2
ii  liblucene2-java                2.9.4+ds1-4
ii  libservlet3.0-java             7.0.28-4
ii  multiarch-support              2.13-38
ii  openjdk-6-jre [java6-runtime]  6b27-1.12.6-1~deb7u1
ii  sat4j                          2.3.1-1

Versions of packages eclipse-platform recommends:
ii  eclipse-pde  3.8.0~rc4-1

Versions of packages eclipse-platform suggests:
ii  eclipse-jdt  3.8.0~rc4-1

Versions of packages eclipse-pde depends on:
ii  default-jre [java6-runtime]    1:1.6-47
ii  eclipse-jdt                    3.8.0~rc4-1
ii  eclipse-platform               3.8.0~rc4-1
ii  libasm3-java                   3.3.2-1
ii  openjdk-6-jre [java6-runtime]  6b27-1.12.6-1~deb7u1

eclipse-pde suggests no packages.

Versions of packages eclipse-jdt depends on:
ii  default-jre [java6-runtime]    1:1.6-47
ii  eclipse-platform               3.8.0~rc4-1
ii  junit                          3.8.2-8
ii  junit4                         4.10-3
ii  libhamcrest-java               1.2-2
ii  openjdk-6-jre [java6-runtime]  6b27-1.12.6-1~deb7u1

Versions of packages eclipse-jdt recommends:
ii  default-jdk  1:1.6-47

eclipse-jdt suggests no packages.

-- no debconf information

---

From: Rev Robert <[email-masked]>
Date: Mon, 7 Jul 2025 02:18:38 -0700

*Ihr Kredit wurde genehmigt. Benötigen Sie ihn sofort? Schreiben Sie uns
dringend eine E-Mail.*

---

From: Alex Choon Yeik NG <[email-masked]>
Date: Sat, 16 Aug 2025 00:14:05 +0000

Hallo Herr/Frau

Ich bin Leonard Valentinovich Blavatnik, ein britischer Geschäftsmann, Investor, Philanthrop und Präsident von Access Industries. Ihre E-Mail-Adresse wurde für meine Spenden ausgewählt. Ich habe 20 Prozent meines Privatvermögens für wohltätige Zwecke gespendet. Ich habe außerdem zugesagt, die restlichen 20 % in diesem Jahr an Einzelpersonen zu spenden. Ich habe beschlossen, Ihnen 3.000.000,00 € (drei Millionen Euro) zu spenden. Wenn Sie an meiner Spende interessiert sind, kontaktieren Sie mich bitte für weitere Informationen ([email-masked])

. Weitere Informationen über mich finden Sie unter folgendem Link:

https://en.m.wikipedia.org/wiki/Len_Blavatnik

Mit freundlichen Grüßen,
Präsident von Access Industries
Sir Leonard Valentinovich Blavatn