Subject: Bug#283: X2Go issue (in src:python-x2go) has been marked as closed

From: Mike Gabriel <[email-masked]>
Date: Sat, 3 Aug 2013 22:29:37 +0200 (CEST)

close #283
thanks

Hello,

we are very hopeful that X2Go issue #283 reported by you
has been resolved in the new release (0.4.0.7) of the
X2Go source project »src:python-x2go«.

You can view the complete changelog entry of src:python-x2go (0.4.0.7)
below, and you can use the following link to view all the code changes
between this and the last release of src:python-x2go.

    http://code.x2go.org/gitweb?p=python-x2go.git;a=commitdiff;h=e658471d76d88c16bd17a61fca1b62ccd5a570e8;hp=3dfee636c74643c794414db4dc44c9afe1b7356d

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:python-x2go.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:python-x2go
Version: 0.4.0.7
Status: RELEASE
Date: Sat, 03 Aug 2013 22:28:13 +0200
Fixes: 283
Changes: 
 python-x2go (0.4.0.7) RELEASED; urgency=low
 .
   [ Mike Gabriel ]
   * New upstream version (0.4.0.7):
     - Drop duplicate method in terminal backend: is_desktop_session().
     - Ignore non-registered session UUIDs in X2GoClient.clean_sessions() method.
     - Make _update_mounts in session registry cache more failsafe, this probably
       fixes an accumulation of server disconnects observed in recent version of
       Python X2Go.
     - Add some sanity checks before actually starting to add a session profile.
   * /debian/control:
     + Replace LDAP support with session brokerage support in LONG_DESCRIPTION.
 .
   [ Orion Poplawski ]
   * New upstream version (0.4.0.7):
     - Remove shbangs from python-x2go library code. (Fixes: #283).

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Sat, 03 Aug 2013 20:33:03 +0000

This is an automatic notification regarding your Bug report
which was filed against the python-x2go package:

#283: Remove shbangs from python-x2go library code

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:python-x2go) has been marked as closed
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Sat, 3 Aug 2013 22:29:37 +0200 (CEST)

close #283
thanks

Hello,

light+love

---

Subject: Remove shbangs from python-x2go library code
From: Orion Poplawski <[email-masked]>
To: [email-masked]
Date: Fri, 02 Aug 2013 15:39:11 -0600

Package: python-x2go
Tags: patch

-- 
Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA, Boulder/CoRA Office             FAX: 303-415-9702
3380 Mitchell Lane                       [email-masked]
Boulder, CO 80301                   http://www.nwra.com
>From 06dd67a05eb1771432ca1b3e85351676bff2f7c7 Mon Sep 17 00:00:00 2001
From: Orion Poplawski <[email-masked]>
Date: Fri, 2 Aug 2013 15:37:23 -0600
Subject: [PATCH] Remove #!/usr/bin/env python from library code

---
 x2go/forward.py        | 2 --
 x2go/mimebox.py        | 1 -
 x2go/mimeboxactions.py | 1 -
 x2go/printactions.py   | 1 -
 x2go/rforward.py       | 2 --
 5 files changed, 7 deletions(-)

diff --git a/x2go/forward.py b/x2go/forward.py
index 8e63bf1..387f6b7 100644
--- a/x2go/forward.py
+++ b/x2go/forward.py
@@ -1,5 +1,3 @@
-#!/usr/bin/env python
-
 # Copyright (C) 2010-2013 by Mike Gabriel <[email-masked]>
 #
 # Python X2Go is free software; you can redistribute it and/or modify
diff --git a/x2go/mimebox.py b/x2go/mimebox.py
index dcf6d32..90f51f5 100644
--- a/x2go/mimebox.py
+++ b/x2go/mimebox.py
@@ -1,4 +1,3 @@
-#!/usr/bin/env python
 # -*- coding: utf-8 -*-
 
 # Copyright (C) 2010-2013 by Mike Gabriel <[email-masked]>
diff --git a/x2go/mimeboxactions.py b/x2go/mimeboxactions.py
index 10ca5e0..7f6a1cb 100644
--- a/x2go/mimeboxactions.py
+++ b/x2go/mimeboxactions.py
@@ -1,4 +1,3 @@
-#!/usr/bin/env python
 # -*- coding: utf-8 -*-
 
 # Copyright (C) 2010-2013 by Mike Gabriel <[email-masked]>
diff --git a/x2go/printactions.py b/x2go/printactions.py
index 23a8f83..f96eec0 100644
--- a/x2go/printactions.py
+++ b/x2go/printactions.py
@@ -1,4 +1,3 @@
-#!/usr/bin/env python
 # -*- coding: utf-8 -*-
 
 # Copyright (C) 2010-2013 by Mike Gabriel <[email-masked]>
diff --git a/x2go/rforward.py b/x2go/rforward.py
index 7105134..adb780e 100644
--- a/x2go/rforward.py
+++ b/x2go/rforward.py
@@ -1,5 +1,3 @@
-#!/usr/bin/env python
-
 # Copyright (C) 2010-2013 by Mike Gabriel <[email-masked]>
 #
 # Python X2Go is free software; you can redistribute it and/or modify
-- 
1.8.3.1