Subject: Bug#278: X2Go issue (in src:x2goserver) has been marked as closed

From: Mike Gabriel <[email-masked]>
Date: Fri, 22 Nov 2013 21:59:27 +0100 (CET)

close #278
thanks

Hello,

we are very hopeful that X2Go issue #278 reported by you
has been resolved in the new release (4.0.1.7) of the
X2Go source project »src:x2goserver«.

You can view the complete changelog entry of src:x2goserver (4.0.1.7)
below, and you can use the following link to view all the code changes
between this and the last release of src:x2goserver.

    http://code.x2go.org/gitweb?p=x2goserver.git;a=commitdiff;h=447e68e8b82ea4b14e5072e57a0fbc82ef32d687;hp=2d19587c215d49048b6295d87c06c452939a1b8b

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:x2goserver.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:x2goserver
Version: 4.0.1.7
Status: RELEASE
Date: Fri, 22 Nov 2013 21:58:27 +0100
Fixes: 276 278 285 305 310 331
Changes: 
 x2goserver (4.0.1.7) RELEASED; urgency=low
 .
   [ Orion Poplawski ]
   * New upstream version (4.0.1.7):
     - Install Xsession file as executable, make Xsession.d directory location
       configurable during build process, do not create unused Xsession.options.
       (Fixes: #278).
 .
   [ Mike Gabriel ]
   * New upstream version (4.0.1.7):
     - Fine-tune x2goserver-xsession/Makefile: if /etc/X11 has Xsession.d and/or
       Xsession.options they get symlinked into /etc/x2go. Otherwise Xsession.d
       and Xsession.options are created under /etc/x2go as empty dir/file.
       (Fixes: #278).
     - Fix automatic keyboard setup (via x2gosetkeyboard) while resuming a
       session. (Fixes: #285).
     - Provide sudoers.d/x2goserver file that allows sudoed commands under
       KDE (by pertaining the env var QT_GRAPHICSSYSTEM. (Fixes: #276).
     - With PostgreSQL as session db backend, prevent the root user from
       launching sessions. Also, prevent x2gouser_root from being added as a
       PostgreSQL user. (Fixes: #310).
     - Execute DB status changes as late as possible during suspend / terminate.
     - Start/resume rootless sessions without geometry parameter. Esp. using
       X2GO_GEOMETRY=fullscreen for rootless sessions lead to an extra 1x1 px
       session window (nxagentCreateIconWindow in nxagent's Window.c).
     - Typo fix in x2goruncommand (for MATE session startup).
   * debian/control:
     + Update LONG_DESCRIPTIONS.
     + Raise Standards: to 3.9.4 (no changes needed).
     + Move xfonts-base to Recommends: field of bin:package x2goserver.
   * debian/x2goserver.init:
     + Make init script LSB compliant.
 .
   [ Helmer Teles ]
   * New upstream version (4.0.1.7):
     - Make umask that is used when mounting client-side folders via SSHFS
       configurable in x2goserver.conf. (Fixes: #331).
 .
   [ Jürgen Hötzel ]
   * New upstream version (4.0.1.7):
     - Use bash-builtin 'type' instead of to be avoided 'which'. (Fixes: #305).
 .
   [ Oleksandr Shneyder ]
   * New upstream version (4.0.0.6):
     - Fix x2goruncommand: "type -P $cmd" can create new lines in EXEC
       variable if command have the arguments wich have same names as existing
       commands, for example "rdesktop -k nl" -> "/usr/bin/rdesktop\n/usr/bin/nl".
       Now we splitting $cmd and taking only first part.

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Fri, 22 Nov 2013 21:03:05 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goserver package:

#278: x2goserver Fedora install issues

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:x2goserver) has been marked as closed
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Fri, 22 Nov 2013 21:59:27 +0100 (CET)

close #278
thanks

Hello,

light+love

---

Subject: x2goserver Fedora install issues
From: Orion Poplawski <[email-masked]>
To: [email-masked]
Date: Tue, 30 Jul 2013 12:27:56 -0600

Package: x2goserver
Version: 4.0.1.6
Tags: patch

During the x2goserver Fedora package review we had a couple issues addressed 
by the attached patches.

-- 
Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA, Boulder/CoRA Office             FAX: 303-415-9702
3380 Mitchell Lane                       [email-masked]
Boulder, CO 80301                   http://www.nwra.com
>From 6362a9a0437aaba373bd6835a0ee1c5063b32d3e Mon Sep 17 00:00:00 2001
From: Orion Poplawski <[email-masked]>
Date: Tue, 30 Jul 2013 11:44:15 -0600
Subject: [PATCH 1/3] Install Xsession executable

---
 x2goserver-xsession/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/x2goserver-xsession/Makefile b/x2goserver-xsession/Makefile
index 4fe806d..98d16cc 100755
--- a/x2goserver-xsession/Makefile
+++ b/x2goserver-xsession/Makefile
@@ -58,7 +58,7 @@ install_config:
 #       provide target dirs for X11 related symlinks
 	mkdir -p $(DESTDIR)/etc/X11/Xsession.d
 	touch $(DESTDIR)/etc/X11/Xsession.options
-	$(INSTALL_FILE) etc/Xsession                    $(DESTDIR)$(ETCDIR)/
+	$(INSTALL_PROGRAM) etc/Xsession                 $(DESTDIR)$(ETCDIR)/
 	$(INSTALL_SYMLINK) /etc/X11/Xresources          $(DESTDIR)$(ETCDIR)/
 	$(INSTALL_SYMLINK) /etc/X11/Xsession.d          $(DESTDIR)$(ETCDIR)/
 	$(INSTALL_SYMLINK) /etc/X11/Xsession.options    $(DESTDIR)$(ETCDIR)/
-- 
1.8.3.1

>From 8f7543e5856a4fd57f71569dc8ac000f11547fca Mon Sep 17 00:00:00 2001
From: Orion Poplawski <[email-masked]>
Date: Tue, 30 Jul 2013 11:45:06 -0600
Subject: [PATCH 2/3] Do not install Xsession.options, not used

---
 x2goserver-xsession/Makefile | 2 --
 1 file changed, 2 deletions(-)

diff --git a/x2goserver-xsession/Makefile b/x2goserver-xsession/Makefile
index 98d16cc..fa6c8e4 100755
--- a/x2goserver-xsession/Makefile
+++ b/x2goserver-xsession/Makefile
@@ -57,11 +57,9 @@ install_config:
 	$(INSTALL_DIR) $(DESTDIR)$(ETCDIR)
 #       provide target dirs for X11 related symlinks
 	mkdir -p $(DESTDIR)/etc/X11/Xsession.d
-	touch $(DESTDIR)/etc/X11/Xsession.options
 	$(INSTALL_PROGRAM) etc/Xsession                 $(DESTDIR)$(ETCDIR)/
 	$(INSTALL_SYMLINK) /etc/X11/Xresources          $(DESTDIR)$(ETCDIR)/
 	$(INSTALL_SYMLINK) /etc/X11/Xsession.d          $(DESTDIR)$(ETCDIR)/
-	$(INSTALL_SYMLINK) /etc/X11/Xsession.options    $(DESTDIR)$(ETCDIR)/

 install_man:
-- 
1.8.3.1

>From dff7a2ea8fb105e112c7a75a2d357160d8ca4537 Mon Sep 17 00:00:00 2001
From: Orion Poplawski <[email-masked]>
Date: Tue, 30 Jul 2013 12:23:19 -0600
Subject: [PATCH 3/3] Make Xsession.d symlink configurable

---
 x2goserver-xsession/Makefile | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/x2goserver-xsession/Makefile b/x2goserver-xsession/Makefile
index fa6c8e4..c83d36d 100755
--- a/x2goserver-xsession/Makefile
+++ b/x2goserver-xsession/Makefile
@@ -20,6 +20,8 @@ LIBDIR=$(PREFIX)/lib/x2go
 MANDIR=$(PREFIX)/share/man
 SHAREDIR=$(PREFIX)/share/x2go
 
+XSESSIONDIR ?= /etc/X11/Xsession.d
+
 #BIN_SCRIPTS=$(shell cd bin && echo *)
 #SBIN_SCRIPTS=$(shell cd sbin && echo *)
 #LIB_FILES=$(shell cd lib && echo *)
@@ -56,10 +58,9 @@ install_scripts:
 install_config:
 	$(INSTALL_DIR) $(DESTDIR)$(ETCDIR)
 #       provide target dirs for X11 related symlinks
-	mkdir -p $(DESTDIR)/etc/X11/Xsession.d
 	$(INSTALL_PROGRAM) etc/Xsession                 $(DESTDIR)$(ETCDIR)/
 	$(INSTALL_SYMLINK) /etc/X11/Xresources          $(DESTDIR)$(ETCDIR)/
-	$(INSTALL_SYMLINK) /etc/X11/Xsession.d          $(DESTDIR)$(ETCDIR)/
+	$(INSTALL_SYMLINK) $(XSESSIONDIR)               $(DESTDIR)$(ETCDIR)/Xsession.d

 install_man:
-- 
1.8.3.1