Subject: X2Go issue (in src:x2goserver) has been marked as pending for release

From: Mike Gabriel <[email-masked]>
Date: Wed, 31 Jul 2013 09:06:29 +0200 (CEST)

tag #278 pending
fixed #278 4.0.1.7
thanks

Hello,

X2Go issue #278 (src:x2goserver) reported by you has been
fixed in X2Go Git. You can see the changelog below, and you can
check the diff of the fix at:

    http://code.x2go.org/gitweb?p=x2goserver.git;a=commitdiff;h=6567318

The issue will most likely be fixed in src:x2goserver (4.0.1.7).

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
commit 6567318201544d31d380a7fabb90de87bfbdb89a
Author: Mike Gabriel <[email-masked]>
Date:   Wed Jul 31 09:06:01 2013 +0200

    Fine-tune x2goserver-xsession/Makefile: if /etc/X11 has Xsession.d and/or Xsession.options they get symlinked into /etc/x2go. Otherwise Xsession.d and Xsession.options are created under /etc/x2go as empty dir/file. (Fixes: #278).

diff --git a/debian/changelog b/debian/changelog
index ce613a0..d6b0af6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,6 +7,11 @@ x2goserver (4.0.1.7-0~x2go1) UNRELEASED; urgency=low
       (Fixes: #278).
 
   [ Mike Gabriel ]
+  * New upstream version (4.0.1.7):
+    - Fine-tune x2goserver-xsession/Makefile: if /etc/X11 has Xsession.d and/or
+      Xsession.options they get symlinked into /etc/x2go. Otherwise Xsession.d
+      and Xsession.options are created under /etc/x2go as empty dir/file.
+      (Fixes: #278).
   * /debian/control:
     - Update LONG_DESCRIPTIONS.

---

From: Orion Poplawski <[email-masked]>
Date: Wed, 27 Nov 2013 16:32:13 -0700

>       - Update LONG_DESCRIPTIONS.

XSESSIONDIR ?= /etc/X11/Xsession.d
XSESSIONOPTIONFILE ?= /etc/X11/Xsession.options

         if [ -e $(XSESSIONOPTIONFILE) ]; then $(INSTALL_SYMLINK) 
$(XSESSIONOPTIONFILE) $(DESTDIR)$(ETCDIR)/Xsession.options; else touch 
$(DESTDIR)$(ETCDIR)/Xsession.options; fi
         if [ -d $(XSESSIONDIR) ]; then $(INSTALL_SYMLINK) 
$(XSESSIONDIR) $(DESTDIR)$(ETCDIR)/Xsession.d; else $(INSTALL_DIR) 
$(DESTDIR)$(ETCDIR)/Xsession.d; fi

One unfortunate side effect of this is that 
XSESSIONDIR/XSESSIONOPTIONFILE needs to be present in the buildroot for 
these directories to get linked.

-- 
Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA/CoRA Division                    FAX: 303-415-9702
3380 Mitchell Lane                  [email-masked]
Boulder, CO 80301              http://www.cora.nwra.com

---

From: Mike Gabriel <[email-masked]>
Date: Thu, 28 Nov 2013 08:48:43 +0000

On  Do 28 Nov 2013 00:32:13 CET, Orion Poplawski wrote:

>>     Fine-tune x2goserver-xsession/Makefile: if /etc/X11 has  
>> Xsession.d and/or Xsession.options they get symlinked into  
>> /etc/x2go. Otherwise Xsession.d and Xsession.options are created  
>> under /etc/x2go as empty dir/file. (Fixes: #278).
>>
> $(XSESSIONOPTIONFILE) $(DESTDIR)$(ETCDIR)/Xsession.options; else  
> touch $(DESTDIR)$(ETCDIR)/Xsession.options; fi
> XSESSIONDIR/XSESSIONOPTIONFILE needs to be present in the buildroot  
> for these directories to get linked.

Indeed. This is not a problem with the .deb packaging logic (as I do  
not use the Makefile for creating dirs and copying files).

So, maybe we should create those folders/files during make install, if  
they do not yet exist? Or do you want to handle that via  
x2goserver.spec?

Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Orion Poplawski <[email-masked]>
Date: Fri, 29 Nov 2013 08:00:40 -0700

On 11/28/2013 01:48 AM, Mike Gabriel wrote:
> Indeed. This is not a problem with the .deb packaging logic (as I do not
> use the Makefile for creating dirs and copying files).
>
> they do not yet exist? Or do you want to handle that via x2goserver.spec?
>
> Mike

I handled it in the spec by using BuildRequires: xorg-x11-xinit.  Works 
for me.