Subject: Bug#273: X2Go issue (in src:x2goserver) has been marked as closed

From: Mike Gabriel <[email-masked]>
Date: Sun, 28 Jul 2013 02:08:13 +0200 (CEST)

close #273
thanks

Hello,

we are very hopeful that X2Go issue #273 reported by you
has been resolved in the new release (4.0.1.5) of the
X2Go source project »src:x2goserver«.

You can view the complete changelog entry of src:x2goserver (4.0.1.5)
below, and you can use the following link to view all the code changes
between this and the last release of src:x2goserver.

    http://code.x2go.org/gitweb?p=x2goserver.git;a=commitdiff;h=535f26d44121c5c8dcd7d63d5f9b6077b9a4dff5;hp=7d15fe237308213fcc4af56de7f61bc60d387eb7

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:x2goserver.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:x2goserver
Version: 4.0.1.5
Status: RELEASE
Date: Sun, 28 Jul 2013 02:06:47 +0200
Fixes: 273
Changes: 
 x2goserver (4.0.1.5) RELEASED; urgency=low
 .
   * New upstream version (4.0.1.5):
     - Do not hard-code paths to NX code in x2goruncommand anymore. Use
       x2gopath instead. (Fixes: #273).

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Sun, 28 Jul 2013 00:15:56 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goserver package:

#273: x2goruncommand uses hard-coded path to Xinerama libraries

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:x2goserver) has been marked as closed
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Sun, 28 Jul 2013 02:08:13 +0200 (CEST)

close #273
thanks

Hello,

light+love

---

Subject: Xinerama not working on RPM based distros
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Date: Wed, 24 Jul 2013 06:58:52 +0200

Package: libnx-x11
Version: 3.5.0.20

Hi Jan,

quoting from IRC...

18:27 < dlmcob> sunweaver: regarding xinerama, I installed ubuntu  
12.04 and installed x2go server.
                 using the same client (fedora 19) it works fine - so  
it seems fedora19 x2goserver
                 is to blame

[...]

23:41 < dlmcob> Also, on fedora 19 server, the packaging is incorrect  
w.r.t paths in
                 x2goruncommand (for xinerama again)
23:42 < dlmcob> There is at attempt to "override" the libXinerama.so.1  
and libXinerama.so.1.0 by
                 creating a "special" directory with these .so files
23:42 < dlmcob> (which are actually links to libNX_Xinerama.so.1 etc)
23:43 < dlmcob> On ubuntu install, these links are created in  
/usr/lib/nx/X11/Xinerama
23:43 < dlmcob> and this path is hardcoded in x2goruncommand
23:43 < dlmcob> however, in fedora install, these links (and the  
directory) are never created.
23:45 < dlmcob> creating the directory by hand and creating the links  
by hand and it's working in
                 fedora 19 client and server (with the hack mentioned  
above still in place)

Can you take a look?

Thanks,
Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb