Subject: Bug#262: Color issue with some programs GUI when used with X2GO (ok with NX)

From: Edouard Villeneuve <[email-masked]>
Date: Fri, 12 Jul 2013 08:22:13 +0200

Package: not_applicable

Hello,

We are trying to move from NX to X2Go.

One of our tools is called Questa Sim (EDA tool from Mentor Graphics).

When we used to run it from NX, no issues.

When we use it with X2Go, we have color issues:

·         What was white or yellow text on a black background, now shows as
… black text on a black background, hence not readable.

·         While we can change colors in a preferences menu, unlike in NX,
changing the text color in X2Go environment does not work

Below are two screenshots:

·         One from NX, where yellow bar and text is readable

·         One from X2Go, where this bar and text have become black (on
black background)

Thanks,

- Edouard

Edouard Villeneuve | IS Manager | PLDA Group | Cell : +33 (0) 670 409 549 |
http://www.plda.com/

---

From: Mike Gabriel <[email-masked]>
Date: Fri, 19 Jul 2013 18:08:15 +0200

reassign #262 x2goagent
thanks

Hi Alex, hi Edouard,

> ·         One from X2Go, where this bar and text have become black (on

Do you have a clue how this can happen?

There is the patch you came up with some time ago that had to do with  
font visibility:

nx-libs/debian/patches/204_nxagent_repaint-solidpict.full.patch

Any chance that this needs some more fine tuning?

@Edouard: as this only affects one special application (which seems  
non-free) getting this fixed may need your help and possibly a couple  
of hours of paid coding work. Is that feasible for you business?  
Otherwise, I do not see a chance of getting this issue fixed soon. :-(

Greets,
Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Edouard Villeneuve <[email-masked]>
Date: Mon, 22 Jul 2013 12:41:24 +0200

Hello,
The impact was too problematic so we had to uninstall X2Go and reinstall NX.
We will retry on new servers which we have to setup, hoping that this will
not reproduce on a new environment.
Regards,
- Edouard

On Fri, Jul 19, 2013 at 6:08 PM, Mike Gabriel <
[email-masked]> wrote:

> There is the patch you came up with some time ago that had to do with font
> visibility:
>
> nx-libs/debian/patches/204_**nxagent_repaint-solidpict.**full.patch
>
> non-free) getting this fixed may need your help and possibly a couple of
> hours of paid coding work. Is that feasible for you business? Otherwise, I
> do not see a chance of getting this issue fixed soon. :-(
>
> Greets,
> Mike
>
> --
>
> DAS-NETZWERKTEAM
> mail: mike.gabriel@das-netzwerkteam.**de<[email-masked]>,
> http://das-netzwerkteam.de
>
> freeBusy:
> https://mail.das-netzwerkteam.**de/freebusy/m.gabriel%40das-**
> netzwerkteam.de.xfb<https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb>