Subject: X2Go issue (in src:x2gothinclient) has been marked as closed

From: Mike Gabriel <[email-masked]>
Date: Fri, 19 Jul 2013 23:53:02 +0200 (CEST)

close #251
thanks

Hello,

we are very hopeful that X2Go issue #251 reported by you
has been resolved in the new release (1.1.0.0) of the
X2Go source project »src:x2gothinclient«.

You can view the complete changelog entry of src:x2gothinclient (1.1.0.0)
below, and you can use the following link to view all the code changes
between this and the last release of src:x2gothinclient.

    http://code.x2go.org/gitweb?p=x2gothinclient.git;a=commitdiff;h=82d0f1a2a4c45b40e76ce98d2b8ad8b28e7aad56;hp=111c8e9da59660fb68473111fb0a32c7106a1170

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:x2gothinclient.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:x2gothinclient
Version: 1.1.0.0
Status: RELEASE
Date: Fri, 19 Jul 2013 23:31:10 +0200
Fixes: 66 95 115 251
Changes: 
 x2gothinclient (1.1.0.0) RELEASED; urgency=low
 .
   [ Mike Gabriel ]
   * New upstream version (1.1.0.0):
     - When X2Go TCE has plymouth installed, make sure pressing the
       halt button does not change to the wrong tty.
     - Truncate echo output lines to less than 80 chars.
     - Use sed to patch initramfs configuration (rather than a patch
       that fails on wheezy). The change is needed for squeeze only.
     - Fix x2go_tce_shell.sh script, escape braces.
     - Change method of mounting /proc, /sys and /dev inside of chroots.
     - Step towards wheezy, enable plymouth boot splash.
     - Symlink /etc/mtab to /proc/mounts before installing any kernel
       during the chroot creation process.
     - Handle /etc/fstab in TCE chroot differently for squeeze and wheezy
       (/dev/pts does not need an entry in fstab on wheezy systems, /var/run
       got relocated to /run).
     - /etc/network/interfaces in wheezy already contains a loopback device
       entry.
     - Mount proc and sysfs from outside chroot, cleanly unmount both in case
       there are more than one mountpoints for sysfs or proc mounted.
     - Do not fail if proc or sysfs are already mounted within chroot.
     - Allow thin client management (x2gothinclient_shell,
       x2gothinclient_upgrade) while thin clients are in use.
     - Disable kms for radeon and i915 graphics adapters.
     - x2gothinclient_shell now does not affect boot behavious of the TCE
       machines anymore, thus, removing the notification output when
       launching the X2Go TCE maintenance shell.
     - Drop i686 kernel support, use i486 kernel by default. In Debian wheezy
       we only find a 686-pae kernel which fails on some (virtual) hardware (e.g.
       virtualbox).
     - Make sure that kernel + initrd symlinks are relative symlinks.
     - Keep mounts for /proc and /dev/pts with option noauto for mounting inside
       of chroot. They are not needed during TCE boot.
     - Make the SSH daemon listen on IPv4 localhost address only.
     - Provide /dev/pts inside chroot.
     - Move configuration template from /usr/share/tce to /usr/share/tce/etc.
     - Add direct FreeRDP support for defaults TCE installation.
     - Add empty known_host file for FreeRDP.
     - Start with US keyboard as default keyboard layout.
     - Only mount /proc, /sys, /dev/pts inside chroot if not already mounted.
     - Xorg appears as /usr/bin/X in ps ax output. Make sure it gets detected.
     - Provide a README.hostname file in doc folder of x2gothinclientmanagement.
     - For TCE stations with multiple heads, align heads next to each other
       in order of appearance in xrandr.
     - Fix multi-head detection failures where xrandr writes output to stderr
       (closes upstream issue #48).
     - Rename x2goclient user to ,,x2gothinclient'' user (system user account).
       Make sure that the system user account gets created during
       x2gothinclient_create and during installation of the x2gothinclient
       package (closes upstream issue #47).
     - x2gothinclient_create: replace /home by /var/lib/x2gothinclient in
       /etc/fstab template.
     - x2gothinclient_update: make sure config target folders exist.
     - x2gothinclient_create: syntax fix, spotted by Thomas Güttler (Fixes: #95).
     - Export $LANG and $LANGUAGE to TCE daemon.
     - Use qx instead of open3 to launch x2goclient. (Fixes: #66).
     - Only make x2gousbmount and x2gognupgccid scripts functional if
       x2gothinclientd is running.
     - When finishing x2gothinclientd, wait when killing processes till all
       processes have vanished. Only kill processes owned by user x2gothinclient.
     - When finishing x2gothinclientd, make sure no dbus-* processes remain.
     - Unmount /proc, /sys and /dev/pts before doing x2gothinclient_cleanup.
     - Add README.qemu that explains how to test the X2Go TCE with qemu.
       (Fixes: #115).
     - Fix code that turns absolute symlinks into relative symlink for /vmlinuz
       and /initrd.img.
     - Fix shutdown button failures.
     - TCE management: Do an apt-get clean after TCE creation/upgrade.
     - TCE creation: fix installation path of FreeRDP's known_hosts file.
     - TCE creation: install the TCE from the nightly builds while this
       project is not yet released. (Fixes: #251).
     - TCE creation: default to wheezy for creating new TCE environments.
   * /debian/control:
     + Maintainer change in package: X2Go Developers <[email-masked]>.
     + Priority: optional.
     + Add dependency (x2gothinclient bin:package): x11-xserver-utils (for xrandr
       support).
     + Add dependency (x2gousbmount, x2gocdmanager): libfile-path-expand-perl.
     + Bump Standards to 3.9.3 (no changes needed).
     + Remove TCE tools (vim, mc, ...) from Recommends: field, install those via
       x2gothinclient_create. Add pulseaudio, dbus-x11, policykit-1 to Depends:
       field.
   * /debian/rules:
     + Fix lintian issue: debian-rules-missing-recommended-target build-arch
     + Fix lintian issue: debian-rules-missing-recommended-target build-indep
   * /debian/x2gothinclient.examples:
     + Fix src location of example config files.
   * /debian/x2gothinclient.install:
     + Install TCE config files into /etc/x2go by default.
   * /debian/x2gothinclientmanagement.manpages:
     + Make sure all man pages for bin:package x2gothinclientmanagement get
       installed into package.
   * /debian/x2gothinclient.init:
     + Update pointer to X2Go TCE documentation on http://wiki.x2go.org.
   * /debian/x2gothinclient.postrm:
     + On action=purge, wait for 20s until x2gothinclientd has stopped.
   * /debian/po/*:
     + Use po-debconf for translating debconf templates. Add German debconf
       translation.
   * Launch X2Go TCE via /etc/X11/default-display-manager. Add debconf template
     to handle default display manager selection. Inspired by Debian's gdm
     package.
   * Only start X2Go CD Manager if x2gothinclientd is the default display
     manager.
 .
   [ Oleksandr Shneyder ]
   * New upstream version (1.1.0.0):
     - Use expand_file from File::Path::Expand to detect full path
       of ~x2gothinclient/.halt.

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Fri, 19 Jul 2013 21:55:16 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2gothinclient package:

#251: User x2goclient expected, but user x2gothinclient established

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:x2gothinclient) has been marked as closed
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Fri, 19 Jul 2013 23:53:02 +0200 (CEST)

close #251
thanks

Hello,

light+love

---

Subject: User x2goclient expected, but user x2gothinclient established
From: Stephan Wagner <[email-masked]>
To: [email-masked]
Date: Thu, 27 Jun 2013 16:09:24 +0200

Package: x2gothinclient
Version: 1.0.1.8-0

A user "x2gothinclient" is established in the TCE- environment, but 
/usr/sbin/x2gothinclientd expects the user "x2goclient", with its home 
directory at /home/x2goclient. Therefore /usr/bin/x2goclient will not start, 
leaving the user in front of a black screen.

Intruducing the user 'x2goclient' solved the problem.

Stephan

-- 
__________________________________________________
Dr. Stephan Wagner
ITos GmbH
Bitzi-Bendel 2555
9642 Ebnat-Kappel
Tel: +41 (0)71 990 05 94
mailto:[email-masked]
http://www.itos-gmbh.com
--------------------------------------------------