Subject: Bug#249: Segmentation fault in x2goclient

From: Heinrich Schuchardt <[email-masked]>
Date: Sun, 23 Jun 2013 23:01:43 +0200

Package: x2goclient
Version: 4.0.1.0
Severity: severe

When trying to connect to a x2go server I experience a first failure 
when the session should be established and a segmentation error ending 
x2goclient when closing the session window:

== Packages installed ==

.../libxcomp3_2%3a3.5.0.20-0+wheezy~main~405~build1_amd64.deb) ...
.../nxproxy_2%3a3.5.0.20-0+wheezy~main~405~build1_amd64.deb) ...
.../x2goclient_4.0.1.0-0~x2go1+wheezy~main~380~build1_amd64.deb) ...

== Output in x2goclient ==

NXPROXY - Version 3.5.0

Copyright (C) 2001, 2010 NoMachine.
See http://www.nomachine.com/ for more information.

Info: Proxy running in client mode with pid '9249'.
Session: Starting session at 'Sun Jun 23 22:35:13 2013'.
Info: Connecting to remote host 'localhost:31001'.
Info: Connection to remote proxy 'localhost:31001' established.
ZeitüberschreitungInfo: Aborting the procedure due to signal '15'.
Session: Session terminated at 'Sun Jun 23 22:35:43 2013'.

== Output in console ==

ONMainWindow constructor

ONMainWindows constructor finished, home Directory is: "/home/user"

read  1  sessions from config file
start new ssh connection to server: "10.0.0.5" : "22" krb:  false

ssh connection ok

continue normal x2go session

"x2gostartagent 1280x1024 lan 16m-jpeg-9 unix-kde-depth_24 de pc105/de 1 
D KDE"

Agent output: "50
cf4921e4ba383a630708d7a92be69259
14724
user-50-1372019694_stDKDE_dp24
30001
30002
30003
"
starting nxproxy with:  "nxproxy -S 
nx/nx,options=/home/user/.x2go/S-user-50-1372019694_stDKDE_dp24/options:50"

"
NXPROXY - Version 3.5.0

Copyright (C) 2001, 2010 NoMachine.
See http://www.nomachine.com/ for more information.

Info: Proxy running in client mode with pid '9249'.
Session: Starting session at 'Sun Jun 23 22:35:13 2013'.
Info: Connecting to remote host 'localhost:31001'.
Info: Connection to remote proxy 'localhost:31001' established.
"

"channel_forward_listen schlug fehl"  -  ""
deleting proxy

nxproxy not running

proxy deleted

checking exit status
check command message

Speicherzugriffsfehler (segmentation fault)

== Valgrind Output ==

==9291== Process terminating with default action of signal 11 (SIGSEGV)
==9291==  Access not within mapped region at address 0x5C
==9291==    at 0x49C128: ??? (in /usr/bin/x2goclient)
==9291==    by 0x446ABF: ??? (in /usr/bin/x2goclient)
==9291==    by 0x446D05: ??? (in /usr/bin/x2goclient)
==9291==    by 0x4CAD69: ??? (in /usr/bin/x2goclient)
==9291==    by 0x6E5854E: QMetaObject::activate(QObject*, QMetaObject 
const*, int, void**) (in /usr/lib/x86_64-linux-gnu/libQtCore.so.4.8.2)
==9291==    by 0x6511F31: QAbstractButton::clicked(bool) (in 
/usr/lib/x86_64-linux-gnu/libQtGui.so.4.8.2)
==9291==    by 0x626606D: ??? (in 
/usr/lib/x86_64-linux-gnu/libQtGui.so.4.8.2)
==9291==    by 0x626689F: ??? (in 
/usr/lib/x86_64-linux-gnu/libQtGui.so.4.8.2)
==9291==    by 0x6266B0B: 
QAbstractButton::mouseReleaseEvent(QMouseEvent*) (in 
/usr/lib/x86_64-linux-gnu/libQtGui.so.4.8.2)
==9291==    by 0x6320A89: QToolButton::mouseReleaseEvent(QMouseEvent*) 
(in /usr/lib/x86_64-linux-gnu/libQtGui.so.4.8.2)
==9291==    by 0x5EFBE0F: QWidget::event(QEvent*) (in 
/usr/lib/x86_64-linux-gnu/libQtGui.so.4.8.2)
==9291==    by 0x5EAC70B: QApplicationPrivate::notify_helper(QObject*, 
QEvent*) (in /usr/lib/x86_64-linux-gnu/libQtGui.so.4.8.2)
==9291==  If you believe this happened as a result of a stack
==9291==  overflow in your program's main thread (unlikely but
==9291==  possible), you can try to increase the size of the
==9291==  main thread stack using the --main-stacksize= flag.
==9291==  The main thread stack size used in this run was 8388608.

---

From: Mike Gabriel <[email-masked]>
Date: Mon, 24 Jun 2013 06:10:52 +0200

severity #249 serious
tag #249 moreinfo
thanks

Hi Heinrich,

On So 23 Jun 2013 23:01:43 CEST Heinrich Schuchardt wrote:

> when the session should be established and a segmentation error  
> ending x2goclient when closing the session window:

Can you check this against a latest build of X2Go Client?

Either install x2goclient package from

   deb http://packages.x2go.org/debian wheezy nightly

or build it from source (debuild -uc -us after cloned from Git).

Please report back, if the latest version show the same behaviour.

Thanks,
Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: DirectAxis Financial Services <[email-masked]>
Date: Sun, 19 Feb 2023 06:03:03 +0000

Welcome To DirectAxis

We are currently on a promotion, giving out loans for only at 5% interest rate per annum. The offer covers all types of loan and open to blacklisted individuals and those under debt review. 

See attached for more information on the 5% loan offer as we await your swift application at:([email-masked])

Kind Regards.

MARKETING TEAM
Direct Axis Financial Services.
WITH US YOU CAN.

---

From: DirectAxis Financial Services <[email-masked]>
Date: Sun, 19 Feb 2023 06:03:03 +0000

Welcome To DirectAxis

Kind Regards.

MARKETING TEAM

---

From: savita singh <[email-masked]>
Date: Fri, 11 Aug 2023 16:29:09 +0000

Hi,

I am still waiting for your reply.

Please May I send you a quote? If you are interested!

Thank you

________________________________
From: savita singh
Sent: Friday, August 11, 2023 1:31 AM
Subject: Quotation and Pricing

Hi,

I found that your website isn't doing well on Google search results. We can help your

website to rank higher on Google.

Please let me know if you are interested, I will send you our SEO Packages and price

list.

Thanks,

Savita

---

From: Bindu singh <[email-masked]>
Date: Wed, 16 Aug 2023 15:08:23 +0000

Hi,

Thank you

________________________________
From: Bindu singh
Sent: Monday, August 14, 2023 11:07 PM
Subject: Quotation and Pricing

Hi,

list.

Thanks,

Bindu

---

From: Arleth yadav <[email-masked]>
Date: Fri, 18 Aug 2023 17:27:12 +0000

Hi,

Thank you

________________________________
From: Arleth yadav
Sent: Thursday, August 17, 2023 8:46 PM
Subject: Quotation and pricing

Hi,

Hope you are well

Want more traffic on your website?

Achieve 1st Page Ranking on Google by SEO. We can help you rank higher than your competitors on Google for your target keywords.

Please let me know if you have any SEO needs, and we could send you a proposal.

Best Regards

---

From: [email-masked]
Date: 19 Nov 2023 14:12:30 -0800

Wir stellen Ihnen den BAHRAIN GROUP FUND vor.

Bei BAHRAIN GROUP FUND bieten wir Ihnen die beste Alternative zu 
Ihrer Bank, um sich die Mittel zu sichern, die Sie benötigen.

Unsere Mission ist es, gleiche Wettbewerbsbedingungen zu 
schaffen, damit Sie Ihre finanziellen Ziele durch unsere Kredite 
zu einem erschwinglichen Zinssatz erreichen können.

Wir bieten Geschäftskredite, Privatkredite, Agrarkredite und 
Schuldenkonsolidierungskredite zu einem sehr wettbewerbsfähigen 
Zinssatz an.

Weitere Informationen finden Sie in unserem beigefügten Flyer. 
Kontaktieren Sie uns noch heute und erhalten Sie eine garantierte 
finanzielle Unterstützung.

Kontaktieren Sie uns per E-Mail> [email-masked]

Danke

---

From: "Euro Millions" <[email-masked]>
Date: 19 Mar 2024 17:51:36 -0700

Herzlichen Glückwunsch, Sie haben €650.000,00 bei den monatlichen Gewinnspielen von Euro Millions / Google Promo am 15.März 2023 gewonnen.

Bitte geben Sie die folgenden Informationen ein, damit Ihr Gewinnbetrag an Sie überwiesen werden kann.

Vollständiger Name:
Heimatadresse:
Geschlecht:
Alter:
Telefon:

John Andrew
Online-Koordinator

---

From: paul carrillo <[email-masked]>
Date: Sun, 4 May 2025 17:38:39 -0700

*We are a direct mandate to various Government refineries in Houston,
Rotterdam, Oman, Dubai, Saudi Arabia, Kuwait and Kazakhstan, I’ll love to
build a good business relationship with you.We currently have available
products in Rotterdam port and Houston port like AVIATION KEROSENE COLONIAL
GRADE A1 JET FUEL A1/JP54, Kazakhstan D2 DIESEL GAS OIL Kazakhstan DIESEL
EN590 10PPM,  HSD2 GAS OIL, Kazakhstan VIRGIN FUEL OIL D6, LIQUEFIED
NATURAL GAS, LIQUEFIED PETROLEUM GAS, Kazakhstan LIGHT CYCLE OIL, ETC.
Kindly advise if you are in contact with buyer’s who are interested in
getting our products and your commission will be saved on the Seller side.I
believe you are in contact with potential buyers one way or the other. Can
we connect on WhatsApp, What's your number, So I can send our soft
offer.Email: [email-masked]
<[email-masked]>Phone/WhatsApp: +31619415104website:
 https://stamproductsbv.com/ <https://stamproductsbv.com/>*

---

From: [email-masked]
Date: Wed, 25 Mar 2026 13:19:00 +0300

We "LLC NEOCOM GEOSERVICE" is an officially registered mandate to 
genuine and reliable end seller company that deals in petroleum 
products. Attached below is our company soft offer for available 
products in refinery reservoir tank awaiting urgent lift: JP54, Mazut, 
Diesel Gas Oil D2, AGO, Aviation Kerosene, Jet A-1, D6 Virgin Oil, 
EN590, Fuel Oil CST! 80/380, Pet Coke, LNG, LPG, REBCO, UREA, etc.
Thanks for your cooperation

  REGARDS

   Borzaev Bibulat Khamzatovich
           Director.
Tel/ WhatsApp: +79684462859

---

From: [email-masked]
Date: Wed, 25 Mar 2026 13:23:49 +0300

REGARDS

---

From: "Joe Jess Thwaite." <[email-masked]>
Date: Thu, 30 Apr 2026 16:01:04 +0000

Hallo,

wir sind Joe und Jess Thwaite aus Gloucester, Großbritannien. Wir haben den EuroMillions-Jackpot in Höhe von 184 Millionen Pfund gewonnen. Um etwas zurückzugeben, haben wir uns entschieden, 15 Millionen Pfund an wohltätige Zwecke zu spenden. Im Rahmen dieser Spende spenden wir jeweils 2 Millionen Euro an fünf glückliche Gewinner für wohltätige und geschäftliche Zwecke. Sie sind einer der Empfänger. Um Ihre Spende zu erhalten, kontaktieren Sie uns bitte unter [email-masked] und geben Sie dabei Ihren Namen und den Spendencode JJT2 an.

---

From: <[email-masked]>
Date: Thu, 23 Jul 2026 10:56:42 +0300

Hallo,

ich habe Ihnen bereits E-Mails bezüglich Ihrer Spende von 2.500.000,00 € gesendet. Haben Sie meine Nachricht erhalten? Ihre E-Mail-Adresse wurde erfolgreich für meine Spende ausgewählt. Bitte ignorieren Sie diese Nachricht nicht; es handelt sich nicht um Betrug. Bitte antworten Sie umgehend, um weitere Informationen zu erhalten. Vielen Dank und Gottes Segen für Ihre Spende zur Unterstützung der Armen und Kranken im Krankenhaus. Bitte antworten Sie so schnell wie möglich, damit Ihre Spende bearbeitet werden kann.

Falls Sie diese Nachricht in Ihrem Spam-Ordner gefunden haben, liegt dies an einer anderen IP-Adresse.

Name:
Land:
WhatsApp-Nummer:

Für weitere Informationen kontaktieren Sie bitte: [email-masked]

Mit freundlichen Grüßen,
Steven Anthony Ballmer