Subject: Bug#228: Mount MTP on thinclients

From: Anders Bruun Olsen <[email-masked]>
Date: Mon, 10 Jun 2013 11:38:29 +0200

Package: x2gothinclientmanagement
Severity: wishlist

X2go thinclients currently mount usb-storage devices nicely. It would be
nice if they could also handle MTP-devices (like newer Android-phones). The
mechanics for connecting the x2goserver session to the actual device
(sshfs) wouldn't need to be changed. It would be a case of adding mtpfs or
something similar to the thinclient chroot and making sure it auto mounts.

-- 
Anders Bruun Olsen
It-ansvarlig
Det Danske Sprog- og Litteraturselskab
(Society for Danish Language and Literature)

---

From: Mike Gabriel <[email-masked]>
Date: Mon, 10 Jun 2013 12:54:01 +0200

reassign #228 x2gousbmount
thanks

Hi Anders,

> something similar to the thinclient chroot and making sure it auto mounts.

This basically has to be solved in the x2gousbmount package of the  
src:x2gothinclient X2Go component.

As I do not have such a device here for testing, I need help for that.

A test rig would look like this:

   o Install a minimal Debian/Ubuntu system
   o install the x2gothinclient package from our nightly builds (+dependencies)
     (or build from source: x2gothinclient.git)
   o edit the files you find in [1] and add mtpfs to the test system till it
     works

Greets,
Mike

[1] http://code.x2go.org/gitweb?p=x2gothinclient.git;a=tree;f=x2gousbmount

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Wed, 12 Jun 2013 09:48:02 +0000

Thank you for the additional information you have supplied regarding
this Bug report.

This is an automatically generated reply to let you know your message
has been received.

Your message has not been forwarded to the package maintainers or
other interested parties; you should ensure that the developers are
aware of the problem you have entered into the system - preferably
quoting the Bug reference number, #228.

If you wish to submit further information on this problem, please
send it to [email-masked].

Please do not send mail to [email-masked] unless you wish
to report a problem with the Bug-tracking system.

-- 
228: http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=228
X2Go Bug Tracking System
Contact [email-masked] with problems

---

From: Mike Gabriel <[email-masked]>
Date: Fri, 14 Jun 2013 12:16:20 +0200

Hi Anders,

On Mi 12 Jun 2013 11:57:56 CEST Anders Bruun Olsen wrote:

> Okay, fair enough. It seems that gvfs does indeed mount the MTP device
> under /run/user/USERNAME/gvfs (wasn't listed with just the mount command,
> but is in /proc/mounts). But I don't think getting gvfs to play nicely with
> the rest of the x2gothinclient setup is worth the trouble. It might also be
> problematic as there is no way for the user to tell gvfs to mount the MTP
> device. It needs to be automatic. I think go-mtpfs might be the solution,
> but I am unable to test it today, as I am away from my work machine, where
> I have the before mentioned VM setup.

Thanks for further introspection into this. Get back to us, once you  
have the chance of testing it further!!!

Greets,
Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy: