Subject: Bug#226: x2gobroker: Incorrect hostname displayed when hostname and address are different

From: Anders Bruun Olsen <[email-masked]>
Date: Fri, 7 Jun 2013 14:51:57 +0200

Package: x2gobroker (perhaps x2goclient)
Version: 0.0.2.3
Severity: minor

With the new setup where servers can be specified as hostname (address), I
have this setup:

host=testterm1 (testterm1.example.com),testterm2 (testterm2.example.com)

When x2goclient gets sent to testterm2.example.com, it displays testterm1
as the hostname, but connects to testterm2.example.com. It is probably only
cosmetic, but should be fixed, so us poor sysadmins won't have problems
troubleshooting :)

-- 
Anders Bruun Olsen
It-ansvarlig
Det Danske Sprog- og Litteraturselskab
(Society for Danish Language and Literature)

---

From: Mike Gabriel <[email-masked]>
Date: Fri, 07 Jun 2013 20:47:22 +0200

reassign #226 src:x2goclient
found #226 4.0.1.0
thanks

Hi Anders,

> Package: x2gobroker (perhaps x2goclient)

This is indeed an x2goclient/x2goplugin issue.

> cosmetic, but should be fixed, so us poor sysadmins won't have problems

Patch is on its way... Please test once it is committed to Git. Thanks!

Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb