Subject: x2gosqlitewrapper is looking for x2gosqlitewrapper.pl in /usr/local/lib/x2go directory

From: Mukesh Singh <[email-masked]>
Date: Wed, 22 May 2013 12:20:50 -0400

Package: x2goserverVersion: 4.0.0.2
I recently upgraded x2goserver to 4.0.0.2 on RHEL6 and it stopped working. I found out that x2gosqlitewrapper is looking for x2gosqlitewrapper.pl in /usr/local/lib/x2go directory. So when I created a symlink in that directory it started working again.
Please change the path for the file in source code or change the package to create the link on installation.

Thanks!
Mukesh Kr

---

From: Mike Gabriel <[email-masked]>
Date: Thu, 23 May 2013 00:20:16 +0200

Hi Mukesh Kr, hi Jan,

@Jan: I guess this one is for you...

On Mi 22 Mai 2013 18:20:50 CEST Mukesh Singh wrote:

> I recently upgraded x2goserver to 4.0.0.2 on RHEL6 and it stopped  
> working. I found out that x2gosqlitewrapper is looking for  
> x2gosqlitewrapper.pl in /usr/local/lib/x2go directory. So when I  
> created a symlink in that directory it started working again.
> Please change the path for the file in source code or change the  
> package to create the link on installation.

For the Debian packages, there is a Makefile-like file called  
/debian/rules that coordinates all the packaging tasks. From this  
file, I explicitly have to export PREFIX=/usr to make the new  
x2gosqlitewrapper.c work.

@Jan: can you check the RPM packages and make sure that the PREFIX  
path reaches the main Makefile of X2Go Server? A similar change to the  
packaging has to be introduced to x2gobroker.git.

Thanks!
Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Jan Engelhardt <[email-masked]>
Date: Thu, 23 May 2013 01:16:48 +0200 (CEST)

On Thursday 2013-05-23 00:20, Mike Gabriel wrote:
>> I recently upgraded x2goserver to 4.0.0.2 on RHEL6 and it stopped working. I
>> found out that x2gosqlitewrapper is looking for x2gosqlitewrapper.pl in
>> /usr/local/lib/x2go directory. So when I created a symlink in that directory
>> it started working again.
> @Jan: can you check the RPM packages and make sure that the PREFIX path reaches
> the main Makefile of X2Go Server? A similar change to the packaging has to be
> introduced to x2gobroker.git.

Fixed for x2goserver.

In x2gobroker however, there are still lots of hardcoded (in the
tarball!) /usr/lib/x2go instead of $(LIBDIR)/x2go...

---

From: Mike Gabriel <[email-masked]>
Date: Thu, 23 May 2013 21:21:34 +0200

clone #219 -1 -2
reassign #219 x2goserver
severity #219 important
fixed #219 4.0.0.2
close #219
reassign -1 x2gobroker-agent
retitle -1 Explicitly export PREFIX=/usr when building RPM packages
severity -1 important
reassign -2 src:x2gobroker
retitle -2 Make hard-coded path /usr/lib/x2go build-configurable via Makefile
severity -2 wishlist
thanks

Hi Jan,

doint some BTS magic above...

On Do 23 Mai 2013 01:16:48 CEST Jan Engelhardt wrote:

>> path reaches

This issue (#219, x2goserver) then gets marked as resolved.

> tarball!) /usr/lib/x2go instead of $(LIBDIR)/x2go...

This I consider as a follow-up. New bug numbers will get assigned for  
this in two ways.

Temp bug number -1 (wait for the bug no. after the cloning has  
happened) will be about fixing the RPM build for x2gobroker(-agent).  
Please make sure that agent works in RPM builds of src:x2gobroker.

If you have fixed this issue send a short message to  
<nnn>[email-masked] (where <nnn>) has to be the  
to-be-newly-assigned bug number after the cloning).

Temp bug number -2 refers to getting the Makefile and the hard-coded  
paths referers to /usr/lib/x2go (et al.) fixed in the more less near  
future.

Thanks+Greets,
Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Thu, 23 May 2013 19:22:00 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goserver package:

#219: x2gosqlitewrapper is looking for x2gosqlitewrapper.pl in /usr/local/lib/x2go directory

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: Re: Bug#219: x2gosqlitewrapper is looking for x2gosqlitewrapper.pl in /usr/local/lib/x2go directory
From: Mike Gabriel <[email-masked]>
To: Jan Engelhardt <[email-masked]>, [email-masked]
Cc: Mukesh Singh <[email-masked]>, [email-masked]
Date: Thu, 23 May 2013 21:21:34 +0200

clone #219 -1 -2
reassign #219 x2goserver
severity #219 important
fixed #219 4.0.0.2
close #219

Hi Jan,

Thanks+Greets,
Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

Subject: x2gosqlitewrapper is looking for x2gosqlitewrapper.pl in /usr/local/lib/x2go directory
From: Mukesh Singh <[email-masked]>
To: "[email-masked]" <[email-masked]>
Date: Wed, 22 May 2013 12:20:50 -0400

Thanks!
Mukesh Kr