Subject: X2Go issue (in src:x2gobroker) has been marked as closed

From: Mike Gabriel <[email-masked]>
Date: Sun, 19 May 2013 12:43:45 +0200 (CEST)

close #210
thanks

Hello,

we are very hopeful that X2Go issue #210 reported by you
has been resolved in the new release (0.0.2.1) of the
X2Go source project »src:x2gobroker«.

You can view the complete changelog entry of src:x2gobroker (0.0.2.1)
below, and you can use the following link to view all the code changes
between this and the last release of src:x2gobroker.

    http://code.x2go.org/gitweb?p=x2gobroker.git;a=commitdiff;h=e7ba5f8e1a81d814f4d3e9f82ad6e9bc2855e7cd;hp=363a8fb21e215d403ef81c9bfc0d079d431bacce

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:x2gobroker.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:x2gobroker
Version: 0.0.2.1
Status: RELEASE
Date: Sun, 19 May 2013 12:41:06 +0200
Fixes: 201 210 211
Changes: 
 x2gobroker (0.0.2.1) RELEASED; urgency=low
 .
   [ Mike Gabriel ]
   * New upstream version (0.0.2.1):
     - Remove trailing slashes from ManagementServer URLs.
     - In Apache2 vhost configuration example, move WSGI environment
       variable settings into VirtualHost setup.
     - Remove unused, not-yet-developed broker backends and frontends.
     - Remove old cruft from x2gobroker.conf.
     - Security fix for setuid wrapper x2gobroker-agent.c. Hard-code path to
       x2gobroker-agent.pl during build via defining a macro in the Makefile.
       Thanks to Richard Weinberger for spotting this!!!
     - Handle URLs in plain WebUI that have slashes (and subpaths) in the
       backend name.
     - In WSGI mode: only populate os.environ with variables matching
       »X2GOBROKER_*«.
     - Make X2GOBROKER_SESSIONPROFILES configurable via a SetEnv WSGI parameter
       in the httpd configuration possible. (Fixes: #210).
   * Provide init scripts and *.default files outside of /debian folder (as
     they are also relevant for non-Debian packaging).
 .
   [ Jan Engelhardt ]
   * New upstream version (0.0.2.1):
     - Populate install target of Makefile. (Fixes: #201).
     - Install man pages and default files through Makefile, as well. (Fixes:
       #211).

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Sun, 19 May 2013 10:48:04 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2gobroker package:

#210: X2gobroker-wsgi variables ignored

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:x2gobroker) has been marked as closed
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Sun, 19 May 2013 12:43:45 +0200 (CEST)

close #210
thanks

Hello,

light+love

---

Subject: X2gobroker-wsgi variables ignored
From: Anders Bruun Olsen <[email-masked]>
To: [email-masked]
Date: Wed, 15 May 2013 14:20:31 +0200

Package: x2gobroker
Version: 0.0.2.0 and 0.0.2.1 (git master)

I am trying to setup x2gobroker served via WSGI with the new
x2gobroker-wsgi package. I have opted to setup a vhost that will serve only
clients from my LAN and a different one for outside access. For this, I
want to point them to different config-files (session profiles) and have
discovered that none of the SetEnv statements in the Apache config files
are being honored. According to
http://stackoverflow.com/questions/9016504/apache-setenv-not-working-as-expected-with-mod-wsgiSetEnv
does not result in variables being available in os.environ, but
instead in the WSGI request's variable called environ. I can see that the
code currently looks in os.environ, and as such, when running through WSGI,
only default values are used. You could either look in both os.environ and
the WSGI requests environ, or only look in the WSGI request and have code
before that, which adds os.environs variables to the WSGI request.

-- 
Anders Bruun Olsen
It-ansvarlig
Det Danske Sprog- og Litteraturselskab
(Society for Danish Language and Literature)