X2Go Bug report logs - #209
Mac Client crashes on start

version graph

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: Florian <florian@innobiz.de>

Date: Tue, 14 May 2013 20:03:02 UTC

Severity: normal

Tags: build-macosx

Merged with 157

Found in versions 4.0.0.4, latest

Done: Mihai Moldovan <ionic@ionic.de>

Bug is archived. No further changes may be made.

Full log


View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#209: Mac Client crashes on start
Reply-To: Florian <florian@innobiz.de>, 209@bugs.x2go.org
Resent-From: Florian <florian@innobiz.de>
Resent-To: x2go-dev@lists.berlios.de
Resent-CC: X2Go Developers <x2go-dev@lists.berlios.de>
X-Loop: owner@bugs.x2go.org
Resent-Date: Tue, 14 May 2013 20:03:02 +0000
Resent-Message-ID: <handler.209.B.136856125025544@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: report 209
X-X2Go-PR-Package: x2goclient
X-X2Go-PR-Keywords: 
Received: via spool by submit@bugs.x2go.org id=B.136856125025544
          (code B); Tue, 14 May 2013 20:03:02 +0000
Received: (at submit) by bugs.x2go.org; 14 May 2013 19:54:10 +0000
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=0.0 required=5.0 tests=none autolearn=ham
	version=3.3.2
X-Greylist: delayed 324 seconds by postgrey-1.34 at ymir; Tue, 14 May 2013 21:54:09 CEST
Received: from web25.dogado.de (web25.dogado.de [93.90.181.177])
	by ymir (Postfix) with ESMTP id 867455DB1E
	for <submit@bugs.x2go.org>; Tue, 14 May 2013 21:54:09 +0200 (CEST)
Received: from bahia.fritz.box (mnch-5d86ace5.pool.mediaWays.net [93.134.172.229])
	by web25.dogado.de (Postfix) with ESMTPA id AF89916C3D89
	for <submit@bugs.x2go.org>; Tue, 14 May 2013 21:48:41 +0200 (CEST)
Message-ID: <5192951C.5020304@innobiz.de>
Date: Tue, 14 May 2013 21:48:44 +0200
From: Florian <florian@innobiz.de>
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:17.0) Gecko/20130509 Thunderbird/17.0.6
MIME-Version: 1.0
To: submit@bugs.x2go.org
X-Enigmail-Version: 1.5.1
Content-Type: text/plain; charset=ISO-8859-15
Content-Transfer-Encoding: 7bit
Package: X2GoClient
Version: latest

Hi Team!

I just wanted to try out the x2go server and Mac client but I cannot get
the client to run. As soon as I start it it crashes. I even do not see a
window opening!
Here is the report my Mac want to send to Apple:

Process:         launchd [1042]
Path:            /Applications/x2goclient.app/Contents/MacOS/x2goclient
Identifier:      launchd
Version:         ??? (???)
Code Type:       X86-64 (Native)
Parent Process:  launchd [608]

Date/Time:       2013-05-14 21:23:57.841 +0200
OS Version:      Mac OS X 10.7.5 (11G63)
Report Version:  9

Crashed Thread:  Unknown

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x00007fff5fc01028

Backtrace not available

Unknown thread crashed with X86 Thread State (64-bit):
  rax: 0x0000000000000055  rbx: 0x0000000000000000  rcx:
0x0000000000000000  rdx: 0x0000000000000000
  rdi: 0x0000000000000000  rsi: 0x0000000000000000  rbp:
0x0000000000000000  rsp: 0x0000000000000000
   r8: 0x0000000000000000   r9: 0x0000000000000000  r10:
0x0000000000000000  r11: 0x0000000000000000
  r12: 0x0000000000000000  r13: 0x0000000000000000  r14:
0x0000000000000000  r15: 0x0000000000000000
  rip: 0x00007fff5fc01028  rfl: 0x0000000000010203  cr2: 0x00007fff5fc01028
Logical CPU: 3

Binary images description not available


External Modification Summary:
  Calls made by other processes targeting this process:
    task_for_pid: 1
    thread_create: 0
    thread_set_state: 0
  Calls made by this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
  Calls made by all processes on this machine:
    task_for_pid: 711
    thread_create: 0
    thread_set_state: 0

Model: MacBookPro8,2, BootROM MBP81.0047.B27, 4 processors, Intel Core
i7, 2.2 GHz, 4 GB, SMC 1.69f4
Graphics: AMD Radeon HD 6750M, AMD Radeon HD 6750M, PCIe, 1024 MB
Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In, 384 MB
Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1333 MHz, 0x80AD,
0x484D54333235533642465238432D48392020
Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1333 MHz, 0x80AD,
0x484D54333235533642465238432D48392020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xD6),
Broadcom BCM43xx 1.0 (5.106.198.19.22)
Bluetooth: Version 4.0.8f17, 2 service, 18 devices, 1 incoming serial ports
Network Service: Ethernet, Ethernet, en0
Network Service: Wi-Fi, AirPort, en1
Serial ATA Device: Hitachi HTS725050A9A362, 500,11 GB
Serial ATA Device: HL-DT-ST DVDRW  GS31N

If I can be of any more assistance please let me know!

Best
Florian

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Thu May 23 23:00:14 2019; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.