Subject: Re: [X2Go-User] Client Wish List

From: Mike Gabriel <[email-masked]>
Date: Sat, 18 Oct 2014 22:51:36 +0000

close #208
reopen #348
forcemerge #348 #481
thanks

Hi Robert,

thanks for testing X2Go so intensively. I highly appreciate your  
wishlist (I am one of the core devs). So that it does not get lost, do  
one thing for a start [1]. Unfortunately, I don't have a Mac and I  
don't use one. The Mac code is the part of X2Go Client that is  
yearning for a constant maintainer. It is not unmaintained, but only  
maintained on customer request.

Submit every wishlist item as a separate bug. Please see below for my  
comments on the individual issues (I will also check, if a bug already  
exists for that issue).

[1] http://wiki.x2go.org/doku.php/wiki:bugs

On  Sa 18 Okt 2014 21:57:22 CEST, Robert Dinse wrote:

> I use X2Go for remote administration and I originate on several different
> platforms, most often Ubuntu 14.04 LTS, but also from MacOS 10.7.5 and from
> Windows XP.  I also use X2Go to allow my customers remote desktop  
> access to our shell servers.

:-)

>      The X2Go client differs in behavior from other NX type clients in that
> on systems with virtual desktops or workspaces, they keyboard sequence used
> to switch workspaces, control+arrow key in the case of MacOS or  
> control+alt+arrow key in the case of Ubuntu, do not work within the  
> client,
> so when I have the client full-screened, I can't switch workspaces  
> except by first minimizing the client.  With OpenNX, NoMachine  
> Player, or Remmina, I can
> use the keyboard short-cuts to switch work spaces without minimizing  
> the client
> and that is much more convenient.

This definitely is a new bug.

Maito: [email-masked]
Subject: <fill-in-with-some-short-explanation>
Body:
Package: nxagent
Version: 3.5.0.27
Severity: minor

<the above description>

The problem is very probably burried in NX code somewhere.

>      Then on Mac there are further problems.  On MacOS 10.7.5,  
> without XQuarts,
> X2Go Client is completely unusable.  Keyboard translations are  
> severely messed
> up and it is unstable and usually dies or locks up within fifteen seconds.

There are several bugs tackling this...

http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=487
http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=481
http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=112
http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=252

>      With XQuartz installed, behavior is much better, keyboard translation is

Actually, X2Go Client is not intended to be used without XQuartz  
installed. We don't bundle it, because the release cycle of XQuartz is  
very short and we recommend having it updated as a separated  
application (rather then us having to rebuild/rebundle X2Go Client  
whenever XQuartz comes up with a new release).

http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=378

> correct with one exception, the state of CAPS LOCK is inverted, that is, when
> CAPS LOCK is on, I get upper and lower case characters, when it is off, I get
> UPPER CASE only.  It's a minor nusiance and most notable when  
> switching between X2Go client and other windows where I have to keep  
> toggling the CAPS LOCK.

Please check the above bugs if this actually has already been reported.

>      Another behaviorial issue with MacOS is that it will only do  
> full screen if I enable the X-server root window, however this  
> breaks many things MacOS,

This is a new issue, I guess. Submit it as a new bug, please.

> and so it is essentially not usable in full screen.  I do not have to do this
> with other NX clients, they all go full screen without using the root window
> and would very much desire this behavior also with X2Go client.

Can you let us know what nxproxy version these other NX clients ship?  
Can you also launch such a session and check the NX options set for  
such a session? That would be awesome!

>      On MacOS, sound does not work.  It works on Windows and Linux fine, but
> not MacOS 10.7.5.  It doesn't produce any errors, but doesn't  
> produce any sound
> either.  There are no choices for audio subsystems so nothing to  
> attempt to tweak.

AFAIK, X2Go Client for Mac OS X never had sound supported. Others may  
correct me if I am wrong.

>      This isn't a bitch list, just a wish list.  I really appreciate the work
> you folks have put into X2Go, aesthetically, I find it far superior to
> NoMachine, it also connects far more reliably, and working sound is nice.

:-)

As I said above, the Mac part of the code in X2Go Client really could  
need some love. (Or financial input, which actually is an option we  
are working on at the moment).

>      I've got the server end working on Centos 6, Centos 7, Fedora  
> 20, Scientific Linux 6, Scientific Linux 7, OpenSuse, Mint, Ubuntu,  
> and until very recently Debian Wheezy.

until very recently... means: now it is broken / or now it is finally working?

> I've also got freenx-server working on all of these
> except Debian.

Cool. They work in parallel? On the same machines?

> For those of you who have experienced problems with the newer
> distributions move to compositing window managers that don't work with X2Go,
> check out mate-desktop.org.  Mate is a fork of gnome2 that works  
> perfectly with
> X2Go and all of the above mentioned Linux distros.

Actually, I am the maintainer of MATE in Debian (/me is a Debian  
Developer and also X2Go upstream). And I have arranged that the  
developer pushing MATE into Ubuntu will meet up with us at the X2Go  
Gathering (first weekened of November in Linux Hotel, Essen, Germany).

Hope to gain more input from you!!!

Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Sat, 18 Oct 2014 22:55:02 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goclient package:

#208: X2goclient on mac

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: Re: [X2Go-User] Client Wish List
From: Mike Gabriel <[email-masked]>
To: Robert Dinse <[email-masked]>
Cc: [email-masked], [email-masked]
Date: Sat, 18 Oct 2014 22:51:36 +0000

close #208
reopen #348
forcemerge #348 #481
thanks

Hi Robert,

:-)

<the above description>

:-)

Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

Subject: X2goclient on mac
From: Dick Kniep <[email-masked]>
To: [email-masked] <[email-masked]>
Date: Tue, 14 May 2013 16:43:23 +0200

package: x2goclient
Severity: normal
Version: 0.4.0.1

Using an ssh proxy with a key gives me this log running on a Mac. 

May 14 16:37:24 autitude x2gosshd[8005]: debug1: PAM: establishing credentials
May 14 16:37:24 autitude x2gosshd[8005]: pam_unix(x2gosshd:session): session opened for user autitude by (uid=0)
May 14 16:37:24 autitude x2gosshd[7765]: error: connect_to local host: unknown host (Name or service not known)
May 14 16:37:24 autitude x2gosshd[7765]: channel_by_id: 0: bad id
May 14 16:37:24 autitude x2gosshd[7765]: Disconnecting: Received ieof for nonexistent channel 0.
May 14 16:37:24 autitude x2gosshd[7562]: pam_unix(x2gosshd:session): session closed for user autitude
May 14 16:37:24 autitude x2gosshd[8005]: User child is on pid 8167
May 14 16:37:24 autitude x2gosshd[8167]: debug1: SELinux support disabled
May 14 16:37:24 autitude x2gosshd[8167]: debug1: PAM: establishing credentials

Met vriendelijke groet,
Dick Kniep
Lindix BV
tel. 036-5215580
mob. 06-50991858