Subject: Bug#203: Session resuming has been fixed in X2Go Server 4.0.1.18 and above

From: Mike Gabriel <[email-masked]>
Date: Fri, 17 Oct 2014 11:42:00 +0000

Control: close -1

Hi,

there have been various reasons for non-resumable session in the past.  
I will close this (#203) bug for PyHoca-GUI, as I assume that it was  
actually server related. Please reopen this bug, if issues persist  
with PyHoca-GUI 0.5.0.0 (to be released soon).

Regards,
Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Fri, 17 Oct 2014 11:45:06 +0000

This is an automatic notification regarding your Bug report
which was filed against the pyhoca-gui package:

#203: X2Go session not resumable after connection got disrupted

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
203: http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=203
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: Session resuming has been fixed in X2Go Server 4.0.1.18 and above
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Date: Fri, 17 Oct 2014 11:42:00 +0000

Control: close -1

Hi,

Regards,
Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

Subject: Waiting for keyboard to appear
From: Dick Kniep <[email-masked]>
To: [email-masked] <[email-masked]>
Date: Tue, 7 May 2013 14:33:44 +0200

package: pyhoca-gui
Severity: normal
Version: 0.4.0.1

Under certain circumstances (which???) the connection is made, but the session cannot be started.

May  7 14:28:29 menea /usr/bin/x2gosetkeyboard: Waiting for /home/dick/.x2go/C-dick-51-1367929691_stRTERMINAL_dp24/keyboard to appear
May  7 14:28:29 menea /usr/bin/x2golistmounts[4191]: db_getmounts called, session ID: dick-51-1367929691_stRTERMINAL_dp24; return value: 127.0.0.1
|/tmp/.x2go-dick/spool/C-dick-51-1367929691_stRTERMINAL_dp24| 127.0.0.1|/tmp/.x2go-dick/media/disk/_home_dick| 127.0.0.1|/tmp/.x2go-dick/mimebox/C
-dick-51-1367929691_stRTERMINAL_dp24|
May  7 14:28:30 menea /usr/bin/x2gosetkeyboard: Waiting for /home/dick/.x2go/C-dick-51-1367929691_stRTERMINAL_dp24/keyboard to appear
May  7 14:28:34  /usr/bin/x2gosetkeyboard: last message repeated 4 times
May  7 14:28:34 menea /usr/bin/x2golistsessions[4313]: x2golistsessions has been called with no option
May  7 14:28:35 menea /usr/bin/x2golistmounts[4327]: db_getmounts called, session ID: dick-51-1367929691_stRTERMINAL_dp24; return value: 127.0.0.1
|/tmp/.x2go-dick/spool/C-dick-51-1367929691_stRTERMINAL_dp24| 127.0.0.1|/tmp/.x2go-dick/media/disk/_home_dick| 127.0.0.1|/tmp/.x2go-dick/mimebox/C
-dick-51-1367929691_stRTERMINAL_dp24|
May  7 14:28:35 menea /usr/bin/x2gosetkeyboard: Waiting for /home/dick/.x2go/C-dick-51-1367929691_stRTERMINAL_dp24/keyboard to appear
May  7 14:28:40  /usr/bin/x2gosetkeyboard: last message repeated 4 times
May  7 14:28:40 menea /usr/bin/x2golistsessions[4382]: x2golistsessions has been called with no option
May  7 14:28:40 menea /usr/bin/x2golistmounts[4396]: db_getmounts called, session ID: dick-51-1367929691_stRTERMINAL_dp24; return value: 127.0.0.1
|/tmp/.x2go-dick/spool/C-dick-51-1367929691_stRTERMINAL_dp24| 127.0.0.1|/tmp/.x2go-dick/media/disk/_home_dick| 127.0.0.1|/tmp/.x2go-dick/mimebox/C
-dick-51-1367929691_stRTERMINAL_dp24|
May  7 14:28:40 menea /usr/bin/x2gosetkeyboard: Waiting for /home/dick/.x2go/C-dick-51-1367929691_stRTERMINAL_dp24/keyboard to appear
May  7 14:28:42 menea /usr/bin/x2gosetkeyboard: Waiting for /home/dick/.x2go/C-dick-51-1367929691_stRTERMINAL_dp24/keyboard to appear
May  7 14:28:42 menea postfix/smtpd[23561]: connect from menea.int.cvix.nl[127.0.0.1]
May  7 14:28:42 menea postfix/smtpd[23561]: disconnect from menea.int.cvix.nl[127.0.0.1]
May  7 14:28:43 menea /usr/bin/x2gosetkeyboard: Waiting for /home/dick/.x2go/C-dick-51-1367929691_stRTERMINAL_dp24/keyboard to appear
May  7 14:28:45  /usr/bin/x2gosetkeyboard: last message repeated 2 times

running as X2Go Agent

NXAGENT - Version 3.5.0

Copyright (C) 2001, 2011 NoMachine.
See http://www.nomachine.com/ for more information.

Info: Agent running with pid '3729'.
Session: Starting session at 'Tue May  7 14:28:12 2013'.
Info: Proxy running in server mode with pid '3729'.
Info: Waiting for connection from 'localhost' on port '30004'.
Info: Accepted connection from '127.0.0.1'.
Info: Aborting the procedure due to signal '1'.
Error: Aborting session with 'Unable to open display 'nx/nx,options=/home/dick/.x2go/C-dick-51-1367929691_stRTERMINAL_dp24/options:51''.
Session: Aborting session at 'Tue May  7 14:29:12 2013'.
Session: Session aborted at 'Tue May  7 14:29:12 2013'.
session-C-dick-51-1367929691_stRTERMINAL_dp24.log (END)

Met vriendelijke groet,
Dick Kniep
Lindix BV
tel. 036-5215580
mob. 06-50991858