Subject: X2Go issue (in src:x2goserver) has been marked as closed

From: Mike Gabriel <[email-masked]>
Date: Sun, 28 Jul 2013 01:48:21 +0200 (CEST)

close #202
thanks

Hello,

we are very hopeful that X2Go issue #202 reported by you
has been resolved in the new release (4.0.0.5) of the
X2Go source project »src:x2goserver«.

You can view the complete changelog entry of src:x2goserver (4.0.0.5)
below, and you can use the following link to view all the code changes
between this and the last release of src:x2goserver.

    http://code.x2go.org/gitweb?p=x2goserver.git;a=commitdiff;h=c7669b9b74f4fc7c730d2c13e50f66c8b0036525;hp=bc1f6e55a56ca81c64a1236690a05ae1ec2d6c64

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:x2goserver.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:x2goserver
Version: 4.0.0.5
Status: RELEASE
Date: Sun, 28 Jul 2013 01:47:03 +0200
Fixes: 202
Changes: 
 x2goserver (4.0.0.5) RELEASED; urgency=low
 .
   * New upstream version (4.0.0.5):
     - Make x2goumount-session tolerant towards usernames that contain spaces
       (Fixes: #202).

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Sun, 28 Jul 2013 00:01:04 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goserver package:

#202: Possibly breakage in x2goumount-session for usernames that contain spaces

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:x2goserver) has been marked as closed
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Sun, 28 Jul 2013 01:48:21 +0200 (CEST)

close #202
thanks

Hello,

light+love

---

Subject: Strange crash?
From: Dick Kniep <[email-masked]>
To: [email-masked] <[email-masked]>
Date: Tue, 7 May 2013 12:26:02 +0200

package: x2goserver
Severity: normal
Version: 4.0.0.1-0~648~precise1

I get a complaint from a user that when she tries to use the shared disk it will end the connection. Now I noticed that the windows userid has spaces in it and it fails to unmount that one. Maybe that is the cause. This is from syslog

May  7 12:15:20 ambulantehulpverlening /usr/bin/x2gostartagent: successfully started X2Go agent session with ID mal00002-54-1367921719_stRstartcvix.sh_dp17
May  7 12:15:28 ambulantehulpverlening /usr/bin/x2gomountdirs[20495]: successfully mounted Erik van [email-masked]:30012/windrive/C/Users/Erik van Malenstein/.x2go/S-mal00002-54-1367921719_stRstartcvix.sh_dp17/spool to /tmp/.x2go-mal00002/spool/C-mal00002-54-1367921719_stRstartcvix.sh_dp17
May  7 12:15:29 ambulantehulpverlening /usr/bin/x2gomountdirs[20534]: successfully mounted Erik van [email-masked]:30012/windrive/C/Users/Erik van Malenstein/.x2go/S-mal00002-54-1367921719_stRstartcvix.sh_dp17/mimebox to /tmp/.x2go-mal00002/mimebox/C-mal00002-54-1367921719_stRstartcvix.sh_dp17
May  7 12:15:31 ambulantehulpverlening /usr/bin/x2gosetkeyboard: Setting X keyboard according to /home/mal00002/.x2go/C-mal00002-54-1367921719_stRstartcvix.sh_dp17/keyboard
May  7 12:15:33 ambulantehulpverlening /usr/bin/x2gomountdirs[20814]: successfully mounted Erik van [email-masked]:30012/windrive/C/Users/Erik van Malenstein to /tmp/.x2go-mal00002/media/disk/_windrive_C_Users_Erik_van_Malenstein
May  7 12:15:40 ambulantehulpverlening postfix/smtpd[32626]: connect from localhost[127.0.0.1]
May  7 12:15:40 ambulantehulpverlening postfix/smtpd[32626]: disconnect from localhost[127.0.0.1]
May  7 12:16:41 ambulantehulpverlening postfix/smtpd[32626]: connect from localhost[127.0.0.1]
May  7 12:16:41 ambulantehulpverlening postfix/smtpd[32626]: disconnect from localhost[127.0.0.1]
May  7 12:17:01 ambulantehulpverlening CRON[22972]: (root) CMD (   cd / && run-parts --report /etc/cron.hourly)
May  7 12:17:40 ambulantehulpverlening postfix/smtpd[32626]: connect from localhost[127.0.0.1]
May  7 12:17:40 ambulantehulpverlening postfix/smtpd[32626]: disconnect from localhost[127.0.0.1]
May  7 12:18:40 ambulantehulpverlening postfix/smtpd[32626]: connect from localhost[127.0.0.1]
May  7 12:18:40 ambulantehulpverlening postfix/smtpd[32626]: disconnect from localhost[127.0.0.1]
May  7 12:18:58 ambulantehulpverlening /usr/bin/x2goumount-session[25304]: successfully unmounted /tmp/.x2go-hoornjva/spool/C-hoornjva-51-1367917939_stRstartcvix.sh_dp17
May  7 12:18:58 ambulantehulpverlening /usr/bin/x2goumount-session[25304]: successfully unmounted /tmp/.x2go-hoornjva/mimebox/C-hoornjva-51-1367917939_stRstartcvix.sh_dp17
May  7 12:18:59 ambulantehulpverlening /usr/bin/x2goumount-session[25304]: successfully unmounted /tmp/.x2go-hoornjva/media/disk/_windrive_C_Users_Gele
May  7 12:19:40 ambulantehulpverlening postfix/smtpd[32626]: connect from localhost[127.0.0.1]
May  7 12:19:40 ambulantehulpverlening postfix/smtpd[32626]: disconnect from localhost[127.0.0.1]
May  7 12:20:07 ambulantehulpverlening /usr/bin/x2goumount-session[26702]: successfully unmounted /tmp/.x2go-mal00002/spool/C-mal00002-54-1367921719_stRstartcvix.sh_dp17
May  7 12:20:08 ambulantehulpverlening /usr/bin/x2goumount-session[26702]: successfully unmounted /tmp/.x2go-mal00002/mimebox/C-mal00002-54-1367921719_stRstartcvix.sh_dp17
May  7 12:20:08 ambulantehulpverlening /usr/bin/x2goumount-session[26702]: ERROR: failed to unmount /tmp/.x2go-mal00002/media/disk/_windrive_C_Users_Erik_van_Malenstein

Met vriendelijke groet,
Dick Kniep
Lindix BV
tel. 036-5215580
mob. 06-50991858