Subject: X2Go issue (in src:x2goclient) has been marked as pending for release

From: Mike Gabriel <[email-masked]>
Date: Wed, 12 Jun 2013 13:54:53 +0200 (CEST)

tag #179 pending
fixed #179 4.0.1.1
thanks

Hello,

X2Go issue #179 (src:x2goclient) reported by you has been
fixed in X2Go Git. You can see the changelog below, and you can
check the diff of the fix at:

    http://code.x2go.org/gitweb?p=x2goclient.git;a=commitdiff;h=e3b8739

The issue will most likely be fixed in src:x2goclient (4.0.1.1).

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
commit e3b87397d75a7e246d29c4f94b1368e092f27207
Author: Mike Gabriel <[email-masked]>
Date:   Wed Jun 12 13:23:05 2013 +0200

    Add cmdline option --broker-autologoff: Enforce re-authentication against X2Go Session Broker after a session has been suspended or terminated. (Fixes: #179).

diff --git a/debian/changelog b/debian/changelog
index 84daa74..c2dcc38 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -20,6 +20,9 @@ x2goclient (4.0.1.1-0~x2go1) UNRELEASED; urgency=low
       patch was applied. Segfault only occurred if the tray icon was not used.
     - Show session name in notification bubbles.
     - Update German translation.
+    - Add cmdline option --broker-autologoff: Enforce re-authentication against
+      X2Go Session Broker after a session has been suspended or terminated.
+      (Fixes: #179).
 
   [ Ezra Bühler ]
   * New upstream version (4.0.1.1):

---

From: Nable 80 <[email-masked]>
Date: Wed, 12 Jun 2013 16:33:06 +0400

Hi, Mike.

What do you think about making this behaviour default?
Because doing logoff by default seems to be a more secure way (and
default settings should be secure) + it doesn't require you to
close-and-reopen window if you want to de-authenticate from the broker
(and switch to other sessions).
I think it would be a good idea, especially if this session broker
system is mainly aimed at setups with thin clients (less configuration
changes for main use-case).

---

From: Anders Bruun Olsen <[email-masked]>
Date: Wed, 12 Jun 2013 14:55:20 +0200

I personally think that it would be better to de-auth from the broker by
default, and then have a commandline option that tells x2goclient to stay
authenticated to the broker, when the connection to a server ends.

2013/6/12 Nable 80 <[email-masked]>

> _______________________________________________
> X2Go-Dev mailing list
> [email-masked]
> https://lists.berlios.de/mailman/listinfo/x2go-dev
>

-- 
Anders Bruun Olsen
It-ansvarlig
Det Danske Sprog- og Litteraturselskab
(Society for Danish Language and Literature)