Subject: Bug#168: UNITY-2d sessions ignore screen dimensions and make display largest possible

From: "Dan Halbert" <[email-masked]>
Date: Tue, 16 Apr 2013 15:50:35 -0400 (EDT)

Package: x2goserver
Version: 4.0.0.1-0~648~precise1
 
server system: Ubuntu 12.04.2 (using ppa:x2go/stable)
client system: Windows 7 64-bit, tested with latest x2goClient (4.0.0.3) and PyHoca-gui (0.4.0.1)
 
When starting up a UNITY-2d session, the screen dimensions given in the client profile settings are ignored, and a window as large as the display is created. If there are two monitors, the window will span both monitors.
 
I've tried this both in  x2goClient and PyHoca-gui, and the behavior is the same, so I'm guessing this is a server problem.

---

From: Mike Gabriel <[email-masked]>
Date: Thu, 06 Jun 2013 01:04:43 +0200

tag #168 wontfix
thanks

Hi Dan,

please re-enable the XFIXES extension in /etc/x2go/x2goagent.options  
that we disabled by default before the release of X2Go Server 4.0.0.0.

Re-enabling XFIXES in x2goagent will set the correct display size in Unity-2d.

Greets,
Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Wed, 05 Jun 2013 23:18:02 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goserver package:

#168: UNITY-2d sessions ignore screen dimensions and make display largest possible

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
168: http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=168
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: Re-enable XFIXES extension in x2goagent.options
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Thu, 06 Jun 2013 01:04:43 +0200

tag #168 wontfix
thanks

Hi Dan,

Greets,
Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

Subject: UNITY-2d sessions ignore screen dimensions and make display largest possible
From: "Dan Halbert" <[email-masked]>
To: [email-masked]
Date: Tue, 16 Apr 2013 15:50:35 -0400 (EDT)

Package: x2goserver