Subject: Bug#1633: New clipboard issue in Libreoffice with X2Go

From: Jens Reyer <[email-masked]>
Date: Wed, 12 Mar 2025 10:59:56 +0100 (CET)

Package: x2goserver

Version: 4.1.0.6-1.1+b1

Severity: normal

Hi,

since an update/reinstallation copy&pasting in Libreoffice in X2Go always needs to be repeated, only the very first run works instantly.

We found this issue only when using X2Go, but not when working directly on the same machine.

It happens only in Libreoffice (Calc and Writer), but not in e.g. Firefox or an editor.

Starting Libreoffice in safe mode (soffice --safe-mode) does not help.

Steps to reproduce:

Start Libreoffice

ctrl+c, ctrl+v OK

ctrl+c, ctrl+v FAIL (nothing is inserted)

ctrl+c, ctrl+v FAIL (nothing is inserted)

Start Libreoffice

right-click > copy, right-click > paste OK

right-click > copy, right-click > paste FAIL (Libreoffice Calc asks where to shift the cells, but then nothing is inserted)

right-click > copy, right-click > paste FAIL (Libreoffice Calc asks where to shift the cells, but then nothing is inserted)

Workaround:

ctrl+c, ctrl+v OK

ctrl+c, ctrl+c, ctrl+v OK

ctrl+c, ctrl+c, ctrl+v OK

Tested affected servers:

Debian Trixie/Sid Mate (libreoffice 4:24.8.5-2 amd64, x2goserver 4.1.0.6-1.1+b1)

LinuxMint 22.1 Mate (libreoffice 4:24.2.7-0ubuntu0.24.04.2, x2goserver 4.1.0.6-1.1build1)

Previously not affected server:

LinuxMint 21.3 Mate (libreoffice 1:7.3.7-0ubuntu0.22.04.8, x2goserver 4.1.0.3-5)

Tested Clients:

Debian Trixie (x2goclient 4.1.2.3-3)

Linuxmint 22.1 (x2goclient 4.1.2.3-1build3)

Win10 (X2GoClient 4.1.2.2), with the X.org server option "do not use primary clipboard" both checked and unchecked

I reported this issue only here, not with the distros or Libreoffice. Please tell me if I should otherwise or if I should provide additional info or tests.

My boss is willing to pay for a solution. Just contact me.

Thanks in advance and thanks for all your work!

Jens Reyer

---

From: Ulrich Sibiller <[email-masked]>
Date: Wed, 12 Mar 2025 11:13:59 +0100

Hi,

please let us know the version of nxagent (x2goagent) you are using. Also
ensure that there’s no clipboard manager running (on both sides!).

Uli

On Wed, Mar 12, 2025 at 11:11 AM Jens Reyer <[email-masked]>
wrote:

> Package: x2goserver
>
> Version: 4.1.0.6-1.1+b1
>
> Severity: normal
>
>
> Hi,
>
> since an update/reinstallation copy&pasting in Libreoffice in X2Go always
> needs to be repeated, only the very first run works instantly.
>
> right-click > copy, right-click > paste FAIL (Libreoffice Calc asks where
> to shift the cells, but then nothing is inserted)
>
> right-click > copy, right-click > paste FAIL (Libreoffice Calc asks where
> to shift the cells, but then nothing is inserted)
>
>
> Workaround:
>
> ctrl+c, ctrl+v OK
>
> Win10 (X2GoClient 4.1.2.2), with the X.org server option "do not use
> primary clipboard" both checked and unchecked
>
>
> I reported this issue only here, not with the distros or Libreoffice.
> Please tell me if I should otherwise or if I should provide additional info
> or tests.
>
>
> _______________________________________________
> x2go-dev mailing list
> [email-masked]
> https://lists.x2go.org/listinfo/x2go-dev
>

---

From: Jens Reyer <[email-masked]>
Date: Wed, 12 Mar 2025 13:50:51 +0100 (CET)

Hi,

thanks for the quick answer.

x2goagent 4.1.0.6, as provided by the distributions,

so on the affected Debian Trixie/Sid Mate server:

x2goserver-x2goagent 4.1.0.6-1.1+b1

and on LinuxMint 22.1 Mate:

x2goserver-x2goagent 4.1.0.6-1.1build1

To the best of my knowledge there's no clipboard manager running on the systems, neither on the 2 tested servers nor the 3 clients.

Most systems were just set up recently by myself, and I never used or even heard about clipboardmanagers before. Neither clipman nor xclipboard are installed.

Greets

jre

> Ulrich Sibiller <[email-masked]> hat am 12. März 2025 um 11:13 geschrieben:
> 
>     Hi,
> 
>     please let us know the version of nxagent (x2goagent) you are using. Also ensure that there’s no clipboard manager running (on both sides!).
> 
>     Uli
> 
>     On Wed, Mar 12, 2025 at 11:11 AM Jens Reyer <[email-masked] mailto:[email-masked] > wrote:
> 
>         > > 
> >         Package: x2goserver
> > 
> >         Version: 4.1.0.6-1.1+b1
> > 
> >         Severity: normal
> > 
> > 
> >         Hi,
> > 
> >         [email-masked] mailto:[email-masked]

---

From: Ulrich Sibiller <[email-masked]>
Date: Wed, 12 Mar 2025 14:57:08 +0100

Sorry, x2goserver-x2goagent is only a wrapper. The real functionality sits
in the nxagent package, and that's the version I need. Alternatively you
can run /usr/bin/x2goagent -version on the server.

KDE includes a clipboard manager. What DE are you using?

Does the problem also show up when you are using a very simple window
manager like twm or fvwm2 or openbox?

Uli

On Wed, Mar 12, 2025 at 1:55 PM Jens Reyer <[email-masked]>
wrote:

> To the best of my knowledge there's no clipboard manager running on the
> systems, neither on the 2 tested servers nor the 3 clients.
>
> Most systems were just set up recently by myself, and I never used or even
> heard about clipboardmanagers before. Neither clipman nor xclipboard are
> installed.
>
>
> Greets
>
> jre
>
>

---

From: Jens Reyer <[email-masked]>
Date: Thu, 13 Mar 2025 10:28:41 +0100 (CET)

Thanks again.

On both servers:

$ /usr/bin/x2goagent -version

running as X2Go Agent
NXAGENT - Version 3.5.99.27

I installed twm on the Debian Trixie/Sid server, and connected to it from a Linuxmint 22.1 Mate client: Yes The problem is still there.

Or should I also connect from a twm session?

> Ulrich Sibiller <[email-masked]> hat am 12. März 2025 um 14:57 geschrieben:
> 
>     Sorry, x2goserver-x2goagent is only a wrapper. The real functionality sits in the nxagent package, and that's the version I need. Alternatively you can run /usr/bin/x2goagent -version on the server.
> 
>     Does the problem also show up when you are using a very simple window manager like twm or fvwm2 or openbox?
> 
>     Uli
> 
>     On Wed, Mar 12, 2025 at 1:55 PM Jens Reyer <[email-masked] mailto:[email-masked] > wrote:
> 
>         > > 
> >         Hi,
> > 
> >             > > > Ulrich Sibiller <[email-masked] mailto:[email-masked] > hat am 12. März 2025 um 11:13 geschrieben:
> > > 
> > >             Hi,
> > >

---

From: Jens Reyer <[email-masked]>
Date: Thu, 13 Mar 2025 10:31:40 +0100 (CET)

> >         KDE includes a clipboard manager. What DE are you using?

Found with clients on:

Windows 10

Gnome on Debian Trixie

Mate on Linuxmint 22.1

---

From: Ulrich Sibiller <[email-masked]>
Date: Thu, 13 Mar 2025 10:52:25 +0100

Ok, thanks for the information. The nxagent is the current version, that's
ok. Also I think we take out the client from the equation.

I have just tried your reproducer with LibreOffice 6.4.7.2 on RockyLinux
8.10 in a rootless NX session without any problems. Maybe this is tied to
newer LibreOffice versions?

You can also do a very lightweight test locally like this:
1. run nxagent -ac :55
2. DISPLAY=:55 openbox (or any other WM)
3. DISPLAY=:55 soffice -> will open soffice in the nx window.

Is the problem showing up then, too?

Maybe we need more debugging information which would require to recompile
nxagent on your server system.

Uli

On Wed, Mar 12, 2025 at 3:00 PM Ulrich Sibiller <[email-masked]>
wrote:

>> Most systems were just set up recently by myself, and I never used or
>> even heard about clipboardmanagers before. Neither clipman nor xclipboard
>> are installed.
>>
>>
>> Greets
>>
>> jre
>>
>>
>> please let us know the version of nxagent (x2goagent) you are using.
>> Also ensure that there’s no clipboard manager running (on both sides!).
>>
>>
>> Uli
>>
>> On Wed, Mar 12, 2025 at 11:11 AM Jens Reyer <
>> [email-masked]> wrote:
>>
>> Package: x2goserver
>>
>> Version: 4.1.0.6-1.1+b1
>>
>> Severity: normal
>>
>>
>> Hi,
>>

---

From: Jens Reyer <[email-masked]>
Date: Thu, 13 Mar 2025 11:42:52 +0100 (CET)

I could NOT reproduce the problem with your lightweight test on Linuxmint 22.1 Mate:

nxagent -ac :55

DISPLAY=:55 twm

DISPLAY=:55 soffice

--> OK (except maybe one fail, but that was probably human failure)

For the previous non-lightweight-test in twm on the remote Debian Trixie server I started in that x2go/twm session a terminal and from there soffice, since I couldn't find a direct Libreoffice launcher. So I tried this for the lightweight test - still works:

nxagent -ac :55

DISPLAY=:55 twm

DISPLAY=:55 xterm

In xterm: soffice

--> OK

I agree there must be something specific with newer Libreoffice versions, since I neither found this with other applications, nor with libreoffice 7.3.7. But as just discovered this is only an issue with (remote?) X2Go sessions.

> Ulrich Sibiller <[email-masked]> hat am 13. März 2025 um 10:52 geschrieben:
> 
>     Ok, thanks for the information. The nxagent is the current version, that's ok. Also I think we take out the client from the equation.
> 
>     I have just tried your reproducer with LibreOffice 6.4.7.2 on RockyLinux 8.10 in a rootless NX session without any problems. Maybe this is tied to newer LibreOffice versions?
> 
>     Maybe we need more debugging information which would require to recompile nxagent on your server system.
> 
> 
>     Uli
> 
>     On Wed, Mar 12, 2025 at 3:00 PM Ulrich Sibiller <[email-masked] mailto:[email-masked] > wrote:
>

---

From: Jens Reyer <[email-masked]>
Date: Thu, 13 Mar 2025 11:44:51 +0100 (CET)

Sorry for yet another PS:
Yes, I may recompile a test x2goserver, if you tell me what changes/options you need.

> Jens Reyer <[email-masked]> hat am 13. März 2025 um 11:42 geschrieben:
> 
>

---

From: Ulrich Sibiller <[email-masked]>
Date: Thu, 13 Mar 2025 13:08:59 +0100

Hi,

just to be sure: have you done the lightweight test on the server side or
the client side?

Assuming you have done the test on the server side. This indicates that the
problem is somehow tied to the connection. Can you please check if
different connection settings in x2go lead to different results?

You don't need to compile x2goserver, just nxagent. Compiling is done like
this:
1. checkout nx-libs from ArcticaProject on github
2. run make

If this fails you probably need to install more dependencies. If it
succeeds, you need to repeat that after changing these lines in
nx-X11/programs/Xserver/hw/nxagent/Clipboard.c:

#undef TEST -> #define TEST
#undef DEBUG -> #define DEBUG

After running make again you should find a new nxagent in
nx-X11/programs/Xserver

Uli

On Thu, Mar 13, 2025 at 11:45 AM Jens Reyer <[email-masked]>
wrote:

> For the previous non-lightweight-test in twm on the remote Debian Trixie
> server I started in that x2go/twm session a terminal and from there
> soffice, since I couldn't find a direct Libreoffice launcher. So I tried
> this for the lightweight test - still works:
>
> nxagent -ac :55
>
> DISPLAY=:55 twm
>
> DISPLAY=:55 xterm
>
> In xterm: soffice
>
> --> OK
>
>
> I agree there must be something specific with newer Libreoffice versions,
> since I neither found this with other applications, nor with libreoffice
> 7.3.7. But as just discovered this is only an issue with (remote?) X2Go
> sessions.
>
>

---

From: Jens Reyer <[email-masked]>
Date: Thu, 13 Mar 2025 15:03:43 +0100 (CET)

I did the lightweight test on the client side, my local PC at work.

And indeed, if I open a Mate x2go session to localhost's IP on the Linuxmint 22.1 Mate client (so server and client are the same, just different users) I can NOT reproduce the issue.

Now I connected from another client/PC to my PC (so what's usually a client acted now as remote server): the issue still exists but only in about HALF of the cases, while it previously existed consistently in every case after the first try.

In the original tests the server's were VMs (Proxmox PVE).

Tests with connection settings:

Previously I had the issue while connecting to the reomote server with connection LAN (here at work) and probably ADSL (from home). Now I tested the same remote server with MODEM: the issue still exists.

Then I changed the clipboard from bi-directional (German: "Zwischenablage-Modus: Kopieren und Einfügen in beide Richtungen möglich" to disabled ("Zwischenablage komplett deaktivieren"). The issue is NOT reproducible anymore.

So now we've found a workaround, good :)

Setting the keyboard from auto-detect to "Model pc105, layout de" didn't help.

Are there any other settings I should test?

I'll recompile nxagent later.

> Ulrich Sibiller <[email-masked]> hat am 13. März 2025 um 13:08 geschrieben:
> 
>     Hi,
> 
>     just to be sure: have you done the lightweight test on the server side or the client side?
> 
>     Assuming you have done the test on the server side. This indicates that the problem is somehow tied to the connection. Can you please check if different connection settings in x2go lead to different results?
> 
>     You don't need to compile x2goserver, just nxagent. Compiling is done like this:
>     If this fails you probably need to install more dependencies. If it succeeds, you need to repeat that after changing these lines in nx-X11/programs/Xserver/hw/nxagent/Clipboard.c:
> 
>     After running make again you should find a new nxagent in nx-X11/programs/Xserver
> 
>     Uli
> 
> 
> 
>     On Thu, Mar 13, 2025 at 11:45 AM Jens Reyer <[email-masked] mailto:[email-masked] > wrote:
> 
> >             > > > Jens Reyer <[email-masked] mailto:[email-masked] > hat am 13. März 2025 um 11:42 geschrieben:
> > > 
> > > 
> > >                 > > > > Ulrich Sibiller <[email-masked] mailto:[email-masked] > hat am 13. März 2025 um 10:52 geschrieben:
> > > >

---

From: Ulrich Sibiller <[email-masked]>
Date: Thu, 13 Mar 2025 15:15:01 +0100

Hi,

disabling clipboard via these setting will effectively suppress
communication between the client and the server regarding clipboard. All
clipboard communication will then happen between libreoffice and the
nxagent on the server side. No remote communication involved, not slowing
down anything.

So chances are that your communication is too slow. I _think_ playing
around with the other clipboard options will show that it works with one of
the "copy from X to Y" options and not with the other. Can you confirm?

Uli

On Thu, Mar 13, 2025 at 3:03 PM Jens Reyer <[email-masked]>
wrote:

> And indeed, if I open a Mate x2go session to localhost's IP on the
> Linuxmint 22.1 Mate client (so server and client are the same, just
> different users) I can NOT reproduce the issue.
>
>
> Now I connected from another client/PC to my PC (so what's usually a
> client acted now as remote server): the issue still exists but only in
> about HALF of the cases, while it previously existed consistently in every
> case after the first try.
>
>
> Previously I had the issue while connecting to the reomote server with
> connection LAN (here at work) and probably ADSL (from home). Now I tested
> the same remote server with MODEM: the issue still exists.
>
>
> Then I changed the clipboard from bi-directional (German:
> "Zwischenablage-Modus: Kopieren und Einfügen in beide Richtungen möglich"
> to disabled ("Zwischenablage komplett deaktivieren"). The issue is NOT
> reproducible anymore.
>
> Assuming you have done the test on the server side. This indicates that
> the problem is somehow tied to the connection. Can you please check if

---

From: Jens Reyer <[email-masked]>
Date: Mon, 17 Mar 2025 12:53:03 +0100 (CET)

Hi

I recompiled nx-libs (based on the current Debian 2:3.5.99.27-2 code, NXAGENT Version 3.5.99.27). I hope this works, tell me if I need to switch to the Arctica code). There I enabled TEST and DEBUG and installed those packages.
Attached is a session.log (Mate, with LibreCalc autostarted, where I first type in a cell, then do a successful ctrl+c, ctrl+v, then a failed one and then a successful one.

results for different clipboard settings:

Clipboard bidirectional between client and server: first, and then every second attempt work

Clipboard client to server: half of the attempts fail, no clear pattern which ones fail

Clipboard server to client: everything works

Clipboard between server and client disabled: everything works

Thanks!

> Ulrich Sibiller <[email-masked]> hat am 13. März 2025 um 15:15 geschrieben:
> 
>     Hi,
> 
>     disabling clipboard via these setting will effectively suppress communication between the client and the server regarding clipboard. All clipboard communication will then happen between libreoffice and the nxagent on the server side. No remote communication involved, not slowing down anything.
> 
>     So chances are that your communication is too slow. I _think_ playing around with the other clipboard options will show that it works with one of the "copy from X to Y" options and not with the other. Can you confirm?
> 
>     Uli
> 
> 
>     On Thu, Mar 13, 2025 at 3:03 PM Jens Reyer <[email-masked] mailto:[email-masked] > wrote:
> 
>         > > 
> >             > > > Ulrich Sibiller <[email-masked] mailto:[email-masked] > hat am 13. März 2025 um 13:08 geschrieben:
> > > 
> > >             Hi,
> > >

---

From: Ulrich Sibiller <[email-masked]>
Date: Mon, 17 Mar 2025 13:13:31 +0100

Hi,

I don't know the differences between the x2go repo (I have nothing to do
with this; I am developing solely on the arctica repo) and the arctica
repo. But since this is 3.5.99.27 there shouldn't be too many differences,
especially regarding clipboard. So this is ok.

The results are interesting (and match my assumptions). Now that we know
that the client to server synchronisation is the culprit we can deduce some
problem on the client side. I will scan the logfile later, maybe it will
shine some light on the issue. For now it might be interesting to know if
the server server clipboard can be pasted _on the client side_.

Uli

On Mon, Mar 17, 2025 at 12:55 PM Jens Reyer <[email-masked]>
wrote:

> Hi
>
>
> I recompiled nx-libs (based on the current Debian 2:3.5.99.27-2 code,
> NXAGENT Version 3.5.99.27). I hope this works, tell me if I need to switch
> to the Arctica code). There I enabled TEST and DEBUG and installed those
> packages.
> Attached is a session.log (Mate, with LibreCalc autostarted, where I first
> type in a cell, then do a successful ctrl+c, ctrl+v, then a failed one and
> then a successful one.
>
>

---

From: Jens Reyer <[email-masked]>
Date: Mon, 17 Mar 2025 14:29:52 +0100 (CET)

Hi,

tested from remote server with bidirectional clipboard Libre Calc to local Libre Calc : if pasting works on the server it also works on the client. If it doesn't work on the server it also doesn't work on the client:

crtl+c, ctrl+v(server): ok, ctrl+v(client): ok

crtl+c, ctrl+v(server): fail, ctrl+v(client): fail

crtl+c, ctrl+v(server): ok, ctrl+v(client): ok

> Ulrich Sibiller <[email-masked]> hat am 17. März 2025 um 13:13 geschrieben:
> 
>     Hi,
> 
>     I don't know the differences between the x2go repo (I have nothing to do with this; I am developing solely on the arctica repo) and the arctica repo. But since this is 3.5.99.27 there shouldn't be too many differences, especially regarding clipboard. So this is ok.
> 
>     The results are interesting (and match my assumptions). Now that we know that the client to server synchronisation is the culprit we can deduce some problem on the client side. I will scan the logfile later, maybe it will shine some light on the issue. For now it might be interesting to know if the server server clipboard can be pasted _on the client side_.
> 
>     Uli
> 
> 
> 
> 
>     On Mon, Mar 17, 2025 at 12:55 PM Jens Reyer <[email-masked] mailto:[email-masked] > wrote:
> 
>         > > 
> >         Hi
> > 
> > 
> >             > > > Ulrich Sibiller <[email-masked] mailto:[email-masked] > hat am 13. März 2025 um 15:15 geschrieben:
> > > 
> > >             Hi,
> > >

---

From: Ulrich Sibiller <[email-masked]>
Date: Mon, 17 Mar 2025 21:35:59 +0100

Hello again,

I had a look at the logfile. It's been a while since I worked on the
clipboard code. But I _think_ there are a few things you should test:

- restrict clipboard to text only: add X2GO_NXAGENT_DEFAULT_OPTIONS+="
-textclipboard" to /etc/x2go/x2goagent.options on the server side and
start a NEW session (no reconnect). Does that help?

- not sure what exactly you have been doing while creating the session
log. But I can seen "caja" on the server side requesting clipboard.
Please try to run a session without caja (which is a file manager,
unclear what it does with selections).

- it _looks_ like something on the client side is requesting the
clipboard when you are doing your tests. The question is what program
is doing that. If possible run a few programs on the client side,
preferably only a very simple session (fvwm twm or so) and an xterm.
Run x2goclient from there.
To find out what program on the client side is requesting the
clipboard you can check the server log file for lines like this:
nxagentHandleSelectionRequestFromXServer: Received
SelectionRequestEvent from real server: selection [529][CLIPBOARD]
target [469][TARGETS] requestor
[display[nx,options=/tmp/.x2go-localadmin/C-localadmin-50-1742211621_stDMATE_dp24/options:50.0]/0xe09e31]
destination [386][GDK_SELECTION] time [13640727]. The bold number is
the requestor. You can check that with xwininfo -id <number> on the
client.

- there's an option to include the clipboard content (or rather the
data being transferred) in the session log in DEBUG mode. This helps
in identifying what stage we are in. Change #undef
PRINT_CLIPBOARD_CONTENT_ON_DEBUG to #define and recompile

- while at it you could also try to change the timeout for the
clipboard transfer. I hardcoded 5s when I wrote all this and it was ok
for me ever since. But YMMV. #define CONVERSION_TIMEOUT 5000. In your
log I see errors like this "nxagentConvertSelection: got new request
before timeout expired on previous request, notifying failure to
client [20] (addr [0x557c39ea2f40] PID [18630] Cmd
[/usr/lib/libreoffice/program/soffice.bin])". This means that the
previous clipboard-related communication has not finished when soffice
starts another request which then is denied. So this indicates that
some answer from the client side is still due. I suspect that this
answer is never sent so your diagnosis that every second paste is
working might in fact resemble a 5s pattern. Meaning: you can only
successfully paste every 5s, but not quicker. So I suggest to decrease
the timeout to 2s or so and see if that makes a difference for you.
One thing here is strange here, though: Doing a copy in soffice on the
server side makes soffice the clipboard owner. So while you are
working inside soffice there should be no communication to the client
that awaits any answer. Which again leads me to the suspicion that
there's some clipboard manager involved.

- x11 clipboard transfers are size restricted. That means that bigger
selections are to be transferred to the requestor in multiple packets.
nx does not support this currently, so you are restricted to 256kB. Is
it possible that your selection is bigger than that?

- I also see SelectionClear requests from the client side. Which also
indicates there's something dealing with clipboard on the client side.

- I played around with these tools:
https://github.com/phillbush/xcliputils Using xclipowner -w you can
watch if the clipboard owner changes. Run that on the client and then
do clipboard stuff in libreoffice on the server. The owner as printed
by xclipowner should never change except for the first time. If it
does we have another indication of a clipboard-manager-in-the-middle
attack ;-)

Hope that helps!

Uli

On Mon, Mar 17, 2025 at 1:13 PM Ulrich Sibiller
<[email-masked]> wrote:
> On Mon, Mar 17, 2025 at 12:55 PM Jens Reyer <[email-masked]> wrote:
>>
>> Hi
>>
>>
>> On Thu, Mar 13, 2025 at 3:03 PM Jens Reyer <[email-masked]> wrote:
>>
>> On Thu, Mar 13, 2025 at 11:45 AM Jens Reyer <[email-masked]> wrote:
>>
>> On Wed, Mar 12, 2025 at 3:00 PM Ulrich Sibiller <[email-masked]> wrote:
>>
>> On Wed, Mar 12, 2025 at 1:55 PM Jens Reyer <[email-masked]> wrote:
>>
>> Hi,
>>
>> On Wed, Mar 12, 2025 at 11:11 AM Jens Reyer <[email-masked]> wrote:
>>
>> Package: x2goserver
>>
>> Version: 4.1.0.6-1.1+b1
>>
>> Severity: normal
>>
>>
>> Hi,
>>

---

From: Jens Reyer <[email-masked]>
Date: Tue, 25 Mar 2025 11:59:33 +0100 (CET)

Hi

sorry for the late reply. I made my answers inline:

> 
>     Ulrich Sibiller <[email-masked]> hat am 17. März 2025 um 21:35 geschrieben:
> 
>     Hello again,
> 
>         * restrict clipboard to text only: add X2GO_NXAGENT_DEFAULT_OPTIONS+="

No, same behavior.

But I kept this setting for all further tests.

>         * not sure what exactly you have been doing while creating the sessionlog. But I can seen "caja" on the server side requesting clipboard.

See new session.log without any caja mention, from a client with twm/xterm to a session with twm on the server. There I started xterm, then did a "libreoffice --calc /home/localadmin/test.ods" and did several ctrl+c ctrl+v in that calc document.

>         * it _looks_ like something on the client side is requesting theclipboard when you are doing your tests. The question is what program

The bold marking went missing, so I just  tested all ids.

>From client mate to server twm I always get "No such window ...", e.g.

me@client:~$ xwininfo -id 531
X Error: 9: Bad Drawable
Request Major code: 14
ResourceID in failed request: 0x213
Serial number of failed request: 3
xwininfo: error: No such window with id 0x213.

Then I tested from the twm/xterm client to a twm/xterm session on the server, see the attached Bug1633_nxagentHandleSelectionRequestFromXServer.log

>         * there's an option to include the clipboard content (or rather thedata being transferred) in the session log in DEBUG mode. This helps

Done, see new session.log.

>         * while at it you could also try to change the timeout for theclipboard transfer. I hardcoded 5s when I wrote all this and it was ok

First I tried waiting for 15 seconds after copying: this does NOT help.

Then I recompiled with #define CONVERSION_TIMEOUT 2000, same behavior, see new session.log

>         * x11 clipboard transfers are size restricted. That means that biggerselections are to be transferred to the requestor in multiple packets.

No, its always just a few characters.

>         * I also see SelectionClear requests from the client side. Which alsoindicates there's something dealing with clipboard on the client side.
> 

I still see SelectionClear in the new twm/xterm to twm/xterm session.log, but I'm not sure which side they are from.

>         * I played around with these tools:https://github.com/phillbush/xcliputils Using xclipowner -w you can

>From client Mate to server twm a successful ctrl+c results in

0x03C0016A

and a failed ctrl+c results in a

0x00000000
0x03C0016A

>From twm/xterm client to a twm/xterm session on the server both failed and successful ctrl+c results in

0x00E0016A

Thanks and greets

---

From: Ulrich Sibiller <[email-masked]>
Date: Wed, 26 Mar 2025 22:55:36 +0100

thanks, review will take some time....

Uli

On Tue, Mar 25, 2025 at 12:00 PM Jens Reyer
<[email-masked]> wrote:
> restrict clipboard to text only: add X2GO_NXAGENT_DEFAULT_OPTIONS+="
> not sure what exactly you have been doing while creating the sessionlog. But I can seen "caja" on the server side requesting clipboard.
> it _looks_ like something on the client side is requesting theclipboard when you are doing your tests. The question is what program
> there's an option to include the clipboard content (or rather thedata being transferred) in the session log in DEBUG mode. This helps
> while at it you could also try to change the timeout for theclipboard transfer. I hardcoded 5s when I wrote all this and it was ok
> x11 clipboard transfers are size restricted. That means that biggerselections are to be transferred to the requestor in multiple packets.
> I also see SelectionClear requests from the client side. Which alsoindicates there's something dealing with clipboard on the client side.
>
> I played around with these tools:https://github.com/phillbush/xcliputils Using xclipowner -w you can

---

From: Ulrich Sibiller <[email-masked]>
Date: Fri, 4 Apr 2025 00:17:19 +0200

Hi,

I have not fully understood yet what's going with your setup and will
go on with checking.

However, I see ibus-related communication which I do not see on my
setup. I have no experience with ibus or X input methods in general. I
see ibus working with selections and _maybe_ it triggers a bug in my
code that has been undetected yet. I would like to ask you to repeat
testing after disabling/uninstalling ibus. I am wondering if you
installed that on purpose or not.

Uli

---

From: Jens Reyer <[email-masked]>
Date: Mon, 7 Apr 2025 13:51:19 +0200 (CEST)

Hi Uli,

Attached a new session.log without any ibus mentioning - still the same issue: only the first copy and then every second copy succeed.

For this I uninstalled ibus on both client and server. The session.log is from starting a terminal, then "libreoffice --calc /home/localadmin/test.ods" and then 7 ctrl+c / ctrl+v.

About the setup:

Client (PC, Linux Mint 22.1, twm) and server (Proxmox VM, Debian trixie/sid (testing/unstable), twm, libreoffice 25.2.2.2) are on the same 1Gbit LAN. For testing so far I changed all mentioned characteristics for both server and client (PC/VM, Linux Mint 22/22.1 / Debian, Gnome/Mate/Windows (client)/twm, LAN/VDSL). Using a PC as server or local session helps a bit.

So in my setup the relevant factor is Libreoffice 24 or above (last known good version was Libreoffice 7.3.7) in a x2go session with clipboard client to server enabled.

Greets
Jens

> 
>     Ulrich Sibiller <[email-masked]> hat am 4. April 2025 um 00:17 geschrieben:
> 
>     Hi,
>