Subject: Bug#163: X2Go issue (in src:x2goserver) has been marked as closed

From: Mike Gabriel <[email-masked]>
Date: Sun, 19 May 2013 00:55:40 +0200 (CEST)

close #163
thanks

Hello,

we are very hopeful that X2Go issue #163 reported by you
has been resolved in the new release (4.0.0.2) of the
X2Go source project »src:x2goserver«.

You can view the complete changelog entry of src:x2goserver (4.0.0.2)
below, and you can use the following link to view all the code changes
between this and the last release of src:x2goserver.

    http://code.x2go.org/gitweb?p=x2goserver.git;a=commitdiff;h=d035421386eb85627f23628e69e0c0b07ebb7c8c;hp=6a78a843e29b9169ed7e64735908f308eacd4951

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:x2goserver.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:x2goserver
Version: 4.0.0.2
Status: RELEASE
Date: Sun, 19 May 2013 00:54:34 +0200
Fixes: 103 149 163 200
Changes: 
 x2goserver (4.0.0.2) RELEASED; urgency=low
 .
   [ Matthew L. Dailey ]
   * New upstream version (4.0.0.2):
     - Do parse profile/xprofile files in X2Go's Xsession file. (Fixes: #149).
 .
   [ Jan Engelhardt ]
   * New upstream version (4.0.0.2):
     - Use x2gopath in Perl scripts to set the lib path. (Fixes: #103).
 .
   [ Mike Gabriel ]
   * New upstream version (4.0.0.2):
     - Use make_path from File::Path in x2godbadmin to create user directory if
       not present. (Fixes: #200).
     - Security fix for setgid wrapper x2gosqlitewrapper.c. Hard-code path to
       x2gosqlitewrapper.pl during build via defining a macro in the Makefile.
       Thanks to Richard Weinberger for spotting this!!!
   /debian/control:
     + Let x2goserver bin:package depend on xfonts-base and fontconfig. (Fixes:
       #163).
     + Create session log symlink after launching x2goagent. Fix order of target
       and symlink name when executing the command.

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Sat, 18 May 2013 23:01:19 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goserver package:

#163: [packaging-Debian] x2goserver should depend on X11 font utilities

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:x2goserver) has been marked as closed
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Sun, 19 May 2013 00:55:40 +0200 (CEST)

close #163
thanks

Hello,

light+love

---

Subject: [packaging-Debian] x2goserver should depend on X11 font utilities
From: Dániel Kondor <[email-masked]>
To: [email-masked]
Date: Mon, 8 Apr 2013 17:39:38 +0200

Package: x2goserver
Version: 4.0.0.1-0~x2go1+wheezy~main~648~build1

Hi,

we recently installed the X2Go server to a headless server machine, which
does not have a normal X server installed. After installing the x2goserver
package and required dependencies we could not log in to the machine, the
relevant error in the logfile ('/tmp/.x2go-*/*.log) was:

Error: Aborting session with 'Could not open default font 'fixed''.

After manually installing the following (X server font handling related)
Debian packages, the problem was fixed: fontconfig, libxfont1,
xfonts-base, xfonts-encodings, xfonts-utils.

I suppose these packages should be a dependency of x2goserver?

The server has Debian Wheezy installed, the x2go server package was
obtained from the X2Go Debian repository:
'http://packages.x2go.org/debian/wheezy/main amd64 Packages'.

Regards:

Dániel Kondor