Subject: Bug#1624: Sound dies after sleep

From: Adam Klobukowski <[email-masked]>
Date: Wed, 31 Jan 2024 10:34:54 +0100

Package: x2goclient
Version: 4.1.2.2

Platform: Windows 10

Steps to reproduce:
1. Setup client to run sound playing app on host
2. Connect to host
3. Play sound in host app - works as expected (sound on client side)
4. Client machine goes into sleep mode
5. Wait enough time for connection to timeout
6. Restore client to full power
7. Restore session in x2go client
8. Play sound in host app - no sound on client side

Tested with:
Host: Ubuntu 23.04, x2go server from Ubuntu packages
Client: Windows 10 22H2, QT5 x2goclient 4.1.2.2 downloaded from x2go.org
Client-side app used: Google Chrome (installed from Ubuntu packages)

-- 
Semper Fidelis

Adam Klobukowski
[email-masked]

---

From: Microsoft on behalf of IHME <[email-masked]>
Date: Sun, 21 Jun 2026 06:45:48 +0000

Verify your email address

Thanks for verifying your [email-masked] account!

Your code is: 916735

Sincerely,

IHME

This message was sent from an unmonitored email address. Please do not reply to this message.

---

From: Microsoft on behalf of IHME <[email-masked]>
Date: Sun, 21 Jun 2026 06:53:11 +0000

Your code is: 935834

Sincerely,

IHME

---

From: Microsoft on behalf of IHME <[email-masked]>
Date: Sun, 21 Jun 2026 07:01:11 +0000

Your code is: 339690

Sincerely,

IHME

---

From: Microsoft on behalf of IHME <[email-masked]>
Date: Sun, 21 Jun 2026 07:08:07 +0000

Your code is: 414292

Sincerely,

IHME

---

From: IHME GBD Results Tool <[email-masked]>
Date: Sun, 21 Jun 2026 07:37:06 +0000

Thank you for your interest in the Global Burden of Disease (GBD)
and for using the GBD Results tool. Your data files are being prepared for download.
We will notify you when they are ready. You can monitor progress by clicking this link:

http://vizhub.healthdata.org/gbd-results/result/59f61163a11c9136b9c2bc9d892bb35a

The IHME Data Team.

---

From: IHME GBD Results Tool <[email-masked]>
Date: Sun, 21 Jun 2026 07:37:11 +0000

Thank you for your interest in the Global Burden of Disease (GBD) and for
using the GBD Results tool. Your data files are ready for you to access:

The data will be available to download for 7 days, after which you will need to request the data again. To save space and to make it easier for you to download, the files are provided in .zip format. If
you are unfamiliar with this format, this is a compressed file format, which you will need to
decompress in order to access. If you do not have a utility to decompress the files, there are a
number of free utilities available online.

If you have questions about the data you have downloaded, please contact [email-masked].

Explore the GBD results in GBD Compare and
our other interactive data visualizations. More background on GBD is available on our
GBD pages.

The IHME Data Team.