Subject: Bug#1579: x2Goclient crashes with error "Can't start X.org Server. Please check your installation"

From: "Peter Geelen (Quest For Security)" <[email-masked]>
Date: Thu, 13 Jan 2022 16:16:12 +0000

Package: X2goclient
Version: 4.1.2.2.-2020-02-13

Operating system
Windows 10 version 2005 (OS build 19041.1415)

Issue
The x2go client worked the last few days.
Suddenly I could not start the app anymore and it crashes with an error

"Can't start X.org Server.
Please check your installation"

Error Screenshot

Error message
"Can't start X.org Server.
Please check your installation"

I can't even disable the error, as soon as the error is displayed, the application crashes.

Troubleshooting/analysis

Possibly a Windows update crashed the application, but I cannot find any proof or logging what exactly is crashing.

Eventviewer:

EventID 0
The following information was included with the event:

sshd: PID 14632: error: Bind to port 7022 on :: failed: Operation not permitted.

The request is not supported

And also

The following information was included with the event:

sshd: PID 14632: fatal: Cannot bind any address.

The request is not supported

Kind regards,
Peter GEELEN

---

From: "Peter Geelen (Quest For Security)" <[email-masked]>
Date: Sat, 15 Jan 2022 18:13:51 +0000

After uninstallation of the X2Go Client, it looks like there are some leftovers on disk and the registry that corrupt or cripple the re-installation.

You can reinstall, after manually removing
- X2Go files (including session config and vcxsrv files) from from the user profile folder
- X2GO file references (to the installation and user folder) from the registry

Then it looks like the X2GO client can be reinstalled and reconnect to the remote sessions without issue.
Just to be clear, as the sessions are removed, they have to be reconfigured.

Kind regards,
Peter

---

From: <[email-masked]>
Date: Sun, 18 Jan 2026 12:13:13 -0000

On Sat, 15 Jan 2022 18:13:51 +0000 "Peter Geelen (Quest For Security)"
<[email-masked]> wrote: 
> After uninstallation of the X2Go Client, it looks like there are some
leftovers on disk and the registry that corrupt or cripple the
re-installation.

> Just to be clear, as the sessions are removed, they have to be
reconfigured. 

Is there no way whatsoever to reset e.g. settings rather than have to do a
complete reinstall and lose all configs? 

For example, as per 
https://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=1369
when I attempted to add "-noprimary" to the vcserv serve custom command line
under X2Go->Settings when I restart x2go it now _immediately_ crashes with
"can't start x.org.server" making my x2go setup completely useless

i.e. I know what caused my instability, so surely there's a way to fix
without a full wipe + install?!

Yours, 

Michael

GreenCompute.UK <https://greencompute.uk/> 

HighEndCompute <https://highendcompute.co.uk/>

---

From: <[email-masked]>
Date: Sun, 18 Jan 2026 12:29:21 -0000

I was able to fix this problem by changing Win11 registry entry
HKEY_CURRENT_USER\Software\Obviously Nice\x2goclient\settings\useintx
(use internal X) from false back to true. (I didn't have xcXsrv installed so
setting it back to use internal worked without having to do full install)