Subject: Bug#1561: bug of ssh daemon\s public host key

From: guo jiawei <[email-masked]>
Date: Tue, 24 Aug 2021 06:36:22 +0000

Package: X2GO Client

Version: 4.1.2.2

My x2go client can’t work. It report an error that “SSH daemon failed to opean it’s public host key. You have enabled remote printing or file sharing. The features require a running and functioning SSH server on your computer.Pringting and file sharing will be disable for this session. Normally this should not happen as X2GOclient for windows ships its own internal SSH server and automatically generates the required keys.”.

And it asks me to report a bug on //wiki.x2go.org/doku.php/wiki:bugs

It says disabling remote Pringting or file sharing support in the session setting will get rid of this message.

Thank you a lot

Jiawei Guo

从 Windows 版邮件<https://go.microsoft.com/fwlink/?LinkId=550986>发送

---

From: guo jiawei <[email-masked]>
Date: Tue, 24 Aug 2021 06:52:01 +0000

Hello,

After I got the issue with the ssh file, there will be a flashback of x2go client on my computer(win10)

Best regards
Jiawei Guo