Subject: Copy & Paste images with x2goserver and x2goserver-x2gokdrive

From: Miguel Quero <[email-masked]>
Date: Mon, 24 May 2021 20:10:56 +0200

Package: x2goclient
Version: 4.1.2.3

Hi,
First of all congratulate you for your great work with x2go.
We have been using x2go for years in research and reporting environments.
The problem we have is that usually in these environments the copy and
paste of images is very common. Currently we overcome this problem
with the option to share folders but we would like to make the
environment more agile by allowing to copy and paste images from the
client to the server. After investigating the options we have found
the following:
1) If the connection is made through the new kdrive, the clipboard
shares images correctly. For example:
* Client side: xclip -selection clip -t image/jpg -i hades.jpeg
* X2go Kdrive Server side: a simple ctrl-v on a document opened on the
server and the image is copied perfectly.
* Problems: The problem is kdrive itself that for example for Spanish
language neither accents nor many symbols work: (á ^ ä ç à ...).

2) With normal x2go:
* Client side: xclip -selection clip -t image/jpg -i hades.jpeg
* SSH normal contextion: The clipboard is shared ok
 xclip -selection clipboard -t TARGETS -o
TARGETS
image/jpg
* X2go Server side: Nothing appear in clipboard :(

Any ideas?

---

From: Stefan Baur <[email-masked]>
Date: Mon, 24 May 2021 20:26:16 +0200

> * X2go Server side: Nothing appear in clipboard :(

Normal X2Go is based on the NX-Libraries. About 9 months ago, Uli (see
CC:) added code that allows copying more than just plaintext via the
clipboard. This isn't part of the X2Go stable release yet, though.

If you're interested, I'm sure we could speed things up with some $$$
(or rather, €€€) funding ... does your company have a budget for this? :)

-Stefan

-- 
BAUR-ITCS UG (haftungsbeschränkt)
Geschäftsführer: Stefan Baur
Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364
Fon/Fax 0731 40 34 66-36/-35 | USt-IdNr.: DE268653243

---

From: Miguel Quero <[email-masked]>
Date: Wed, 26 May 2021 18:50:26 +0200

Of course, I think my company was starting a project to help the
development of some opensource projects.
I am from the technical side and I don't have visibility but I have just
escalated it in case they tell me something. I don't think it's a big deal,
we are a small company, but something will surely help.
Best regards.

El lun., 24 may. 2021 20:15, X2Go Bug Tracking System <[email-masked]>
escribió:

> Thank you for filing a new Bug report with X2Go.
>
> You can follow progress on this Bug here: 1548:
> https://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=1548.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
>  X2Go Developers <[email-masked]>
>
> If you wish to submit further information on this problem, please
> send it to [email-masked].
>
> Please do not send mail to [email-masked] unless you wish
> to report a problem with the Bug-tracking system.
>
> --
> 1548: https://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=1548
> X2Go Bug Tracking System
> Contact [email-masked] with problems
>