Subject: Bug#1541: x2go graphics issue on MacOS Big Sur

From: Kailin Zhuang <[email-masked]>
Date: Mon, 19 Apr 2021 12:57:50 -0700

Package: x2goclient
Version: 4.1.2.1

I'm using X2Go to run scientific software on our campus compute cluster
(since 2019).
I recently installed X2Go on a new MacBook Pro 2020 with the M1 chip
running Big Sur.

Immediately after launching X2Go, the following message repeats about 10
times per minute until I close X2Go:

        com.apple.xpc.launchd[1] (com.apple.mdworker.shared.XXX): Service
exited due to SIGKILL | sent by mds[499]\

When I start Matlab (a scientific application I use for research), the x2go
window turns black and becomes unusable.
I'm enclosing a screenshot.

The same Matlab software works as expected (no display problems) when I run
it remotely via ssh (with X11 forwarding enabled) instead of X2Go.

---

From: Robin Ince <[email-masked]>
Date: Fri, 4 Mar 2022 14:10:20 +0000

I am seeing this same bug trying to use Matlab in an x2go session on an M1
mac
OS X 12.2.1
XQuartz 2.8.1 (xorg-server 1.20.11)
X2Go Client v. 4.1.2.2 (Qt - 4.8.7)

For me it actually goes OK as long as X2go X11 window is in the background,
but as soon as it gets focus there are these black distortions and tracers
when moving windows.

---

From: Nicola Thibault <[email-masked]>
Date: Tue, 24 May 2022 16:02:38 +0000

Hello,

I am trying to run X2go with MATLAB on my Macbook PRO with a M1 chip and it seems it’s not working fine.

It looks like the following image. It seems to be a well documented bug with the new MAC M1 chip.

Is there a solution to this bug, if not are you currently working on a fix?

Have a nice day,

Nicola Thibault, B.A.
Étudiant au doctorat en psychologie concentration neuropsychologie - Ph. D. Recherche et intervention
Laboratoire de la psychologie de la perception
Laboratoire du Prof. Albouy - CERVO
Auxiliaire d'enseignement
Université Laval

---

From: Orion Poplawski <[email-masked]>
Date: Fri, 12 Aug 2022 16:21:53 -0600

XQuartz issue: https://github.com/XQuartz/XQuartz/issues/31

On 4/19/21 13:57, Kailin Zhuang wrote:
> Package: x2goclient
> Version: 4.1.2.1
> 
> I'm using X2Go to run scientific software on our campus compute cluster (since
> 2019).
> I recently installed X2Go on a new MacBook Pro 2020 with the M1 chip running
> Big Sur.
> 
> Immediately after launching X2Go, the following message repeats about 10 times
> per minute until I close X2Go:
> 
> The same Matlab software works as expected (no display problems) when I run it
> remotely via ssh (with X11 forwarding enabled) instead of X2Go.
> 
> _______________________________________________
> x2go-dev mailing list
> [email-masked]
> https://lists.x2go.org/listinfo/x2go-dev

-- 
Orion Poplawski
IT Systems Manager                         720-772-5637
NWRA, Boulder/CoRA Office             FAX: 303-415-9702
3380 Mitchell Lane                       [email-masked]
Boulder, CO 80301                 https://www.nwra.com/