Subject: Bug#1529: x2goclient crashes when attempting connection through proxy

From: Fabio Rossi <[email-masked]>
Date: Tue, 2 Mar 2021 15:19:28 +0100 (CET)

Package: x2goclient
Version: 4.1.2.2 windows

I have created a tunnel to a proxy server on a local port. I have then configured x2goclient pointing the local port as SSH proxy. As soon as I try starting the configured connection, I insert the credentials (both to target x2go server and proxy server) and then I get a crash:

Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	x2goclient.exe
  Application Version:	0.0.0.0
  Application Timestamp:	057066f0
  Fault Module Name:	ntdll.dll
  Fault Module Version:	6.1.7601.24545
  Fault Module Timestamp:	5e0eb751
  Exception Code:	c0000005
  Exception Offset:	0002e4f3
  OS Version:	6.1.7601.2.1.0.256.48
  Locale ID:	1040
  Additional Information 1:	0a9e
  Additional Information 2:	0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:	0a9e
  Additional Information 4:	0a9e372d3b4ad19135b953a78882e789

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\windows\system32\en-US\erofflps.txt

---

From: Fabio Rossi <[email-masked]>
Date: Tue, 2 Mar 2021 15:44:10 +0100 (CET)

I have tested the older version 4.1.2.0 and it works correctly so it seems a regression of latest version. I have tried the debugging mode but there is no useful information in the console