Subject: Bug#1513: X2Go client v4.1.2.x (mswin32) crashes when starting "gitk"

From: "Abt, Johannes" <[email-masked]>
Date: Mon, 28 Dec 2020 09:57:23 +0000

Package: x2goclient
Version: 4.1.2.2

I'm using x2goclient on Win10. 

Steps to reproduce the problem:

* I start/resume a session on RHEL7.4 with x2goserver-4.1.0.3-9.el7.x86_64. I used "konsole" to start my custom session.
* I change to a directory that is under git revision control.
* I start "gitk".

Result: A window pops up: "VcXsrv windows xserver has stopped working: "A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available." Button: "Close program" All remote windows are closed.

When I resume the session, the "gitk" window is "restored" as open. It seems there has not been any problem for the x2goserver.

Same problem for all other x2goclient versions known to me on MS Windows (i.e. since 2015).

---

From: Stefan Baur <[email-masked]>
Date: Fri, 16 Dec 2022 15:10:54 +0100

Hi,

I was able to reproduce this bug with the X2Go/NX-Libs packages in EPEL 
on CentOS7.

Using our current nightly builds, the problem is gone.
So I would consider it a server-side issue, probably with NX-Libs.

There seems to be a bit of a version mismatch between what is in EPEL 
and what is in heuler (our nightly builds), though.

I would hope that the problem fixes itself once we push a new release 
and EPEL copies it.

However, making sure that a release actually fixes the issue requires a 
closer look at the actual package contents in both EPEL and heuler.

It seems EPEL has built its version of NX-Libs not based on our sources 
but based on source hosted by Arctica, and decided to give the package a 
higher version number than what we are currently using for the packages 
in Heuler.
So this may cause some further trouble down the road.

Kind Regards,
Stefan Baur

-- 
BAUR-ITCS UG (haftungsbeschränkt)
Geschäftsführer: Stefan Baur
Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364
Fon/Fax 0731 40 34 66-36/-35 | USt-IdNr.: DE268653243