Subject: Profile files not being sources in x2goserver-xsession

From: "Matthew L. Dailey" <[email-masked]>
Date: Mon, 25 Mar 2013 12:17:33 -0400

Package: x2goserver
Version: 4.1.0.0

Greetings,

When launching X sessions, x2goserver-xsession does not source the following files:

/etc/profile
$HOME/.profile
/etc/xprofile
$HOME/.xprofile

This can lead to problems if important things are needed from these files, usually PATH additions. I've looked at a couple of greeters - lightdm and gdm - and each of these source these files within their Xsession script.

So, the fix is to just use the same logic in the Xsession script within x2goserver-xsession. Below (and attached) is a patch based on code from the lightdm Xsession script.

Thanks for your attention and please let me know if you have any questions or need any other information. 

-- 
Matthew L. Dailey
Systems Administrator
Thayer School of Engineering
Dartmouth College

--- Xsession.orig	2013-03-25 11:41:16.629002598 -0400
+++ Xsession	2013-03-25 11:54:44.588718173 -0400
@@ -49,6 +49,14 @@
            "<[email-masked]>."
 }

+# Load profile
+for file in "/etc/profile" "$HOME/.profile" "/etc/xprofile" "$HOME/.xprofile"; do
+    if [ -f "$file" ]; then
+        echo "Loading profile from $file";
+        . "$file"
+    fi
+done
+
 # initialize variables for use by all session scripts

 OPTIONFILE=/etc/x2go/Xsession.options

---

From: Mike Gabriel <[email-masked]>
Date: Mon, 25 Mar 2013 22:41:16 +0100

tag #149 pending
thanks

On Mo 25 Mär 2013 17:17:33 CET "Matthew L. Dailey" wrote:

> This can lead to problems if important things are needed from these  
> files, usually PATH additions. I've looked at a couple of greeters -  
> lightdm and gdm - and each of these source these files within their  
> Xsession script.
>
> So, the fix is to just use the same logic in the Xsession script  
> within x2goserver-xsession. Below (and attached) is a patch based on  
> code from the lightdm Xsession script.
>

Thanks a lot for reporting!!!

Patch has been applied to master branch and release/4.0.0.x branch.

Here is the master branch patch:
http://code.x2go.org/gitweb?p=x2goserver.git;a=commitdiff;h=592a66ce229942afce5fe64fc8690f5e5f48848c

Greets,
Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, rothenstein 5, 24214 neudorf-bornstein
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb