Subject: Bug#149: X2Go issue (in src:x2goserver) has been marked as closed

From: Mike Gabriel <[email-masked]>
Date: Sun, 19 May 2013 00:55:40 +0200 (CEST)

close #149
thanks

Hello,

we are very hopeful that X2Go issue #149 reported by you
has been resolved in the new release (4.0.0.2) of the
X2Go source project »src:x2goserver«.

You can view the complete changelog entry of src:x2goserver (4.0.0.2)
below, and you can use the following link to view all the code changes
between this and the last release of src:x2goserver.

    http://code.x2go.org/gitweb?p=x2goserver.git;a=commitdiff;h=d035421386eb85627f23628e69e0c0b07ebb7c8c;hp=6a78a843e29b9169ed7e64735908f308eacd4951

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:x2goserver.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:x2goserver
Version: 4.0.0.2
Status: RELEASE
Date: Sun, 19 May 2013 00:54:34 +0200
Fixes: 103 149 163 200
Changes: 
 x2goserver (4.0.0.2) RELEASED; urgency=low
 .
   [ Matthew L. Dailey ]
   * New upstream version (4.0.0.2):
     - Do parse profile/xprofile files in X2Go's Xsession file. (Fixes: #149).
 .
   [ Jan Engelhardt ]
   * New upstream version (4.0.0.2):
     - Use x2gopath in Perl scripts to set the lib path. (Fixes: #103).
 .
   [ Mike Gabriel ]
   * New upstream version (4.0.0.2):
     - Use make_path from File::Path in x2godbadmin to create user directory if
       not present. (Fixes: #200).
     - Security fix for setgid wrapper x2gosqlitewrapper.c. Hard-code path to
       x2gosqlitewrapper.pl during build via defining a macro in the Makefile.
       Thanks to Richard Weinberger for spotting this!!!
   /debian/control:
     + Let x2goserver bin:package depend on xfonts-base and fontconfig. (Fixes:
       #163).
     + Create session log symlink after launching x2goagent. Fix order of target
       and symlink name when executing the command.

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Sat, 18 May 2013 23:01:20 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goserver package:

#149: Profile files not being sources in x2goserver-xsession

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:x2goserver) has been marked as closed
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Sun, 19 May 2013 00:55:40 +0200 (CEST)

close #149
thanks

Hello,

light+love

---

Subject: Profile files not being sources in x2goserver-xsession
From: "Matthew L. Dailey" <[email-masked]>
To: "[email-masked]" <[email-masked]>
Date: Mon, 25 Mar 2013 12:17:33 -0400

Package: x2goserver
Version: 4.1.0.0

Greetings,

When launching X sessions, x2goserver-xsession does not source the following files:

/etc/profile
$HOME/.profile
/etc/xprofile
$HOME/.xprofile

This can lead to problems if important things are needed from these files, usually PATH additions. I've looked at a couple of greeters - lightdm and gdm - and each of these source these files within their Xsession script.

So, the fix is to just use the same logic in the Xsession script within x2goserver-xsession. Below (and attached) is a patch based on code from the lightdm Xsession script.

Thanks for your attention and please let me know if you have any questions or need any other information. 

-- 
Matthew L. Dailey
Systems Administrator
Thayer School of Engineering
Dartmouth College

--- Xsession.orig	2013-03-25 11:41:16.629002598 -0400
+++ Xsession	2013-03-25 11:54:44.588718173 -0400
@@ -49,6 +49,14 @@
            "<[email-masked]>."
 }

+# Load profile
+for file in "/etc/profile" "$HOME/.profile" "/etc/xprofile" "$HOME/.xprofile"; do
+    if [ -f "$file" ]; then
+        echo "Loading profile from $file";
+        . "$file"
+    fi
+done
+
 # initialize variables for use by all session scripts

 OPTIONFILE=/etc/x2go/Xsession.options