Subject: Bug#1464: x2goclient 4.1.2.2 version does not work with Pageant SSH authentication agent

From: "[email-masked]" <[email-masked]>
Date: Tue, 21 Apr 2020 18:32:19 +0000

Package: x2goclient
Version: 4.1.2.2

With the latest x2goclient version available as of today ( x2goclient 4.1.2.2-2020.02.13 ), user faces authentication error while trying to login using Pageant SSH agent.

The error message received is:
"Access denied for 'publickey'. Authentication that can continue: publickey
Access denied for 'none'. Authentication that can continue: publickey"

The error does not happen with the previous version of x2goclient. Tried and tested with x2goclient 4.1.2.0 and it works fine.

Pageant version used is: Pageant Release 0.73
The client's OS: 64-bit x86 Windows 10
The server's OS: Ubuntu 19.04

best regards,
Saion

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 3 Aug 2020 11:58:08 +0000

Hello,

Any update on this issue?

---

From: Ulrich Sibiller <[email-masked]>
Date: Tue, 4 Aug 2020 13:41:08 +0200

Hmm, might be related to libssh, too (as some other problems are). I
suggest you stay with the old version.

Uli

On Tue, Aug 4, 2020 at 12:18 PM [email-masked]
<[email-masked]> wrote:
> _______________________________________________
> x2go-dev mailing list
> [email-masked]
> https://lists.x2go.org/listinfo/x2go-dev

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 4 Aug 2020 12:12:51 +0000

Thank you for the reply Ulrich! Can you please tell me how long will you support the older version (x2goclient 4.1.2.0) in terms of bug fixes and security updates?

Best,

Saion