Subject: Bug#1459: X2GoMiniSSHBroker

From: Stefan Baur <[email-masked]>
Date: Sun, 19 Apr 2020 15:47:44 +0200

package: x2gobroker
priority: wishlist

Hi everyone,

A while ago, I wrote a small broker demo in bash.

I would like to get this added to X2Go's official repository, in the
x2gobroker.git tree, as a separate binpkg (maybe called
x2gobroker-ssh-mini).

Limitations:

1) This script is not suitable for a multi-server setup.
   It needs to run on the only X2GoServer there is.
   (There's an idea in the comments how to overcome this limitation,
   though.)
   This is, however, also its advantage: You don't need to mess with
   LDAP, postgres and NFS just to be able to use a central configuration
   for your X2GoClients.

2) It does not offer all the ACL options of the "big" broker
   implementations.

Problems:

1) There's currently no manpage for it.  All documentation is in the
   comments in the bash script.

2) IIRC, Alex made some changes to X2GoClient and/or X2GoServer that
   will cause this script to break - however, these changes are not part
   of our stable release yet.  So it should be possible to release this
   package right now, but it needs to be kept in mind that it will have
   to be adapted once Alex' changes make it to stable.
   This was related to more "chatter" about "Access granted" and similar
   status messages being exchanged between server/broker/client.

Script attached.

Kind Regards,
Stefan Baur

-- 
BAUR-ITCS UG (haftungsbeschränkt)
Geschäftsführer: Stefan Baur
Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364
Fon/Fax 0731 40 34 66-36/-35 | USt-IdNr.: DE268653243

---

From: Mike Gabriel <[email-masked]>
Date: Mon, 20 Apr 2020 20:38:27 +0200 (CEST)

tag #1459 pending
fixed #1459 0.0.4.2
thanks

Hi!

X2Go issue #1459 (src:x2gobroker) reported by you has been
fixed in X2Go Git. You can see the changelog below, and you can
check the diff of the fix at:

    https://code.x2go.org/gitweb?p=x2gobroker.git;a=commitdiff;h=752a74133e9423173087f848b53b7133ca3ea1e1

The issue will most likely be fixed in src:x2gobroker (0.0.4.2).

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
commit 752a74133e9423173087f848b53b7133ca3ea1e1
Author: Mike Gabriel <[email-masked]>
Date:   Mon Apr 20 20:37:39 2020 +0200

    contrib/x2go-mini-sshbroker: Contribute Bash script that demonstrate a simple X2Go SSH Broker written in Bash. (Fixes: 1459).

diff --git a/debian/changelog b/debian/changelog
index bbede3b..d89ac2d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,10 @@ x2gobroker (0.0.4.2-0x2go1) UNRELEASED; urgency=medium
   * x2gobroker/defaults.py: Hint that there is a new feature in X2Go: X2Go
     KDrive.
 
+  [ Stefan Baur ]
+  * contrib/x2go-mini-sshbroker: Contribute Bash script that demonstrate
+    a simple X2Go SSH Broker written in Bash. (Fixes: 1459).
+
  -- X2Go Release Manager <[email-masked]>  Mon, 22 Apr 2019 12:31:49 +0200
 
 x2gobroker (0.0.4.1-0x2go1) unstable; urgency=medium